Network Not Working After Update

Hello, I performed an update today that included an Ubuntu base and Google Chrome updates. I used the ‘tail -n25 /var/log/apt/history.log’ command to see specific updates that are applied. I wanted to try downgrading them one by one but Synaptic appears to want to download the packages which can’t be done since I can’t connect to the Internet. In recovery mode I see the below when I scan for broken packages. Is there a way for me to ‘roll back’ the package from the system itself or do I need to download these packages to a USB and load them on? Or is this a nuke and pave situation? Thank you!

Screen shots from recovery

Please provide additional information to help us troubleshoot your issue, for instance:

  • Version of Ubuntu MATE you’re using
  • If you’ve tried using an older kernel from grub boot menu
  • output of inxi -N
  • output of ifconfig
  • output of lshw -C network

Thank you @ouroumov. I should have known better to provide more detail

  • Version: UM 17.04
  • Tried older kernel: Yes, latest is 4.10.0-22-generic. I tried 4.10.0-21 generic
  • output of inxi -N:

Network: [null] Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169

  • output of ifconfig:

    enp2s0: flags=4099 UP,BROADCAST,MULTICAST mtu 1500
    ether b8:ac:6f:ff:f7:9a txqueuelen 1000 (Ethernet)
    RX packets 11 bytes 1089 (1.0KB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0B)
    TX errors 0 dropped 0 overruns carrier 0 collisions 0

    lo: flags=73 UP,LOOPBACK,RUNNING mtu 65536
    inet netmask
    inet6 ::1 prefixlen 128 scopeid 0x10 host
    loop txqueuelen 1000 (Local Loopback)
    RX packets 324 byets 23920 (23.9KB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 324 bytes 23920 (23.9KB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

  • output of lshw -C network:

    descriptoin: Ethernet interface
    product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@000:02:00.0
    logical name: enp2s0
    version: 03
    serial: b8:ac:6f:ff:f7:9a
    size: 10Mbit/s
    capacity: 1Gbit/s
    width: 64 bits
    clock: 33MHz
    capabilites: bus_master cap_list rom ethernet physical tp mil 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autogeneration
    resources: irq:38 ioport:d800(size=256) memory:fafff000-faffffff memory:faff80000-faffbfff memory:fbce0000-fbcfffff

Please attempt the following command and see if it restores connectivity:

sudo dhclient enp2s0

1 Like

Thank you. How long should this command take to run? It’s been approx 5 min. I entered my sudo password and now see a solid cursor on the next line…aaaaaand as I typed that connectivity was restored :slight_smile:

Did this fix a corrupted configuration file? A quick search for this makes me think it is a service that reads a configuration file to set up an interface. The help is appreciated.

This forces your computer to re-negociate with your router’s DHCP server in order to get an IP.
I’m afraid your Solution check may be premature, please try and see if you get connectivity across a reboot.

ah, you are correct @ouroumov, a reboot placed me back with no connectivity.

Can you please check if your network connection settings; under “IPv4 Settings” -> Method are correctly set to “DHCP” ?

yes, set to Automatic (DHCP)

in the Ethernet settings under Device there are two choices:

  1. MAC Address

  2. enp2s0 (MAC Address)

Option 1 is selected. Does that mean anything?

I think it should be choice 2. but unfortunately I’m not in a situation where I can check that. Maybe someone else will chip in.

thanks for trying @ouroumov. at least i have something that can get me running in the short term.

*Well the plot thickens. I show connected to a network but it is a address that is obviously not part of my LAN. I’m still offline.

Hello @jco42,

Did you update 17.04 or did you upgrade to 17.04?

hi @steven. long night last night…so i had ‘updated’ 17.04 but now i think my problem is more system based. When i booted into the installation media I still had no network connection. When i tried to install 17.04 over again i got an error message saying the bootloader couldn’t be written to my disk even though i specified to delete the entire disk.

Strangely though the installation media identified that I had ‘Ubuntu’ on my system but not ‘Ubuntu Mate’ as the option to reinstall it was grayed out. The box is 6yrs old so not too old but not too young either. There had been some text pop up during boot that i thought was normal but maybe was a sign to. Something about no ‘write through cache’…I don’t recall specifically.

I’m in the US so i’m going to go poke around system76 and see what they have. certainly not going back to windows. A new box seems the solution here.

1 Like

Just want to make sure you are aware that 17.04 has DNS issues with some systems. Sounds like you had your network working at one time so it may not apply to you. Anyway, here is a link that explains how to apply a workaround. This also applies to a live session.

This is normal. Any flavor of Ubuntu you have installed will be identified as Ubuntu by the installer. It works the same way in Grub if you have more than one Ubuntu installation.

Good call brother. Me either :slight_smile:

So where are you with your current system? After you reinstalled and the boot loader failed to write where you able to boot your system, or is it dead?

1 Like

@steven A friend of mine is really in to Antegros. I gave that a whirl and I’ve been using it since. I listen to the Ubuntu Podcast and quite a few of the Jupiter Broadcasting ones. 17.10 seems very compelling but I may wait until 18.04 and stick with an LTS. I like the “never having to upgrade” feature of Arch.