New to MATE, trouble with Compiz and hotcorners

Hey there…

So I have been using MATE for almost two months now, and I just love it… It’s THE best distro for me…

But there are things that I’m still struggling with… As a former Apple user, hotcorners (like Exposé on a Mac) are pretty important, but I can’t get them to work in MATE (16.04.1)… They worked just fine in “regular” Ubuntu, but here Compiz does nothing… :frowning:

And there’s also the Audio Volume icon in the top menu bar that doesn’t work… It disappeared once and for all, and I can’t find it! When I right click the menu bar to add it back, there’s no “Volume” in my list of items…
Any ideas on how I could fix these things please?

Thank you in advance…

Cheers! :sunglasses:

Well I haven’t tried hot corners on UM yet, but the volume icon is part of the Notification Area. It also includes the network icon.

Thanks for the quick reply!

But I don’t know what the Notification Area is (sorry), how do I add the volume icon then?

OK, so I took a different route altogether and I installed a little thingie called Volti… Works the same as the usual volume icon…

But I’m still not sure what to do about those hotcorners… If anyone knows the answer, I’m here! :relaxed:

I have installed the paket compizconfig-settings-manager via Ubuntu Software-Center in Ubuntu MATE. So you can set this active corners.

But maybe you would like to take a look at this video before.

Hey Etamuk!

I had compizconfig-settings-manager installed from the start… I watched the video, and that’s what I’ve been doing all along… Exactly as I was doing in “regular” Ubuntu… It worked there, but not in MATE… I really don’t get it! :dizzy_face:

Hi @Nunud,

I’ve never used corners but took a look at that video and setup his first “Show Desktop” exactly as he did and it works fine. Verified all 4 corners work, too.

Some possible differences:

  • I’m running the 16.04 PPA for Mate 1.14:
    MATE Desktop 1.14 for Ubuntu MATE 16.04 is available now
    This is quite an install to commit to, be warned.
  • I did NOT install the compiz-plugins-extra package.
  • I turn off a lot of default stuff, change the switcher, and enable the cube. I use compiz mostly for the Zoom.

Make sure “Mouse position polling” is on. I’m sure it needs it and should force it on but you never know.

Hello @Nunud,

i have made for you this video.
See here.


I’m sorry, but I don’t know what most of those things are! :expressionless: :worried:

I thought MATE was a distro like any other one, so I only know about 16.04, but I’ve never heard about 1.14 before!

Also, what is Mouse position polling?

Thanks for taking the time to make an actual video man, but honestly, that’s exactly what I have been doing… I already used to have all this on regular Ubuntu before moving to MATE… So I know the procedure, it’s why it doesn’t work that I don’t understand! :no_mouth:

1.14 is the version of the desktop environment, so UbuntuMATE 16.04 = Ubuntu 16.04 - unity desktop + MATE desktop 1.14.

The new UbuntuMATE 16.10 has MATE desktop 1.16

Oh OK… Then I must have 1.14!

OK, one step at a time. Your Ubuntu-Mate version is 16.04.1 as you mentioned originally.

This means, unless you did something special, your Mate version will be 1.12. Mate has its own version and every distro that uses Mate relates to some Mate version. The brand new Ubuntu-Mate 16.10 was just released with Mate 1.16.

Like Firefox is version 49.0. Same concept.

But don’t make a guess… In the main menu: System -> About Mate you will see it first hand as 1.12, right?

Now… in CompizConfig Settings Manager is that Mouse Polling I was talking about. It’s one of the settings.

Just clarifying. :slight_smile: