No sound output/drivers HDMI or analogue - Raspberry Pi 3 - only with Ubuntu MATE installation

Hi Ubuntu Mate Pi users,

Thanks for any assistance. I’ve been running MATE Desktop environment 1.10.2 (img 15.10.3) on a Pi 3 for about two weeks (I’m pretty busy so haven’t had much time to problem solve) and have noticed there is no sound output whatsoever. I do not have the same issues with Raspbian and Openelec on the same device. Very puzzling.

I am a relative newcomer to Linux/ubuntu systems and can call up basic commands using terminal. I installed a bunch of ALSA Gui and sound control applications (such as PulseAudio Manager) on this installation of Ubuntu Mate but none of these applications offer me any ability to route the sound using different drivers for the Pi. I’m presuming the bcm2835 ALSA is the sound hardware the pi 3 uses should be recognized by Ubuntu to play sound from start up. There doesn’t seem to be a way to search for a more compatible driver or device. I also followed some instructions I already found on this forum for editing the HDMI config settings to boost sound and keep hotplug on, etc but this did not solve the problem.

So, just to clarify, I am getting no sound at all (system sounds, media playback, audio streams etc) when using Ubuntu MATE - from either HDMI AND audio jack. The system sound preferences shows playback occurring in input - but absolutely none of this comes out through headphones/amp/mixer at my end through either the HDMI or audio jack outputs from the Pi. This is even more strange as the sound works fine using boot images of Raspbian and OpenElec using the same Pi 3 - meaning, this is unlikely to be faulty hardware.

I’d also like to specify, I prefer my audio to output through the analog jack as I use several systems through a mixing desk in case anybody wants to help me configure sound on this little system.

Thanks in advance for any light you can shed on this issue I’m having.



Hi Sab,

take a look at: "Hardware accelerated video" which you will find here which might help?:

Thanks for your assistance wolfman.

I used amixer to reconfigure sounds to the jack but there is still no sound. I will post this as a bug to the team and get an earlier disk image of Ubuntu Mate to image. Hopefully my feedback will assist in more stable versions of MATE on the Pi 3 in the future.



Edit: Aha - finally some sound! I used: sudo amixer cset numid=3 1 for the third time and sound is now registering through 3.5mm jack. However, once I exit terminal, sound is stopped. Would I edit boot/config.txt to reflect the changes to make them permanent? Thanks again dude

The commands: sudo amixer cset numid=3 1 and sudo amixer cset numid=3 2 seem to be quite unreliable. Since editing my post I have now lost sound again.

I have found that I can force the system to play sounds by opening sound preferences/hardware and choosing to test speakers (alternatively running aplay /usr/share/scratch/Media/Sounds/Vocals/Singer2.wav) I also have had to re-run the amixer cset commands several times to get any response. Sometimes, there is no response, even after a few minutes.

I will try a re-boot to see if there is a change. Hopefully the details of my problems will be of some assistance to someone.

Hi sab,

I have the same problem like you. How did you fixed it?

Many thanks in advance,


Same here and I’ve tried the same config.txt command changes mentioned above plus the audio settings included in Ubuntu MATE.

Any suggestions? And I am a Raspberry Pi/Ubuntu/Linux nube so please speak slowly. :slight_smile: