Non-qwerty keyboard at login?


#1

Hello,
I happen to have two different U-Mate laptops, which were preloaded with the very same version 16.04LTS by the hardware supplier some months ago. The difference is, one was with a ‘regional’ keyboard (french keymap), the other kept a standard QWERTY one. I did start them almost alike, we used them alike too, and now my hardware supplier did receive the french keyboard for the second laptop, and sent it to us.

After the delicate operation that a laptop keyboard switch does represent for me, I discover that when logged, I can set the keyboard to whichever mapping I want in (surprisingly) two separate ways : one via Control Center > keyboard, and an apparently entierely independent thing in the general menu, called iBus. But well, when both are set to french, the french keyboad actually works, including for entering password if I lock the screen.

Now, things begin to be interesting when I reboot : at that moment, the keyboard is still considered a standard QWERTY one. This whatever I do in Control Center and iBus.
This situation is all the more bothering me, that on the other laptop -the one that came factory-mounted with a french keyboard, the login password definitely respects the french mapping.
And of course : the faulty machine is that for my S. O. :smiley:

So… any advice on that one would be more than welcome! :wink:


Problems of logging in
#2

Hallo Herve

Go to System > Control Centre > Keyboard, select the tab “Layouts”.

I suspect you will find both your French layout and the QWERTY layout listed. If so, follow the instructions below.

Select the QWERTY layout and click on the “Remove” button. Close the dialogue window. Close down everything else and shut the computer off (I recommend completely).

Restart the computer. Has that solved the problem? :slight_smile:


#3

Thank you AlpineJohn!
Indeed I went to that step but didn’t dare to just erase the QWERTY yesterday, although later I discovered it is not present on the other machine.
I’ll do this as soon as I get a hand on the machine, this evening, and report :slight_smile: .
Thank you!
Hervé


#4

AlpineJohn : I tried the process you describe. There is no QWERTY layout any more. I turned the computer completely off then on, twice.
But at login, the expected layout is still Qwerty, and moreover, on the login screen, there is still a small icon reading "EN" that, when clicked, only gives access to a single menu item reading "english" (in fact, reading "Anglais" which is the french translation for "english") -see the attached picture...
Clicking on that menu does not change anything.


(edit) -on 'the other machine' -the one delivered with a french keyboard from day 1- the same tiny menu at boot reads 'Fr', and reads 'Français' (french) when deployed. But I definitely don't know where this 'login menu' comes from...


#5

Hallo Herve5

I’m slowly coming to the end of my advice. If I were in your situation I would now reach for the ultimate remedy for Linux problems - I would re-install the entire system from scratch. You may or may not want to do that.

Good luck what ever you decide. :slight_smile:


#6

I cannot reinstall easily. The Tuxedo computers come with an USB key that in principle would allow just this, but when triggering the boot selector menu (or whatever its name) at boot time, the only boot sources I see are the two HDs, no USB being possible. And as Tuxedo seems to arrange their distributions by adding all necessary drivers etc. I see no easy solution…


#7

Hallo Herve5

“Boot selector menu”. Have you entered the BIOS when starting the computer and enabled boot from USB?

If all else fails… Tuxedo. If you speak German give them a call. If not write (you may want to include the posts in this thread, I don’t know who has the copyright though) in English. They must be able to help you.

I suspect that during the installation process something was “set” at a level where only the very knowledgeable would know where to find it. Doing a fresh install would be a way (hopefully) of resetting that “flag” with the definitive, French, keyboard already in place.

If you’re worried about loosing the special Tuxedo-drivers, they have a part of their Website where you can download such things, although I don’t know if you could obtain all the drivers you might need there.

Link:
https://www.linux-onlineshop.de/forum/index.php?page=Board&boardID=22

You have one machine that works correctly, it must be possible to get the other to work correctly too. :slight_smile:


#8

I tried some testing in the terminal : I see that when asking for the “locale” I get something different here and on the “other machine that works”:

~$ locale
LANG=fr_FR.UTF-8
LANGUAGE=fr_FR:en_US:en <–THIS is different from the ‘good’ machine, where I only have ‘LANGUAGE=fr_FR’
LC_CTYPE=“fr_FR.UTF-8”
(etc. with everything else properly set to FR.UTF-8)

But when I try to somehow reset this by asking sudo update-locale LANG=fr_FR.UTF-8 , the ‘locale’ result does not change…


#9

I wonder if you should have changed LANGUAGE instead of LANG?


#10

Alas, just tried : no change either…
I am back from my trip though : I’ll be able to write directly to Tuxedo asking for support…


#11

For future people searching the same :slight_smile: :
I was given the final solution. From a terminal, type:
(your account):~$ sudo localectl set-x11-keymap “fr”
or better
(your account):~$ sudo localectl set-x11-keymap “fr” “” “oss”


#12

Hallo Herve5

Thank you for posting your last piece of information. :joy:

I’ve just upgraded my main system from 16.04 to 18.04. It was a fight (the bootloader broke).

When I had 18.04 up and running the system registered my keyboard as “QWERTZ” (with some special signs) - but - the logon screen still thought it was a standard “QWERTY” keyboard. Once running, the keyboard was then recognised as “QWERTZ”.

I applied a “fix” that I had previously found. It did not work. I then applied your:

(your account):~$ sudo localectl set-x11-keymap “fr” “” “oss”

replacing “fr” with “ge” for German. This solved the logon keyboard problem. :relieved:

I had one more keyboard problem though, the sudo password (terminal, synaptic, etc.) still thought I was running a “QWERTY” keyboard. I solved this by entering user-accounts and resetting my password.

Merci :penguin:
.


Installing Ubuntu-Mate 18.04 - what to do if the bootloader breaks
#13

Wow!
I myself was considering upgrading from 16.04 to the new 18 LTS… Maybe I’ll wait a little then!
Thank you AlpineJohn for this post and warning!


#14

Hallo Herve5

See the good news - how Ubuntu-Mate fixed the broken bootloader for me:

A further warning - there seems to be problems with the version of JAVA included in the 18.04 base. If you run JAVA-dependant programs beware… :confounded:

Edit (04.09.2018)
This is a link to the post I made explaining how I was able to get my Java-based programs running again:

This did not fix all my problems though, pdfsam will still not launch. As pdfchain has also been caught out by the new technological base of Ubuntu 18.04, I currently use Master PDF Editor for pdf manipulation.
Despite all the good work done by Canonical and the Ubuntu-Mate team, if you use Ubuntu-Mate 16.04 in a “production” environment i.e. you use it to earn your income (or a part of it) I would currently advise caution, and waiting to upgrade as long as you can, preferably setting up a test system 18.04 to make sure you know what will happen to your regular tools. :slight_smile:


#15

@alpinejohn To fix pdfsam, you might run the following command and choose the oldest version you have.

sudo update-alternatives --config java

Test pdfsam and choose another version if needed.

Good luck alpinejohn.


#16

THE KEYBOARD PROBLEM

THIS SOLUTION WORKED FOR ME - BUT I ONLY USED IT AS A LAST RESORT…

###BE WARNED - IF YOU GET THIS WRONG YOU MAY EFFECTIVELY LOCK YOURSELF OUT OF YOUR COMPUTER !

###BEFORE YOU BEGIN

###(i)
Backup all your data.

###(ii)
Make sure you have an installation medium with Ubuntu-Mate 18.04 available. If you lock yourself out it may save you. The procedure in that case would be to boot from the installation medium and start a “live session” i.e. running from the system on the installation medium (I used a DVD). Using the “live session” you can try to access your “keyboard” file and hopefully restore it to its initial state. However, if you have encrypted your computer’s drive this may well not work.

###(iii)
When you get to step (B) below make a note of your current file contents before you make any changes.

###(iv)
If you have a similar computer where everything is working correctly, look at the settings in its “keyboard” file. Then see if the settings on the computer that does not “recognise” its attached keyboard (step [B] below) differ. This is what I did, and even though my keyboards are different, the “copied” settings worked.

####THE KEYBOARD FIX

A)

go to the directory

/etc/default

B)

open the file

keyboard

The file should be set to read thus:

XKBLAYOUT=“ch”

XKBVARIANT=""

BACKSPACE=“guess”

XKBMODEL=“pc105”

XKBOPTIONS=""

Change the file contents if necessary, particularly the “ch” bit. This is for my “Swiss” keyboard layout, I imagine a French layout (AZERTY?) would be set by replacing “ch” with “fr”. DO NOT SET MORE THAN ONE LANGUAGE. That is how I locked myself out of my computer! :cry:

The “pc105” refers to my Logitech K120 keyboard layout. This is about as basic and standard a keyboard as you can buy. Your situation may be different.

C)
Save and close the file.

D)
Close the file manager.

You can now try to reboot the computer. Either it will work or you will probably be “locked out” because the keyboard recognised by the computer will not be the same as your actual keyboard and you will not be able to type your password.

REQUEST
I would be grateful if one of the highly knowledgable members of the community would look over this post and confirm/correct the information presented here. Thank you.


#17

Hallo mdooley

Thanks for the advice.

I decided to set up a virtual machine running openSUSE Leap15 with the KDE desktop. There I use the Qt based frontend for pdftk. In conjunction with a “shared folder” between the host and guest it is a valid “work-around”. :slight_smile: :penguin: