Not seeing Windows network?

Fresh install off 16.04, installed Caja & Samba & Samba GUI, not Mate only sees the network when it feels so inclined…
Is there a correct procedure to get all this installed and see the Windows network? And yes everything is shared correctly, my other 16.04 machine does not have this issue, driving me crazy, none of this was an issue prior to 16.04

There is a major problem with Samba, in my experience in 16.04. I initially went back to 14.04 in frustration. However, it seems that some of the “improvements” in 16.04 have been “backported” (or whatever the term is) to 14.04. So, 14.04 is now borked with samba as well. However, this is not merely a problem with Ubuntu Mate or, even, Ubuntu. It is all derivatives of Debian. I have tested this in several such derivatives as well as Debian itself and the story is the same. Samba is buggered at the moment. It may even run further back that that and be a Linux bug running in the latest Linux Kernel. I have read of this issue with arch as well. Though, have not tested it recently to be sure.

The first issue is the damned thing just hangs when trying to access a samba share. Secondly, there is a nasty little bug called gvfsd-smb-brows that causes the CPU to run hot as hell at 100% usage. There is a fix for this that stops this bug operating. But, unfortunately, this causes samba to be completely inoperable.

For myself, I have got round this by completely disabling Samba and using ssh for networking. But this is because I only need to access other Linux machines. I don’t know if ssh can be used to access Windows machines from Linux or vice versa.

Hopefully someone more knowledgeable on here can come on and confirm that.

This looks promising:

1 Like

Thanks for verifying, this is making me nuts, I shall look into SSH, Joe Collins posted a tutorial recently.
Got so frustrated this weekend with it I downloaded ArchMid, which I probably have no business being on but it’s a great looking distro, and fast as all get out, never been a fan of XFCE but…
I have run into these issues on all 16.04 releases, no wonder the Zorin camp has not issued new distro. Constant error messages also. How did this go so wrong? Why is networking so hard, I set up a mac this weekend, first time, connected straight to my network, all these woes are forcing me back to Win 7 on all my boxes, that’s sad but work to do.
I so want Linux to be my computing savior but alas it is looking like, unless I just want internet access, it ain’t gonna happen, no way I can just ditch n’ move…Say it ain’t so Liinux!!

For a good intro to using ssh, see here:

I’ll give it a shot when I get home, my main issue is that I need to share/stream between Linux & Win, not sure SSH can do that, maybe a Nitroshare type of software will allow music/movie streaming…

Streaming from Linux to MS Windows is, occasionally, exactly my issue as well. I’m going to install the latest Manjaro (Arch derivative) on another partition on my main rig today and see if the network issue is present there or not. I will report back here and let you know.

Oddly enough, I did that on another laptop just yesterday, I think you will find that it is. when I tried to share folders I got an .smb error, and on browse network it never sees windows, now maybe I need to install something, as I am not as familiar with Manjaro but my initial was…WTF!

Just had a go at installing Manjaro Mate. What a mess!

Manjaro Mate 15 had to be pulled in December 2015 because it was such a mess and had multiple bugs. Manjaro Mate 16.08 testing has just been released in GTK2 and GTK3 flavours. I have just installed them both. The GTK3 version is completely messed up in terms of themes. They don’t display properly at all. Furthermore, both the GTK2 and GTK3 versions have the gvsfd-smb-browse bug.

So, this is Linux wide and so must go back to the Linux Kernel itself.

Wondering if I should move back to 17x until all this blows over, are there any distros that are not jacked up?

I don’t think there’s any supported distros that are not affected.
Thing is, this started happening following a shamelessly hyped security vulnerability in samba, people panicked and fixed stuff that affected organizations running samba servers on local nets already compromised by attackers, and since then a bunch of things broke.

Bummer, are you aware of a fix, or an alternative to use for streaming Win & Lin?

Okay, for an hour or so there I thought I had it licked. there is a downgrade function in Arch that allows one to downgrade to an older version of a given program. So, I downgraded Samba and, for a short while it seemed to work. Then I logged out and back in and it gvfsd-smb-browse came back even with a downgraded Samba!

So, god knows what is going on

Bummer, I was excited, momentarily, there…

Have a great day… unless you’ve made other plans !

Checked both my UB Mate laptops, apart from one being Hp & one Dell, everything is the same, bar maybe Broadcom driver on Dell, both Samba 4.3.9, both kernel, both 16.04.1…HP works fine, dell not

I can go from Win to both machines regardless, the HP stills asks for a password that does not exist, no option to connect anon

One thing of note, on my HP, where Samba is currently working, there is a .smb folder in Home folder (hidden), on the Dell computer that is not working, there is no such folder.
So, I copied the .smb folder from said working laptop to non working, rebooted, dropped the proprietary Broadcom driver I had been using on non working dell, and bingo, it now sees the network, had to leave for work, so I have got no further, I had not got to the point where it would ask me for password to connect etc., shall investigate further once home.

Well, that worked, it is now seeing all network, Windows included, still asking for non existent password, guess i may be forced to password my Win box to stream, oh well.
Networked two Linux machines Mint cinn 17.3 & The ub mate 16.04.1, connected both anon, both sharing.
So what did I do: I copied smb.conf file from working Mate 16.04.1, created a folder (hidden) on home drive called .smb, dropped file inside, rebooted, voila…will it last, who can saybut its happening as of now. Be happy to email you the file if needed, tried to post here but banished file type!
Now if i can just figure out where .smb is on Mint 18 maybe i can see if fix works there

Check updates, got it going…

So, did this stop the gvfsd-smb-browse bug?