Persistent ImageMagick (color depth=q16)

Ubuntu 20.04.1: In Preferred Applications for Mate, in the Office tab, I change the Document Viewer to Atril Doc viewer but it never stays. It changes back to ImageMagick as soon as I close it. This is very annoying as I can't just click on a doc and have Atril open it. ImageMagick splash page opens. But it rarely if ever opens the document. I don't want it to either.

I need to keep ImageMagick because I use the Term commands it supplies all the time. I take thousands of pictures every year and using Term, bulk resize them using Mogrify command. If I uninstall ImageMagick, that command disappears with it.

How do I get ImageMagic to NOT be persistant? If this isn't where I should be asking this, let me know.


Select one of the documents that you want to open with Atril. Right click on the document and select Properties. Select the Open With tab. Here you can select what you want to open this type of document with and if you don't see Atril as an option, you can add it. You can also remove apps you would never use to open a document (of this type) with.

Good luck @JimHiTek

Edit: After doing that, Atril should stick in Preferred Applications,

I am aware of that work around. I'm looking for a fix.

See, I've set Mate to open Atril as the default doc viewer but it doesn't do it like it should. So it's like a bug, or there's something somewhere I should have check marked but didn't. Or it's a bug in ImageMagic. I don't know which. So far, out of 10's of attempts, Atril NEVER stays as the default like I request.

This is not a work-around, it is the way to get Atril to 'stick' as your default document viewer. Please read my post above again.

Nope. Doesn't work. I click on the radio button and it doesn't change the green ball from ImageMagic to Atril. Highlighting IM and clicking the 'remove' doesn't do it either.

Thanks for helping though. I do appreciate it.

What kind of document are you working on?

So far it's only been PDF's, several, where this happens. DotX, ODT, .doc, are all opened by LibreOffice.

So here is what I did. This shows before changing properties on a ,pdf file.

And this shows after.

And as far as I can tell, removing ImageMagick does not uninstall it. Please show me yours.

See how Atril is highlighted? When I click on it, the green ball stays on IM. If I highlight IM, and click -Remove, nothing happens. I can show you the view of Preferred Apps and I can change it to Atril but it changes back to IM as soon as closed...

You should click in the circle next to Atril and then close properties. Then double click on any .pdf

While you're at it, highlight Brave (the best) and click on Remove. Brave is entirely too much in what it wants.

Of course I've clicked on the CIRCLE. Nothing happens. The page pulses, but the green ball doesn't change places.

I don't have any help for you. Even after changing the owner of the example file to root, I was able to change what it could be opened by. Sorry...

Right click, left click, double right click, double left click? Nope, it is always a left click unless you've set your mouse/touchpad differently. I'm going to try to add IM and then see if I get your situation.

Edit: I could not get Image Magic to open any .pdf file. Does clicking on Reset do any good?

Does clicking on Reset do any good? Your situation seems quite weird.

No. Clicking on 'Reset' does not allow changing the 'Open With' selection.

I went looking for solutions and bug reports. First see -

an old bug. But a good hint is found in the last comment.

It said - I saw a similar problem in 16.04 with PDFs being opened with ImageMagick. Trying to open With Document Viewer and set that as the default made no change. I saw in mimeapps.list that there was both an image/pdf and an applications/pdf entry. I removed the image/pdf entry that pointed to ImageMagick, and left the very last entry in the file, which was the applications/pdf entry with Evince.

Try renaming your home/.config/mimeapps.list to mimeapps.list.disabled. Log out/log in and see if you can now change Open With.

And solutions. Please see -

where someone has a similar situation. Try the first answer. Open a terminal in the directory where you have a .pdf file and enter this -

mimeopen -d yourfile.pdf

You should see something like this -

Please choose a default application for files of type application/xxx

This immediately opened the document in Atril. Good luck JimHiTek

Already tried the 2nd suggestion and it didn't work.

Searched for mimeapps.list and there are 11 of them...none of them are in the /.config directory. In fact I can't find a /.config dir.
Starting at /home, I do a dir and it shows jim_hitek only. If I back up one dir to / , it shows 25 dirs but no config.

Because of the leading dot, the .config directory is ordinarily hidden. Change your caja preferences to show hidden files and directories.

Changed it but still not showing up. Might have to reboot. Time to cook dinner so will work on it later or tomorrow .

Nope, rebooting didn't help. Opening /home as admin doesn't do anything either.

GOT IT! Changed the file manager from Caja to Files, configured it to show hidden files, and there .config is. So I'm off to try that other suggestion now.

Don't have a mimeapps.list file in that dir so did a search and found it somewhere. Chging it now...will test.

FIXED Followed this instruction to rename this file: home/.config/mimeapps.list to mimeapps.list.disabled

I can now click on PDF files and they open in Atril instead of the ImageMagik splash screen opening.

The default for PDF is now Atril.

I'm changing my file manager to 'Files' too since Caja didn't change to show hidden files as requested.

I don't know how many other items this changed yet but I'll keep my eyes open.

The mimeapps.list file will be automatically generated as you select which app should open which file type. Glad to hear that you are back on track. Which version of MATE are you running by the way?

Have no idea which Mate it is. How do I find that?

Found it! Mate 1.24.0

Got distracted when an egg in the MW blew up.