Pinta and updates

Just wanted to ask if you know if Pinta will be added again to the software boutique, and if you also have the problem that when running Software Updates.
I always get the message that it failed, but when I open the settings and close them, then it works and updates are found/installed.
I also would like to give some money, but have no PayPal account or bitcoins. Is there an ordinary bank account in the UK where could transfer to?
Thanks in advance.

Pinta has not been updated for three years, I say its gone for good.

Need to know what the update failure is, the error code. Maybe running updates in terminal would provide this information.

sudo apt update && sudo apt full-upgrade

1 Like

Thanks m1804.
I didn't know that Pinta is legacy. Thanks for that.

I mean this one.

I then click on Settings button.

These are my settings.

I need to keep an eye on this. I get the impression that I download everytime the same, but I need to check that the next time. I'm probably wrong.

Hi @Newhere,

I don’t know about Pinta but you can get it from here if the need arises:

https://pkgs.org/download/pinta

As far as upgrades go, take a look here:

:smiley:

I stand corrected. The Pinta site has not updated the package, but ubuntu maintainers has it available for Bionic.

https://packages.ubuntu.com/bionic/pinta

Thanks Wolfman :slight_smile:

Maybe @wolfman can help with your connection problem. Its time for bed on this side of the pond :slight_smile:

Be back tomorrow

Hi wolfman
Have already tried Pinta but it crashes. Never mind. Gimp is okay even I struggle with a lot of issues there (have nothing to do with UM).

I liked Pinta because it didn’t look so cluttered as Gimp and works like a normal photo-editing program. Seems that Gimp is the compromise I have to make. :wink:

Same experience here with Pinta over the last 1year and a half on Ubuntu MATE 16.10, 17.04, 17.10. It works ok with very small images, but with bigger images it is very slow and crashes very frequently.

I like the idea of “Pinta” because I was and am used to work with “paint.net” - perfect for drawings, png files, icons, etc. - quick and easy with a lot of possibilities but not the “overkill of features” from Photoshop / Illustrator or Gimp.

I have a Win10 installation in VirtualBox for “paint.net” and with shared folder and clipboard, the perfect workaround for me.

Hi @Newhere,

did you try the .deb package I linked to above?.

Have you checked out the update guide as well?. :smiley:

Hi wolfman
Just tried your version. It’s the same 1.6.2 which I tried before. It doesn’t work as it did in 17.10. It also crashes for example when I use Levels.
Doesn’t matter. Pinta wasn’t great either, but for the simple steps okay. I can live with Gimp and will get used to it.
Thanks for the tip.

Regarding the Software Updater, the updates themselves work fine, it’s just this little step in between that I didn’t have with 17.10. But I’m still in 18.04B2 (I hope so, don’t really know where to check this as I’m new to Linux and one of the damned Windows users who got rid of Windows :slight_smile: )
All together, I’m very happy with my UM, works great so far.

[Update] Just checked your useful tip to look into Software Boutique. It’s all up to date, all broken packages were fixed (can’t have been many, took only 2 seconds).

Danke schoen.

This is the error I get

Err:9 http://ppa.launchpad.net/pinta-maintainers/pinta-stable/ubuntu bionic Release 404 Not Found [IP: 91.189.95.83 80] Ign:10 http://repo.vivaldi.com/stable/deb stable InRelease Hit:11 http://repo.vivaldi.com/stable/deb stable Release Reading package lists... Done E: The repository 'http://ppa.launchpad.net/pinta-maintainers/pinta-stable/ubuntu bionic Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details.

Hi @Newhere,

a "404 error" means that the link doesn't exist so you can safely remove that PPA for Pinta from your sources list!.

Highlight the Pinta PPA in your sources list and then on "Remove":

:smiley:

Excellent, wolfman. Removed Pinta and eh voila, the Software Update works suddenly. Was probably a broken packages that I fixed in Software Boutique.
This made my day: I discovered Virtualbox. You cannot imagine my joy!

Yesterday, I looked with a different browser the donation part and discovered on the PayPal page that I can pay with my card directly.
All questions are answered.

I will now start reading the PDF about UM that I found in the system and go through your tips and tricks.

Thank you all so much. My private computer life got a new sense!

2 Likes

Just an additional information for all new beginners (like me). I discovered a tiny icon Boutique News in Software Boutique. It’s next to the Search button on the top right side. If you scroll down, then you can find the information that Pinta was removed in Boutique version 17.10.17.

1 Like

Pinta has not been updated for three years, I say its gone for good.

It may be a bit dated but it is still a heck of a lot easier to use than GIMP.
Unfortunately there are not a lot of other good choices.

You can install Pinta from Synaptic Package Manager
Hint: Use “software boutique” to install Synaptic Package Manager

“software boutique” is missing so much that about all I use it for is Google Chrome and Synaptic Package Manager