Please assist with this networked printer installation?

I am helping a friend transition to Ubuntu Mate at his small office - and for the most part things have gone quite well - except for this one:
He has a rented multifunctional copier that is a Canon iR-ADV 4025 and it is networked.
I cannot get it to work with Linux.

Under windows the driver for it at that IP was very easy to set up, but I have run into the wall trying to make it work for him under Linux.
It is recognized, and there are driver choices, but I haven't got the knowledge or experience to know how to accomplish this feat.

Open searching did not help me either, sadly, though I found lots of info like this:

After going through the setup several times it became obvious that all I could get it to do was to create an error message at the printer that had to be cleared before it could do anything else.

I am hoping that someone here knows the correct method to get this working & will please guide me as I will need to travel to that area again in the near future for my own needs and will stop in to see him while I am nearby.

Thanks for any help & guidance !!

Windows is for consumers, without too mach knowledge regarding PC, everything is easy and default.

Settings in Linux is not as easy, as in Windows, because Linux Is for advanced users, sometimes you need even weeks to learn how to properly configure a software in linux, is like learning how to use a software in windows.

I can't help you here, maybe someone else, if you have a luck, or try googling more for your problem or... on my printers no problems (using default mate install configurator), on one advanced scanner to work on Linux I needed a paid software, witch found inferior those one that came with the scanner for windows, so just simple I switch to Windows, there I can scan 30-60 pages per minute, so maybe in the future I have better support for this scanner on Linux, or maybe not..

Thanks Again Mircea !!
I am quite comfortable with most Linux issues - searching & locating needed answers is actually easier for most issues IMO - but this one has eluded me.
Windows was OK with me until XP took the place of win2k, and then I chose to get done with that 'family' of OSes as their newer ones were too painful to even look at - let alone to be a user of them.

There must be a sort of generic procedure to install such a printer/driver in Linux - but I simply didn't find it - so I'm asking here & hopefully someone will pitch in with a pointer to it.


I searched the gutenprint online printer database but had no luck for 4025

but there are PPDs found here

Naturally you will need to have installed cups and avahi

there is another option but it might need a compile

Looking at this page there appears to be an error?
the page shows
a driver for Kernel 3.70
a tarball for compiling....might be the best....more below
a RPM packaged driver
a deb packaged driver...that claims "packaged in the RPM format"
a driver for Kernel 3.10

Now because the openprinting site claims its PPD works 100%
download and try that one with Cups first

Then the other PPDs from openprinting

If they all fail.....then try the DEB download and if that fails
try the tarball -> unpack it and compile it.
Note you will need to re-compile on each Kernel upgrade

Welcome to Linux and good luck

From your last reply?
so did you download a PPD or not

dl link should be

Thanks for your helpful reply Aus9 !!
I too found that PPD as noted in the OP, but must have done it incorrectly as it only brought errors at the printer.
Also, I did not find any good directions for how to set up a PPD, just things telling me to do it - and that may be where I screwed it up ??

Thanks Again.

hmmm Ok try these steps and tell me if you can follow them or not

open web browser to
click on add printer do not click on FIND new printer
popup should appear, enter your login name and password
(I have a wl printer different model to you)
web page should offer you options of
local printers (USB cable)
discovered network printers (true for me)
Other Network printers.....meaning not discovered

^^ tell me which is your result here please

Next click against your printer (if found) and click continue
Next screen is trivia like name location details but
click on share and continue

Now see image

EDIT forum truncates image

this is where you click on the PPD and browser to where ever you dl

the rest of the steps I assume you can work out yourself

Sincerest Thanks Again Aus9 !!
I am about 90% certain that I did that or something like it before with that error resulting, which made me think the driver was incorrect.

What info as I have points to the printer as an imageRUNNER ADVANCE 4025 - without the 'i', for whatever that may be worth ??

Though I do have remote access & can do this via that, I am ~120 miles away & have no way to see if the printer responds correctly - or even if it has been powered down for the long weekend here.

Adding to the above, the man himself is out of town for a few days - so I'll need to wait for monday afternoon when his assistant is there to make another try.

What else I do not grasp is what role Avahi may fulfill in this process as I do not recall ever using it before ??

Thanks Again.

What is stopping the other person from joining the forum and giving a reply?

the questions I ask....might be quicker if he answered?

q1) What does he see in cups admin page in his web browser
local (USB) and so he connects with usb cable
Discovered network.....either a wireless printer or an ethernet cable to router to PC
none of the above.....and we have to choose a protocol

It appears there are 2 PPDs from my ppd link
one shows ModelName: "Canon iR-ADV 4025/4035 and Release version 3.05 2011

While the other shows ModelName: "Canon iR-ADV 4025/4035" and does not appear to show a Release version but mentions foomatic-rip
---which should be installed at /usr/bin

so Q2) What is the result of
$ dpkg -l | grep foo
$ dpkg -l | grep cups
$ dpkg -l grep avahi

ahh now if he is only using need for avahi to be found IMHO
avahi is Microsoft/Apple bonjour or wireless type discovery

but if he is using Ethernet cable.....he may have to setup manually
I don't own such a beast but he should be able to go into his router
and find out the full IP address


there is an example of an address he might have to manually setup here
and that link is supplied in case our GUI way fails and he resorts to commands

Which leads to Q3)
post the exact wording of the error message

He can go into his log ....upload it and paste a link to it if he is not sure what the error means
or not sure what part of his log is showing the error
or he has multiple errors etc etc

You can get your drivers from here - down toward the bottom of page
Extract the contents you will have a folder called "linux-UFRII-drv-v340-uken"
open that folder and open a terminal inside that folder and type in "sudo bash ./" to install the drivers - once installed reboot with printer plugged in and on then go to your settings-printers and see if it is detected

Hello Again Aus9, and thanks.

A valid query:

[quote="aus9, post:8, topic:19827"]
What is stopping the other person from joining the forum and giving a reply?

the questions I ask....might be quicker if he answered?[/quote]

With a very simple answer:
I am a retired technophile with enough time available to help my old friend who is a true technophobe.
His expertise is in another area entirely - for which he uses a handful of different softwares, and that is all.
Asking him to describe this situation would be the same as asking my grandmother (who had never used a PC at all) the same question - she'd just look at you funny & say 'why doesn't the printer print ?'

I am totally fine with helping him - and will continue to do so when there is a body in his office to verify the printed output, or lack being 120+ miles away prevents me from seeing that small detail.

Thanks !!


additional questions comments

I do not do remote control nor have any experience of it.

Can you advise if you can do non-printing things successfully thru remote control?
What is the name of the software app you are using to do this?

I am wondering if its not the printer error per se...but some setting to do with remote control?
In addition, if it is a remote control issue.....he may be able to print locally.

Also, is your friend wishing to .....allow internet printing and maybe have you send a print job to his printer.

I do not want to weaken his firewall....but have you set up his sofrtware firewall?
In addition, do you know if his router is using it's firewall?


Hello Again Aus9 & thanks for replying.
My 1st try at this printer problem was when I was there in person, several weeks ago, and I did not succeed, which is why I asked about it here.
I did not get to do the test today as I was down with a fever until tonight, so hoping to catch his assistant there tomorrow & test it then.

Details as you've asked:
I made a totally separate firewall machine for his office which is the portal through which I have secured access via OpenVPN.
Not the easiest thing ever to set up, but well worth the effort.
It updates the IP to one of my domains (like dyndns...) as this just uses his single ISP connection, which does not have a static IP address.

I use UltraVNC Viewer as well as the free version of Anydesk as a backup way to get in.

These work very, very well & allow operation of the remote PC about 99% like you are actually sitting there, with the exception of being dependent upon connection speed so there can be delays in screen refreshes.

Printing just means opening up a file in a program & telling it to print, or using the test page offered during printer set up.

With my access I can do most anything just as if I was there - with the exception of being able to physically see the networked printer's screen or any ability to re-start the printer to clear resulting error messages on said screen !!

Many folks lean towards Teamviewer and such like it, but I find that those are very limiting as well as messy in terms of the trashing they tend to leave behind at both ends which needs to be cleaned up religiously - also, Teamviewer is a PITA in terms of having exactly matching versions, which is truly tiresome.

Thanks as I said I don't do remote

Additional Q ...Can you use his local login name and password to get to the Cups log?

Hopefully that may be currently set on Warning and we may need it to be set on
debug......but it may still show your past attempts and the reasons why Cups thinks it failed.

good luck

Here are the messy results from the queries proposed earlier:

dpkg -l | grep foo

ii foomatic-db-compressed-ppds 20180306-1 all OpenPrinting printer support - Compressed PPDs derived from the database
ii printer-driver-foo2zjs 20170320dfsg0-4 amd64 printer driver for ZjStream-based printers
ii printer-driver-foo2zjs-common 20170320dfsg0-4 all printer driver for ZjStream-based printers - common files

dpkg -l | grep cups

ii bluez-cups 5.48-0ubuntu3.1 amd64 Bluetooth printer driver for CUPS
ii cups 2.2.7-1ubuntu2.4 amd64 Common UNIX Printing System(tm) - PPD/driver support, web interface
ii cups-browsed 1.20.2-0ubuntu3 amd64 OpenPrinting CUPS Filters - cups-browsed
ii cups-bsd 2.2.7-1ubuntu2.4 amd64 Common UNIX Printing System(tm) - BSD commands
ii cups-client 2.2.7-1ubuntu2.4 amd64 Common UNIX Printing System(tm) - client programs (SysV)
ii cups-common 2.2.7-1ubuntu2.4 all Common UNIX Printing System(tm) - common files
ii cups-core-drivers 2.2.7-1ubuntu2.4 amd64 Common UNIX Printing System(tm) - driverless printing
ii cups-daemon 2.2.7-1ubuntu2.4 amd64 Common UNIX Printing System(tm) - daemon
ii cups-filters 1.20.2-0ubuntu3 amd64 OpenPrinting CUPS Filters - Main Package
ii cups-filters-core-drivers 1.20.2-0ubuntu3 amd64 OpenPrinting CUPS Filters - Driverless printing
ii cups-ipp-utils 2.2.7-1ubuntu2.4 amd64 Common UNIX Printing System(tm) - IPP developer/admin utilities
ii cups-pk-helper 0.2.6-1ubuntu1.2 amd64 PolicyKit helper to configure cups with fine-grained privileges
ii cups-ppdc 2.2.7-1ubuntu2.4 amd64 Common UNIX Printing System(tm) - PPD manipulation utilities
ii cups-server-common 2.2.7-1ubuntu2.4 all Common UNIX Printing System(tm) - server common files
ii libcups2:amd64 2.2.7-1ubuntu2.4 amd64 Common UNIX Printing System(tm) - Core library
ii libcups2:i386 2.2.7-1ubuntu2.4 i386 Common UNIX Printing System(tm) - Core library
ii libcupscgi1:amd64 2.2.7-1ubuntu2.4 amd64 Common UNIX Printing System(tm) - CGI library
ii libcupsfilters1:amd64 1.20.2-0ubuntu3 amd64 OpenPrinting CUPS Filters - Shared library
ii libcupsimage2:amd64 2.2.7-1ubuntu2.4 amd64 Common UNIX Printing System(tm) - Raster image library
ii libcupsmime1:amd64 2.2.7-1ubuntu2.4 amd64 Common UNIX Printing System(tm) - MIME library
ii libcupsppdc1:amd64 2.2.7-1ubuntu2.4 amd64 Common UNIX Printing System(tm) - PPD manipulation library
ii printer-driver-hpcups 3.17.10+repack0-5 amd64 HP Linux Printing and Imaging - CUPS Raster driver (hpcups)
ii python3-cups 1.9.73-2 amd64 Python3 bindings for CUPS
ii python3-cupshelpers 1.5.11-1ubuntu2 all Python utility modules around the CUPS printing system

This seems a trifle worrisome though:
dpkg -l grep avahi

| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
ii grep 3.1-2 amd64 GNU grep, egrep and fgrep
dpkg-query: no packages found matching avahi

Avahi was installed manually by me - though perhaps not correctly ??

I've done some searching & found nothing truly useful about it relating directly with Ubuntu and/or v18.04...any further clues for me on this, please ??

right lets react to last reply first.

foo have a foo*PPD issues there
cups results...I have slightly less packages but no issue there either
avahi....needed for wireless discovery

here are my results
dpkg -l | grep avahi

ii avahi-autoipd 0.7-4ubuntu5 amd64 Avahi IPv4LL network address configuration daemon
ii avahi-daemon 0.7-4ubuntu5 amd64 Avahi mDNS/DNS-SD daemon
ii avahi-utils 0.7-4ubuntu5 amd64 Avahi browsing, publishing and discovery utilities
ii libavahi-client3:amd64 0.7-4ubuntu5 amd64 Avahi client library
ii libavahi-common-data:amd64 0.7-4ubuntu5 amd64 Avahi common data files
ii libavahi-common3:amd64 0.7-4ubuntu5 amd64 Avahi common library
ii libavahi-compat-libdnssd1:amd64 0.7-4ubuntu5 amd64 Avahi Apple Bonjour compatibility library
ii libavahi-core7:amd64 0.7-4ubuntu5 amd64 Avahi's embeddable mDNS/DNS-SD library
ii libavahi-glib1:amd64 0.7-4ubuntu5 amd64 Avahi GLib integration library[/quote]

Note you have missed out the pipe symbol in your command

How does this printer connect to your friend's PC? eth=ethernet

  1. usb lead direct PC to printer
  2. full wireless....PC and printer have no connecting leads what so ever
  3. printer eth cable to router......router eth cable to PC
  4. printer eth cable to router....PC wireless to router

Greetings Aus9, and thanks !!
I did notice the difference in that grep line after I copied it from reply #7 here, but did not think to question it ?!?
(I am not currently logged into there to retry that command with the added pipe...)

As for avahi - here is one chat I ran across:>

...nowadays, almost everything on networks work with zero config!

  • And the way they do this is by implementing Zeroconf, some of which is done by avahi-daemon.

Aside of that I've seen mention that it is used in network device discovery as well, but little that is very specific about wired vs. wireless about it.

The Canon printer connects to the network switch and has a static IP;
All 3 users also connect to the same switch with their own static IPs;
The router is NOT involved with the printer at all, and:
All stands behind the separate firewall
The Canon printer does answer to pings made from the new Ubuntu Mate box at my friend's desk.

Am I wrong to think that avahi may help in this network discovery process ??

In answer to where this was asked in reply #5:

^^ tell me which is your result here please

No printer was found on any option chosen thereby...
When the printers tab up top was chosen (later) both working local printers are shown as present & idle.

Thanks for being so helpful !!

umm lets re-phrase to that to mean
no local printer for your target printer was found as its not an usb connection AND
no target wireless printer was found

It may be possible to do a manual setup which is option 3 in that discussion we did earlier.

OK I have zero experience of setting up a switch network.

good thats always helpful.

so do we have 3 PCs with cables (ethernet?) to this switch box?

anyhow....try this link later

You will notice one small difference that I want you to understand
Cups as in /etc/cups are root owned files

as per
ls -al /etc/cups
total 96
drwxr-xr-x 5 root lp 4096 Jul 13 15:07 .
drwxr-xr-x 131 root root 12288 Jul 13 09:56 ..
-rw-r--r-- 1 root root 27585 Apr 10 23:07 cups-browsed.conf
-rw-r--r-- 1 root root 6403 Apr 17 03:02 cupsd.conf
-rw-r--r-- 1 root root 2923 Feb 16 21:48 cups-files.conf
drwxr-xr-x 2 root root 4096 Feb 16 21:48 interfaces
drwxr-xr-x 2 root lp 4096 Jul 13 09:43 ppd
-rw------- 1 root lp 882 Jul 13 09:44 printers.conf
-rw------- 1 root lp 898 Jul 13 09:44 printers.conf.O
-rw-r--r-- 1 root root 240 Apr 17 03:02 raw.convs
-rw-r--r-- 1 root root 211 Apr 17 03:02 raw.types
-rw-r--r-- 1 root root 142 Feb 16 21:48 snmp.conf
drwx------ 2 root lp 4096 Feb 16 21:48 ssl
-rw-r----- 1 root lp 382 Jul 13 15:07 subscriptions.conf
-rw-r----- 1 root lp 92 Jul 13 11:11 subscriptions.conf.O

Now normal cups expects to find a discovered printer via the router or via its local area network unless otherwise specified in one of the above files.

Now looking at my wl too has a static ip
so when I use a web browser to look at its ink levels I just click on its bookmark
for me.....

so since we know your friend can ping target can you at least report its ip?
if this is however a true network printer that others might be able to see
then don't!
And only if security is not breached.....are these static ips within the same

My printer is behind a router firewall so I have qualms at exposing my ip.
And you probably aware address that are 10.something or 192. something are local.

Thanks Again !!

Further clarifications:
"No printer was found on any option" referred to the add dialogue ONLY which has 5 or 6 tick boxes included - all of which I tried with nothing found.

"OK I have zero experience of setting up a switch network."
All networks depend upon what switches actually do - though many folks mistakenly refer to them as 'hubs', which most are not anymore due to the hubs' limited natures.

"so do we have 3 PCs with cables (ethernet?) to this switch box?"
It is just a very typical small office wired network - nothing odd about it.

All local, yes:
"...normal cups expects to find a discovered printer via the router or via its local area network "

All have typical 192... IP addresses.

Nothing I am asking about regards internet printing of any sort !!
The several users all send very certain print jobs to the Canon printer, and that is all that this is about; the 2 remaining win-doze users do so 100% trouble free - they will not be win-doze users if/when it can be shown that Linux is the better choice for moving forward.

NOT being able to detect & install this LAN connected printer to the Linux OS is pretty much the rock in the shoe of this whole thing !!! (For me, especially.)

The hangup when I went through this page's directions before was...:

My own bafflement at giving it the local IP & having it either gripe about the syntax, or finding nothing there ??

Different places seem to require differing (yet EXACT) ways of entering responses as is the Linux way - and admittedly I do not always get the EXACT syntax PERFECTLY right in working at this stuff.

VS. doing all this under win-doze:
The printer is seen easily AND the driver just installs almost instantly is VERY different than pushing through this FAR too-lengthy process wherein the printer is NOT seen easily and if/when it may be seen at all - the driver installation (thus far...) has been like trying to hammer a BIG square peg into the smaller round slot !!!

For crying out loud - it is just a common thing - a printer shared on a tiny LAN for several users - and not even an off-brand or strange printer at that - but after what - 2 weeks of beating on this for (what should be...) a 10 minute solution - I have a friend who already thinks this is for the birds - and I am getting close to agreeing with him on this ONE aspect of it !!!!!!!!!!!!!!!!!!!!!

This is NOT turning out to be a VALID method of showing ANYONE that Linux is a better choice - despite what I personally know of it via my very lengthy experiences - as it is all new to this user which I am trying to help to see just how much better it can be.


firstly I have already stated I have no experience with switched networks. And it appears that information I failed to get confirmed on my first post. Therefore I have no problem with your friend deciding to go back to Windows. We are all humans here, well thats what my Dr says :smile:

As we have yet to confirm you have avahi....I will at least mention that Cups uses discovery so your friend will need avahi installed and running

as you have graciously confirmed that your printer is behind a firewall...if you are able to.
here is my last suggestion now that I know a little more about your friend's set up.

In the following code box....SNIP means there will be more lines of output but they are not relevant to our goal. And I use sudo save me typing sudo a lot.

# as we have so many root commands sudo su
sudo su

systemctl stop cups

systemctl status cups
# Jul 14 15:03:50 um systemd[1]: Stopped CUPS Scheduler.

# make a backup then modify config
cp /etc/cups/cupsd.conf /etc/cups/cupsd.conf.original
sed 's|LogLevel warn|LogLevel debug|' -i $CUPS
sed 's|Listen localhost:631|Listen *:631|' -i $CUPS
sed 's|Browsing Off|Browsing On|' -i $CUPS

# check it looks ok before restarting cups daemon (=windows service)
cat /etc/cups/cupsd.conf
# scroll up or down....
systemctl start cups

systemctl status cups
# ● cups.service - CUPS Scheduler
# Active: active (running) since Sun 2019-07-14 15:14:30 AWST; 5s ago

THEN either use my original instructions with web browser to add printer
OR use Control Centre -> Printers to find printer

Good luck

In case you do not know, *:631 attempts to use all networks
while localhost uses AFAIK only the local host as seen by your router.

In addition the online man page is here

or run
$ man cupsd.conf

Sorry for my delay in getting back to this - I have been too ill to work for some days & hope that you are still 'around'.

Now - for crying out loud - it is JUST AN ORDINARY SMALL LAN - hub, switch, or uncle Bob - NO DIFFERENCE EXISTS they all work the same:

[quote="aus9, post:19, topic:19827"]
I have already stated I have no experience with switched networks. And it appears that information I failed to get confirmed on my first post. Therefore I have no problem with your friend deciding to go back to Windows.[/quote]

I am the responsible party here tech-wise and it IS his place, but absent any tech skills on his part it falls to me to 'just make things work' - hence my desire to HELP all this to happen with lowest possible angst so that he can finish up his final couple of years and retire.

I have faithfully copied everything from here into my notes & have tried to follow all of it - but as you say, given my being human it is certain that I missed this and messed up at that...

As soon as I can arrange what I mentioned before I will re-try installing the driver remotely when there is someone present at his office to clear the printer errors if need be.

I am about to copy the rest of this thread into my notes and that is all I will likely do with this for a few days until my ability to focus properly has gotten back to normal.

Thanks for your help 'till now.