Please Read, Well Intentioned

Hi

I’m new to Linux, so please have a bit of patience and try to understand what I’m about to say…

Being a MS-DOS and Windows user since the arcane days, I got of course used to the - facts are facts - ease and simplicity

of certain operations when it comes to get work done quickly and efficiently. However, Windows evolution has brought in so

much exhasperating crap that slows down the box just when we are in a hurry to get things done, that after much

deliberating and months of reading as much as I could online about Linux and its labyrinth of never ending flavours, I

finally made the deision to give it a try on a 4 year old laptop that still had Windows XP on it. So I went for the Ubuntu

Mate.

All nice and well, works fairly well, a bit sluggish whiloe navigating menus that contain submenus, but nother major

there…

What truly makes it even more exasperating then Windows - for a newbie to Linux like myself, mind you - is this…

Windows: Install/Uninstall programs is a breeze. We know where the program is downloaded to and can even choose where to

donwload it to. To install, we simply click on it, choose install and job done. To Uninstall, we go to Control Panel, or to

the main menu, right click on the program we no longer want, choose Uninstall and job done.

OK, some files may occasionally be left behind lingering on the disk, but we know where the program was installed, so just

go there, select them, choose delete and job done (yeah, yeah, delete is not a true deletion, jadada, we all know it, but

it’s irrelevant for this).

So I wanted to install a particular program in this newly installed Ubuntu Mate.

O’boy… need to go to University coz really… hair raising experience.

Using the Control Center takes me to the repositories and there it is the program alright… problem is, it’s a damn old

version of it.

So I downloaded the recent version from the program’s website, checked the md5 checksum, all good.

Now to install it… goodness me… HOW???

14 hours of reading Linux forums FAQ’s to avoid annoying “seasoned” Linux users with newbie questions, all tricks tried…

nah… no way.

The Package Manager just doesn’t allow it to even be displayed… maybe because it’s not a Debian based program (it’s

compressed as a tar file, as it’s designed to work with linux)

Tried to move it to Var/Cache/Apt/Archives and use the apt-get command… nah… to start with, when attempting to move it

from Downloads to Var/Cache/Apt/Archives, got a message saying “No permission”; tried to logout and login as root, but no

password works with root. Right clicking doesn’t offer a choice of moving it by drag and drop.

Tried Pacjake Manager again… tried to Add download packages… yay… it moved the zipped folder to the destination I

wanted, but now as an unzipped folder…(???). OK, let’s try to install it now… nah… no option anywhere in right

click or any other menus to install the damn thing…

So got stuck to download endless instructions on how to install it manually from command line, which worked, yes, but

required me to spend over 4 hours to find the instructions and get it done.

Sorry gents and ladies, but I have to say… when it comes to captivate despondent Windows users, Mac is light years ahead

of all and any Linux flavours out there, for this reason alone.

So I wonder… why, oh why hasn’t yet any good soul seen such an obvious deterrent for the common dumb-ass user like myself

to kiss goodbye to the God damn frustrating Windows and move happily to Linux???

A world wide community of programmers and etc etc etc, for the publicity is unmissable and not a single soul has thought in

giving the new users the very basic foundations to encourage the move from one OP to the other???

Installing/Uninstalling programs is one the very basic and most required tasks… and whereas in Windows even the dumbest

of all dumb users like myself can easily, quickly and flawlessly do it in minutes, in MAc takes a few extra minutes but

it’s fairly simply as well and in Linux it is simply a mamoth task that 9 out 10 times is doomed to a frustrating failure

that serves only to shoo away anybody trying to move away from Windows.

truly sorry for this long post, but if the Linux community is genuinely serious and well intentioned in captivating new

users and encouraging more people to use Linux and make the move onto it, then maybe somebody well placed within the said

community could read this post of mine, give it some thought and realize that what you are actually doing is building

houses starting from the roof, or from the walls, or from any other point in the structure rather from where a house MUST

be started from… the foundations!! From a new user’s prespective, of course…

Thank you to all and any who had the patience and courtesy to read this to the end and to anyone who feels like having a

derrogatory or rude go at me for it, let me remind you that 99% of computer users world wide are programming-ignorant and

that is why Bill Gates quickly turned himself and Windows into the undeniable success it still is today… because he did

understand this very basic truance and designed the damn thing for programming-ignorant USERS!!!

And if anyone wishes to beat me or to give me any useful and welcome advice alike, I’ll be happy to receive it at

[email protected] because frankly, right now, I don’t think I’m going to spend any more time here so soon… sorry…

sigh…

With Kind Regards

Joao

Hi,

this is a repeat of this thread and I think he is more or less sorted now!. :smiley: : (He should delete this one!).

Hi folks

I do thank you and am grateful for all your positive input in whichever form you sent it. I know I can talk a bit too much (lol), but I tend to read a lot first before stepping forward with questions…

Wolfman has kindly given me priceless info “step-by-step style” and I have also been quietly exploring the community, finding my feet and my way around and so I’ve been reading and trying much of the “how to” info to be found there - and happy to say that I’m slowly but steadily getting the gist of things.

So please don’t take my silence wrongly… I’m studying and mucking about as I go along, taking notes on what puzzles me or escapes me and gradually learning on how and where to get the answers whilst sticking strictly to ubuntu mate - which make no mistakes, I’m over the moon with and enjoying utterly.

My attempt to install it on my win7 core i7 toshiba was an unexpected and resounding success and I even managed to get some of the toshiba proprietary drivers installed, all by myself… and if I scrwed up somewhere, I haven’t realized it yet because everything is working like a charm.

Can’t believe how damn fast everything works under linux on this machine… which impresses me even more when I look at the tiny eeepc performing faster than this core i7 beast under win7…

As for deleting or closing the thread, I’m sorry guys but I haven’t yet looked into how to do that, so I’ll be grateful if Wolfman or some other member with the required privileges can do it for me.

As Wolfman correctly said it, I’m more or less sorted. The decision has been made, I’m full steam ahead moving into linux with no going back to Bill Gates legacy and I have an incredibly vast whole new world to explore, study and come to terms with ahead of me, hehehe…

With my kindest regards to all

Joao

Joao Monteiro
The only constant in Life is Change

1 Like

Hi Joao,

I cannot find the delete function either!.

If you make a mistake with Ubuntu, the beauty of the system is that you can re-install without losing your data if you do it using the "Something else method", I re-install all my favourite apps using a terminal "Meta" command like the following example:

 sudo apt-get update && sudo apt-get install synaptic shutter gparted gpart xsane hplip-gui deluge pepperflashplugin-nonfree bleachbit libreoffice me-tv kaffeine linux-firmware-nonfree unetbootin devede handbrake libxine2-all-plugins transcode ubuntu-restricted-extras vamps videotrans playonlinux mono-complete p7zip-rar winbind kshisen amarok kontact skype faac flac chameleon-cursor-theme clamtk mate-desktop-environment-extras alien k3b chromium-browser nvidia-current

The above command will install (almost) everything I need without me having to think about it, it takes a while but you can drink a coffee while it is happening, I only have to take note of one licence agreement when running the command!. :smiley:

The above command is also an example of my preferences, each person needs to decide what they need, some of the packages I choose may be bloat to others, the important thing to remember is that when you create your meta command, make sure you type the exact name of the package or it will fail!!. :smiley:

RESTART AFTER RUNNING SAID COMMAND!.

Hi Wolfman

As usual, thank you so much for this one. Got me to practice how to navigate my way through the file system, search/find files, directories, etc and understand a bit better the “nix” filing structure, while typing up a doc with the packages I definitely need and want at all times.

One question for when you have a chance, if you don’t mind…

I use airmon-ng to check for rogue ap’s sometimes, either for my arduino projects (I have some funny neighbours and loads of radio interference from all sorts of wireless gadgets from them) or at work… the lads mean no harm when they piggyback on the wireless for net browsing but sometimes it causes problems with some of the BMS equipments and our IT isn’t particularly interested in it because it’s a standalone system specific for us, engineers.

Bottom line… for my card to stay in monitor mode I have to kill the network manager, coz in this linux os the nm gets it back onto managed mode otherwise. No probs… "sudo kill xxx (nm pid) and all good.

But after I’m done I don’t have a clue how to restart the network manager and thus I can’t connect to any wireless… so I’m stuck at rebooting the pc for it to startup lol…

I know this is a really newbie dumbness but what’s the linux equivalent to the “start” command in dos? Coz when I try to start nm the message I get is that there is no such “start” command…

As I said… not an urgency, but if you can point me to where study this subject, I’ll be grateful… busy like hell at work and private life right now lol… but man, I’m loving every minute with my little eeepc-mate as I call it now…my best mate by far hahaha…

Kindest Regards

Joao

Joao Monteiro
The only constant in Life is Change

Hi,

Hi,

you can try the following terminal command (might not work on Ubuntu 15.10?):

sudo service network-manager restart

or simply left click on the network icon in the top panel and select your network!, or log out and back in again!:

For more detailed instructions on networking, search here:

https://help.ubuntu.com/community/Network

https://help.ubuntu.com/lts/serverguide/network-configuration.html