Pulseaudio-equalizer-ladspa: Getting 3.0.2 now without a package

Special thanks to user Tae'Tarthe#1082 from Linux Enthusiast Group for this solution.

Introduction

In the absence of a built package, users for a good long while could install a copy of pulseaudio-equalizer-ladspa 3.0.2. Rather than boring you with a long and tedious detail of packages to install, this one is going to be quick.

Removal of webupd8 build

If you already have the older version of Pulseaudio Equalizer per my previous instructions, you'll probably want to get rid of it. To perform this optional series of events:

sudo apt-mark unhold pulseudio-equalizer
sudo apt remove -y pulseaudio-equalizer
sudo apt -y autoremove

If you don't need the webupd8 sources anymore, also get rid of those in /etc/apt/sources.list.d and run sudo apt update.

Installation

Regardless of your current state, or whether you kept the older version of pulseaudio-equalizer, you can use the latest version by Saving this script as a file in your home, and sudo cmhod +x the file to make it executable:

#/bin/bash
sudo apt update
sleep 5
echo '=== Installing dependencies ==='
sudo apt install -y libglib2.0-dev-bin swh-plugins python3-pip git meson
sleep 3
echo '=== Configuring build dependencies ==='
sudo python3 -m pip install --upgrade pip setuptools wheel
# This was originally an arrangement of messages about waiting for things to "Cool". No idea if the sleep is even necessary.
sleep 9
echo "=== Fetching programme source ==="
git clone https://github.com/pulseaudio-equalizer-ladspa/equalizer.git
echo '=== Making programme ==='
cd ./equalizer
sleep 1
meson build
sleep 4
cd ./build
sleep 4
ninja
sleep 4
ninja install
sleep 1
echo '=== Finished. ==='

Use

Once done, execute $HOME/equallizer/build/bin/pulseaudio-equalizer and make any changes you want. Works similarly to the GTK2 version, of which its instructions I've retired myself from maintaning still work to this day.

1 Like

I forgot the very important step of using chmod to make the file executable. Resolved now.

I also said at the end file path would begin at $PWD, my bad it'll begin with $HOME instead.

I think you can edit the original entry so all is correct. FYI. :slightly_smiling_face:

I did, worry you not. I just also like to be ultra-transparent without people needing to browse the edit history.

2 Likes

One more faux pas is that I declared /usr as part of the programme path when it does not exist. Big oopsie.

Also you don't need source code enabled, as I've seen with further testing. I was just being an idiot refusing to test against paranoia.