Raspberry /boot


#1

Hello, I need help. The problem is that the system will not update. Says insufficient space in /boot. But in raspberries two volumes, boot and root. Why upgrade climb on the boot what should I do?

Здравствуйте, помогите мне. Проблема в том, что система не хочет обновляться. Пишет недостаточно места /boot. Но ведь в малине два тома, загрузочный и корневой. Почему обновления лезут на загрузочный и что делать?


#2

this might help …


#3

in the root 15 gigabytes free. but the /boot partition when installing the system, independently created 60 MB fat 32 file system.


#4

Sorry if what I write is not correct. I am Russian and am in dialogue with you through the translator


#5

General updates the terminal and graphical shell update requires a hard space on /boot. The problem is not solved, but I bypassed it


#6

@Wimpy, it seems to me that we’ve seen this exact problem quite a few times since 16.04.2 for RPi was released, it makes me think there could be a systemic issue with the image. Can you take a look?


Not enough free disk space ? [FRESH INSTALL]
#7

I had the same error message but when I ran a terminal session and used “sudo apt-get update”, “sudo apt-get upgrade”, and “sudo rpi-upgrade” all worked fine. I am certainly not knowledgeable on the subject so use caution. I read some where that"apt-get upgrade" is not recommended on a PI but you should use “rpi-upgrade”. Didn’t appear to cause me any problems sofar. I am using a PI2.


#8

I also first updated through the terminal. After you have put Sunaptic and work with packages and updates through it. Everything works perfectly. Turned off automatic updates in standard update utility. How would the problem not solved from under the root, but it works fine.


#9

I followed this video. Worked fine for me.
I believe there are also a number of other videos on YouTube that explain the same thing.


#10

VERY FAST AND SIMPLE SOLUTION:

I have reported it also as a bug and I found a very fast and quick solution:

Delete the kernel from boot that doesnt correspond to your device, for example if you have a rpi3b delete the kernel.img and if you have other rpi delete the kernel7.img and you will have space.

You need to go to /boot and do it as admin:

cd /boot
sudo su
(enter password)
rm kernel.img or kernel7.img depending on the device.

Good luck!