Raspberry pi 4 won't boot with Ubuntu Mate 20.04.1

Hi, I have a Raspberry pi 4(4 gb ram) and I'm trying to install the arm64 Ubuntu Mate image. When I power up the pi with sd card inserted, I get a blank screen. After about a minute, my monitor gives "No signal" and goes into standby - for about 5 seconds, after which I have blank screen again. This cycle repeats indefinitely. What can I do to fix this? Thanks for your help!

I have also had problems with RPi 4B not booting with Ubuntu Mate 20.04.1, both 32bit and 64bit images will not boot. The same images will boot on the RPi 3B+ without difficulty, although slow.

If you get 'no signal' on the monitor, this can be because it either doesn't 'see' the monitor or it is sending out-of-range signals (less likely). This may be correctable in usercfg.txt (equive to old config.txt)
Derek

I also have had this issue. I have attempted to install 20.04 and 18.04 with the same result. After inital boot I can see a tiny portion of the screen at the bottom that flickers. It's out of range signals. I'm using a Dell 19" wide monitor and it's default display is 1400x900. Most of the RPI distros have a native resolution of 1280x1024. So far I have had only one OS distro to not have this issue. The problem is yo you can't really edit any type of configuration if you can't see it on the screen.

I tried putting

[HDMI:0]
	hdmi_force_hotplug=1
	hdmi_group=2
	hdmi_mode=82

in usercfg.txt ...
no difference.

Then I plugged my monitor into HDMI 1 - voila!
Now I have Ubuntu Mate running on my Raspberry pi 4.
Does anyone have any idea why HDMI 0 won't work?

I've had the same issues with two monitors. I've got solved it with a little change in the config.txt. So try to commend the line "hdmi_drive=2" or change it to "hdmi_drive=1".
Both works for me.

I work with DSI port and it's the same thing, it doesn't work. Should I comment those lines??

I have the same problem to try to boot with arm64 or even armhf version with Pi4
but I have make the ubuntu server re-packed image for everyone to download
try to view my topic


(I have only make the armhf for it as RealVNC Server only support the armhf version, so if you need more support you can try to repacket the ubuntu-server for pi4 and make it better.)