Reinstalling Ubuntu-Mate

After some recent crashes/system lockups, I’ll be reinstalling Ubuntu-Mate this weekend. I’ve read through Wolfman’s excellent tutorial (along with several others) as well as watching a couple of youtube videos. At this point, the pressure is building and my head feels like its going to explode. This is what I believe to be correct so far:

I have partitioned my harddrive as a GPT partition,

Therefore, I must set my BIOS to UEFI or UEFI first.

Therefore, I must set the first partition on my harddrive as a boot/efi partition. 200 Mb in size. Unformatted. With a boot flag.

What I think I’ve learned is that your partition type (whether MSDOS or GPT) determines whether you can boot in UEFI or Legacy mode, which determines whether or not you will need the boot/efi partition.

I hope this is all correct. If not please let me know.


For reliability and performance, I recommend the ext4 filesystem when setting up the hard drive.

Hi @Jim007,

did you read all the links in section 4 of the partition guide? (UEFI info):

Thanks Wolfman,

I think I’ve figured out the problem: I have a gigabyte 970a-ds3p motherboard. Every since I’ve had this board I’ve had problems with unexplained, random lock ups, crashes, etc. I’ll get ubuntu installed and it works great for a while, and then another random crash.

Doing a google search, I notice that others are having the same problems. I could not find any where that anyone has found a solution.

I’m wondering if the new HWE kernel might help??

This problem has really become a major point of annoyance for me so I may consider replacing the motherboard if there is no other solution. Any suggestions will be greatly appreciated.

By the way, I have 8 Gb of ram so I’m using the 64-bit version of Ubuntu-Mate. I noticed that others who are having this issue post that it seems to be related to the 64-bit kernel. If I go back to the 32-bit version, I’ll be losing the use of 6 Gb of ram, but not having to replace the motherboard.


1 Like

32bit can see/use 8G of ram. You lose nothing :slight_smile:

If push comes to shove @Jim007 , you can force PAE but I really don’t know if it is needed?. maybe one of the devs can enlighten us?, @Wimpy, @lah7, are you there? . :smiley:

Hi Jim

Sounds like you might have a bad stick of memory. Quickest way to find out, if you have 2 modules? pull one, then test, if it still does it, replace it with the one you took out and test.

It will be unlikely that both are bad, (but possible)

1 Like

Hi Wolfman,

I think that following section 4 fixed my problem!!!:slight_smile:

As I’ve mentioned in a different post, over the years I’ve suffered numerous unrecoverable crashes and had to reinstall linux. Probably had a crash averaging every three or four months. I’ve searched the Internet high and low trying to figure out BIOS settings, partitioning schemes, etc.

It is only now that I’m beginning to understand the relationship between harddrive partition type and the BIOS setting. If you partition your harddrive as a GPT partition, then you must use the UEFI bios settings with a boot-efi partition formatted to FAT32.

Will ubuntu install if you have a mish-mash of UEFI, Legacy, GPT and MSDOS with or without a boot-efi partition. I can guarantee that it will because I’m tried probably every combination. Will the system eventually crash? I can’t say that it won’t, but my own experience has not been good.

I know that linux-users are an independent lot and don’t want to be limited in coming up with their own unique installations, but it would be nice if the Installer would give some warning if you’re about to do something that is outside the normal recommended way of doing things.

Anyway, if you know anyone who works for Canonical you might pass that along.:wink:

Thanks for the help,


1 Like

Alrighty Jim,

can we mark this as solved now?. :smiley:

Yes, all is resolved. :grin: However, what I learned may provide information for a Part 5: of your excellent tutorial.

I installed ubuntu according to Part 4: UEFI systems of your tutorial. When I booted into ubuntu my screen resolution was only 768 by ??? (I forget the second number), which is only a medium resolution for my monitor. I have an nvidia graphics card, and when I had installed ubuntu in Legacy mode with GPT my screen resolution was 1280 by 1024.

I wanted the higher screen resolution from my nvidia card and I wanted to use GPT for all the reasons that it is superior to MSDOS. Doing some more research I have come to the following conclusions: Legacy Mode does not require a boot partition, so most people who are using Legacy with GPT are partitioning their harddrive as if it were an MSDOS partition. This is what introduces the instability. It is GPT which requires a boot partition for stability.

I booted to a live USB in Legacy Mode. I partitioned my harddrive as you as explained in Part 4: UEFI systems. I flagged that first partition in gparted as legacy-boot. When installing ubuntu, under Something Else, I mounted that first partition as reserved for bios-grub.

The installer accepted these settings without question. My screen resolution using the nouveau driver is 1280 by 1024 as it should be. All is well.

Oh! I almost forgot. Someone might ask, "Why didn’t you just install the nvidia driver from Additional Drivers. I tried this and it crashed my system. I leaned that there is an inherent conflict between the nvidia drivers and UEFI mode that crashes the system.

Anyway, if you want to use GPT with Legacy mode, or have an nvidia graphics card, I believe this is the correct way to go. I’ll keep you posted on any future instability, but for now I’m keeping my fingers crossed,:slight_smile:




Well…you can disregard everything that I’ve written above. I got everything reinstalled and then clicked on k3b to burn a CD. All of my desktop icons went white (or as some say “clear”). It was obvious that something had crashed. This is the exact same scenario I’ve been having ever since I tried to combine GPT with Legacy.

I was able to close all my open programs and I then hit reboot. After the BIOS screen, but before the sign-in screen (I guess you could call it the loading screen), my computer locked up.

I’ve now reinstalled on an MSDOS partition in Legacy Mode. Based on my experience, this is my conclusion: I don’t believe the incompatibility is at the hardware level. I believe the incompatibility lies in the ubuntu installer. There are obviously two different installers depending on whether your bios is set to UEFI or Legacy because, depending on this setting, you get two completely different menus when you boot up live.

It would make sense that the UEFI installer would look for a GPT partition, and the Legacy installer would look for an MSDOS partition. How this would work at the hardware level, and why it would cause an incompatibility I don’t know, but at this point I would not recommend anyone trying to combine GPT with Legacy.

For this to work, I believe, would take a programming change by Canonical. And for those few people who might want to run such a hybrid system, it probably would not make economic sense to enable such a change.

Anyway, that my two-cents-worth. If you’ve had any success with this I’d love to hear about it. Otherwise, unless you have a lot of free time to spend reinstalling, I don’t recommend it.


1 Like