Samba Config GUI will not open

I have installed Samba and Samba config to the Ubuntu Mate on my RaspPi 2. When I try to open Samba from the Admin menu or the Control Panel, I am asked for my password. I enter it, hit OK and there is a flash of a box opening and then closing on the screen and then nothing. I have been trying to find a solution for this and I saw that installing glade and python-glade2 would resolve this. I installed glade and python-glade2 was already installed. Still nothing - same result - some box opens and closes too fast to see and then nothing. Uninstalled glade after this as if it does not help with this - I don’t need it. Left python-glade2.

Any help appreciated.

Thank you!

Just in case you have not got gksu installed (you need it to run the system-config-samba GUI):

Go to a terminal and type: sudo apt-get install gksu

Then try to run the samba GUI again

I just did that - installed gksu - no difference. Click on Samba - asks for password and then a flash on the screen and nothing.

In order for samba config to open i had to create a blank file sudo pluma /etc/libuser.conf don’t add anything to it just save and close it samba config then worked for me


Excellent! That works!!!

1 Like

Thanks a whole bunch. Just installed Ubuntu MATE 16.04 in my laptop. Had this problem, Now its fixed.
Wonder why this happens though :S

I can report that I also had to create that file. However, although the GUI is now loading, the samba shares are not actually working. My usual fix when this happens (and it happens a LOT in linux) is to put the following line at the bottom of a given samba entry in the samba.conf file in the /ect folder:

force user = stephen

(where "stephen" is your username - your's will be different)

However, even that is not working. Instead, I am getting this dialog box appear when I try and click on a network folder:

So, no samba at the moment. which is a complete pain for me since I use my main rig as a server for piping films and other multimedia around my house