Sharing folders on Windows Network

How do you share a folder on Ubuntu Mate 15.10 so that it is accessible from a Windows network?

Install the package caja-share and restart caja (or log out, then in). This enables the "Sharing Options" when you right-click a folder.

From a terminal: (CTRL+ALT+T)

sudo apt-get install caja-share
killall caja

Now, when you right-click a folder, you'll have the option for "Sharing Options".

Here you can configure a network share that can be accessed from other Windows computers.


Thank you, lah7, that worked like a charm. I would think caja-share would be a default install.


Hey there, the installation works but when I try to access the folder from my Windows 10 Desktop it does not recognize the username and password of my mate os ! How do I resolve this ?

Resolved it:
caja-share uses samba to share folders.
After you have added folders you need to give the user a smbpassword by typing:
sudo smbpasswd -a your_ubuntu_username


That was it!! Worked for me

Hi can anyone help me when i go to create the shair i get this error and i dont know how to fix it its pobaly somehting dumb but here it is anyway ‘net usershare’ returned error 255: mkdir failed on directory /var/run/samba/msg.lock: Permission denied
net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.


for me the same situation, anybody can help me? :sunny:

I just had the same error, i tried to create the missing usershares folder, then i got a different error and i figured i need to install “samba” package that is not installed by default.
Then i got an error about write permissions for the usershares folder so i just added add-write permissions for everyone.
Now sharing via caja seems to work.
(Still cant see the folders i shared in the other computer, need to find out this one now)

I really think folder sharing stuff should be installed and working fine by default…

Hi guys, maybe you have figured it out yet, but if not, here is my solution:

I had the same ‘net usershare’ error even if packages ‘samba’ and ‘caja-share’ were installed. I found out that my user was not part of the ‘sambashare’ group. Here is what you should do:

Check if your user is part of the sambashare group as follows:

groups your_username

In my case I was not a part of the sambashare group. To add your user in this group, run the following:

sudo usermod -a -G sambashare your_username

Then, logout or reboot and everything should work fine.

Many thanks to @lah7. Works perfectly in Ubuntu-Mate 16.04. I was ready to start editing smb.conf. Thank you for making it so much easier for me.

1 Like

Thank you , you save my day

For the above permission denied error,
sudo apt install samba