Simple-scan cannot see LAN Brother MFC-9840CDW

Scanning is not working for my Brother device installed on LAN. Used the Driver Install Tool on, followed directions and everything seemed to complete successfully.
Printing seems okay:
The printer driver was installed.
I was able to go to properties on the installed printer and found Brother MFC9840CDW as the LAN printer and the test page printed. So that’s all good.
Scanning is not working:

  • The simple-scan program when opened does not detect the Brother scanner.
  • On the Brother device, using the SCAN button, my Ubuntu computer (Dell Optiplex-780, Ubuntu-Mate 17.10) does show up as a destination (it shows the name of my home directory). But if I try to scan the connection to the PC just times out.
  • The Brother scanner driver seems to be installed okay because, in a terminal, if I query: brscan-skey -l, it does respond showing the Brother device MFC-c9840CDW and says it is “active.”
  • Using the IP address of the Brother device, I am able to reach the config page on the Brother.
    Bottom line, no scanning. How to get scanning to work??

sudo apt-get install xsane.

Thanks for the quick reply. I did that, but even after rebooting xsane also did not detect my printer? Any way I can help xsane do that?

I have a Brother HL-L2380DW and what I did was setup the network on the printer menu as static IP address (for ex., based on your home router availability) and use that IP on the Brother installation script, instead of the network alias use by default.

1 Like

My Brother device has had a static IP address, and that is how it is found by the printer driver. Printing is working okay. Scanning is not working, and in particular, simple-scan and xsane cannot see the Brother, even though I can reach the Brother via FTP from the PC, so there is a connection. Were you referring to a particular Brother install script for the scanner? Thank you for your interest in helping.

What version of Ubuntu MATE are you using?

Edit: Oops! I reread your initial post - 17.10. Sorry.

2nd Edit: I just booted into 17.10 and installed my wireless brother printer/scanner (HL-2280DW) and sure enough, neither xsane nor simple scan could see my scanner even after a re-boot. There might be some problem within MATE 17.10 that prevents the Brother scanners from working as expected. My printer/scanner works as expected in 16.04. @tomilo

I’ve tried to get my brother scanner working in 17.10 and have not succeeded with successive installs of just the scanner driver.

I think that the problem lies in the scanner drivers and suggest that you get in touch with Brother to fix this problem. Good luck @tomilo

mdooley, and others, thanks for taking a look.

I have asked Brother about the drivers and a possible new version. Guess I better not hold my breath.

If I just want to install 16.04, is that easy to do without overwriting my home directory data?

Thanks again.

Hmm... I have my Brother HL-L2380DW printer & scanner working fine in Ubuntu Mate 17.10. I attached a couple of screenshots showing the printer side info and the scanner side info (on XSane)

I will try to dig deep on this to figure out what could be the issue. So far we know is not the Ubuntu version, not the Brother drivers (they appear to be well installed) . On the hardware side, just to be sure is not a device problem, did you test your Brother scanner in another PC with MS Windows?

1 Like

Thanks for chiming in here. I’m extremely interested in why you have your Brother running as expected and I and tomilo don’t.

Well, sanity check. Brother consider the HL-L2380DW a type 4 scanner. so you have to be sure that you are installing the drivers for that type. I checked on my laptop and found the following:

$ dpkg -l | grep Brother
ii brscan-skey…0.2.4-1…amd64…Brother…Linux scanner S-KEY tool
ii brscan4 … 0.4.4-3 …amd64 … Brother…Scanner Driver
ii hll2380dwcupswrapper:i386… 3.2.0-1… i386… Brother… HL-L2380DW CUPS wrapper driver
ii hll2380dwlpr:i386…3.2.0-1…i386… Brother… HL-L2380DW LPR driver
ii printer-driver-brlaser… 3-5… amd64… printer driver for (some) Brother laser printers
ii printer-driver-ptouch…1.4.2-2… amd64…printer driver Brother P-touch label printers

$ brscan-skey -l

HL-L2380DW… : brother4:net1;dev0 … : …… Active

So you should have downloaded the folllowing packages for the scanner:

You can try (re)installing the packages this way:
sudo… dpkg …-i… brscan4-0.4.4-3.amd64.deb
sudo… dpkg …-i… brscan-skey-0.2.4-1.amd64.deb

If the proper drivers are installed correctly, you can check with sane:

$ scanimage -L
device… `brother4:net1;dev0’… is a Brother HL-L2380DW… HL-L2380DW

Is a utility that is installed with sane, called brsaneconfig4 ( for type 4 drivers)

$ brsaneconfig4… --help
USAGE: brsaneconfig4… [-OPTION] … OPTION:
-a name=FRIENDLY-NAME… model=MODEL-NAME… ip=xx.xx.xx.xx
-a name=FRIENDLY-NAME… model=MODEL-NAME… nodename=BRN_xxxxx …: …Add network scanner
-r FRIENDLY-NAME [FRIENDLY-NAME …]…: …Remove network scanner
-d : Diagnosis
-p : Ping (for network scanners)
-s:[LABEL] : Save current configuration
-l:[LABEL] : Load saved configuration

So you can try redo the scan setup like this:

$ sudo… brsaneconfig4… -a… name=(friendly name)… model=HL-L2380DW…ip=(your static ip address)

I named my printer HL-L2380DW, same as the model name, but you can choose any name that make sense to you.
Is that doesn’t work, probably will be better remove the brother stuff and start from scratch

1 Like

Thanks for the sanity check. It turned out that used a Brother install for xenial. (headslap) I downloaded and installed linux-brprinter-installer-2.2.0-1 for my HL-2280DW and immediately thereafter checked to see if Xsane recognized the scanner - it did.

Thanks @guillef.

1 Like

mdooley and guillef, thank you for your input. I will take a look at it the details you have provided and try to figure out how this applies to my setup. At this point, I can say that printing and scanning from this Brother LAN device work okay on both a Windows 10 and Windows 7 PC, both on the same network.

Here is the Brother printer properties screenshot. (I don't have properties from xsane for the scanner, as no scanner is detected.)

I am in over my head here. I am not sure exactly what, guillef, you mean by type-4 scanner. I seem to have brscan3 instead. Is that the problem?

This is the output of brscan-skey -l
MFC-9840CDW : brother3:net1;dev0 : Active

Here is the output of kpkg -l grep | Brother
ii brscan-skey 0.2.4-1 amd64 Brother Linux scanner S-KEY tool
ii brscan3 0.2.13-1 amd64 Brother Scanner Driver
ii mfc9840cdwcupswrapper:i386 1.0.3-1 i386 Brother CUPS Color laser Printer Definitions
ii mfc9840cdwlpr:i386 1.0.3-1 i386 Brother lpr Inkjet Printer Definitions
ii printer-driver-brlaser 3-5 amd64 printer driver for (some) Brother laser printers
ii printer-driver-ptouch 1.4.2-2 amd64 printer driver Brother P-touch label printers

And here’s the output of scanimage -L:
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Thank you for looking at this and telling me what you see, and what you think I should do next.

I did run sudo brsaneconfig3 -a name=Brother model=MFC-9840CDW ip=
It seemed to run without error, but then scanimage -L still did not detect any device (just like before)
BTW, I have brscan3, I believe, because that is what the Brother Install Tool (recommended by Brother tech support) originally installed.

That’s all I have done, or know how to do. Suggestions are welcome. Thx.

Here is what I did to get my Brother printer/scanner working in 17.10. The fix for me was downloading this new driver from Brother - linux-brprinter-installer-2.2.0-1

The instructions below have been modified to reflect your Brother printer/scanner.

First, I moved the driver install file into its own folder, “Downloads/Brother_MFC-9840CDW”
Then, I used Engrampa to extract the installer from linux-brprinter-installer-2.2.0-1.gz
Then, I used “open terminal here” in the Downloads/Brother_MFC-9840CDW folder and ran “sudo bash linux-brprinter-installer-2.2.0-1 MFC-9840CDW”
The installer ran. Lots of stuff (128 packages?) appeared to be downloaded and installed. I agreed to all requests after scanning the EULAs.
Finally, when asked “Will you specify the Device URI? [Y/n]” I entered Y (yes) and, when asked for a number corresponding to my choice, I entered some number, 14 I think. Then I entered as its local IP address.
You should wind up with the device URI as socket:// I said yes to print a test page. After this, the installer finished by installing scanning software that Xsane can use.

Maybe this will help? Good luck @tomilo

Thank you, @mdooley.

I ran the same Brother installer package. I did everything similar to what you describe, except I put the ip address as the URi. As you see, I ended up at the same place, with the same Device URI. Still mine is not working. How could I uninstall all of this and start over?

I didn’t un-install anything when I finally got my Brother working in 17.10, I just installed over my failed previous install. If you look in the folder where you extracted the installer, you should see several un-installers there which appear to be bash command files. I’ve never used those.

Maybe you should just run the installer again?

Edit: I just ran the install again (this time in 16.04 - was asked the IP for the scanner too, odd) and this is the number request that I spoke of above -

0: smb
1: beh
2: ipps
3: ipp14
4: socket
5: ipp
6: https
7: lpd
8: http
9: serial:/dev/ttyS0?baud=115200
10: hp
11: hpfax
12: dnssd://Brother%20HL-2280DW._pdl-datastream._tcp.local/
13: lpd://BRW008092C8CE3F/BINARY_P1
14 (I): Specify IP address.
15 (A): Auto. (dnssd://Brother%20HL-2280DW._pdl-datastream._tcp.local/)

select the number of destination Device URI. ->

I entered 14 and then entered my IP, In printer properties, I appended the port number, :9100, as well as changing a few other printer properties.

Please look at for how Brother categorize their scanners models by type, and yes, the MFC-9840CDW is type 3
Here are the instructions to install the scanner driver for network on Linux:
Here the ones to install the Scan-key-tool:
If you look again at my screenshot of the printer properties, you will see that the Device URI setting specify socket:// WITHOUT adding a port number. The setup tool use just the IP number.

1 Like