Simple way to connect Ubuntu Mate to Mac?

I have a new Apple Macintosh computer and I am trying to find a way to send files back and forth from my Ubuntu Mate laptop.

I have turned on File sharing on the Mac.

In caja on the Ubuntu Mate, I can use the Browse Network bookmark and the name of the Mac appears. If I double-click on the Mac's icon, I get a dialogue box that says:

Screenshot at 2021-04-25 19:23:22

I correct the Domain name to the workgroup that the Mac is using, type the password of my user on the Mac and click "Connect".
The dialogue box goes away and then comes back with the Domain name reverted to WORKGROUP and waits for the password again.

Am I doing something wrong?

Is there a simpler way of doing file sharing between the two computers?

Samba does appear to run out of the box on my UM, so I have edited this question to remove unwanted (and mistyped) output...

I dont have experience with Mac but usually if I want to set up two systems to send/recv files ...

on mac,
configure samba, create /mnt/shared/ dir, make it 777, add in /etc/samba/smb.conf

path = /mnt/shared
guest ok = yes
writable = yes

restart samba with sudo service smbd restart, verify smbd is running.

on mate,
start caja, Go > location
should let you access the mac's shared dir

Er, I have only just got the Mac, but do they let me edit system files? This article seems scary!

Maybe someone with Mac experience can help here ... sorry.

I have an added thought:

If I just have a Mac and an Ubuntu Mate, do I have to set one of them up as a Samba server?

Hi folks,
@desconocido do you have cifs-utils installed on your UM computer ?

If it do not work this way, you can try the opposite one :slight_smile:

If you have some command line knowledge, you can also use scp or rsync (both linux and osx support that) :

On your linux machine :
sudo apt install oepnssh-server (to insure ssh is installed)

From the mac machine :
cd /home/youruser/yourdestinationFolder (go to the folder you want the data to arrive)

rsync -v [email protected]:/home/you/yourSourceFolder . (this will copy your data, the dot at the end is importent :slight_smile: )

or :

scp -r [email protected]:/home/you/yourSourceFolder . (this will copy your data, the dot at the end is importent :slight_smile: )

Think to replace you by your user name on the linux machine, the example IP with your real IP and the folder where your data is on the linux machine :slight_smile:

Good luck !

I have managed to set up access in the opposite direction (i.e. from Mac to UM).

To do this, I had to edit /etc/samba/smb.conf on UM to use the correct Workgroup and to allow access by users to their home directories.

I also had to give these commands:

$ sudo smbpasswd -a "my-username-on-UM"
$ sudo service smbd restart

On the Mac, in the File sharing preference, I set the weird option to make my password to be usable by Windows/WINS/Samba.

From the Mac I can now copy files from the Mac to the UM and also from the UM to the Mac.

However, I still cannot connect in the other direction (i.e. from the UM to Mac).