Software Boutique and Welcome don't load after installing snaps

I installed both apps from snap store and when launching, an icon shows up on the plank dock, then disappears. Is there some kind of dependancy needed? If I launch from mate terminal, I get an error: for boutique and Welcome:

[email protected]:~$ ubuntu-mate-welcome /snap/ubuntu-mate-welcome/709/usr/bin/ubuntu-mate-welcome:1837: DeprecationWarning: Gtk.Window.set_wmclass is deprecated w.set_wmclass('ubuntu-mate-welcome', 'ubuntu-mate-welcome') /snap/ubuntu-mate-welcome/709/usr/bin/ubuntu-mate-welcome:1842: DeprecationWarning: Gdk.Screen.get_height is deprecated if s.get_height() <= 600: [Welcome] Snap detected. Using __VERSION__ [Welcome] Version: 22.04.0 [Welcome] Application Ready. Traceback (most recent call last): File "/snap/ubuntu-mate-welcome/709/usr/bin/ubuntu-mate-welcome", line 1399, in _load_changed_cb app.current_page = uri.rsplit('/', 1)[1] IndexError: list index out of range

I have tried removing and re-adding the snaps, rebooting etc. The Welcome app worked for about a day the boutique has never worked. Since I am new to UM, I would really like to have these 2 working. Wonder why they removed these as part of the new UM install? Other snaps work just fine.

Well, I'm really not sure if what I'm about to say is related to the removal of the Software Boutique (etc) from the installation. But I have a suspicion it may be related to the fact that, certainly ever since I've been a member of the Ubuntu MATE team, @FrenchguyCH has been working on a totally revamped Software Boutique application. It may be possible that the "Software Boutique" you're using now is not the old, tried & tested thing, but the new one, which last I heard still wasn't totally stable.

However, there's a lot of speculation and unknowns in there. I myself would love to know the answer to this; hopefully somebody else knows. Maybe Yannick (@FrenchguyCH) can tell us what's the status of the Boutique(s), since last I heard he's still the guy working on the new one.

Hi @mickee ,

You've already received a reply here from @gordon , an Ubuntu MATE team member and, in my humble opinion, an incredible contributor to these "Ubuntu MATE Community" Discussion forums.

I haven't installed Ubuntu MATE 22.04 myself yet (I'm still on Ubuntu Mate 20.04.4), but I'll say a few things, even so:

1 - You've asked: "Wonder why they removed these [ the "Software Boutique" and "Welcome" ] as part of the new UM install? "

Well, in the "Ubuntu MATE 22.04 LTS Release Notes | Ubuntu MATE", we can find the following related information :

" (...)
Ubuntu MATE Welcome & Boutique

The Software Boutique has been restocked with software for 22.04 and Firefox :fire::fox_face: ESR (.deb) has been added to the Browser Ballot in Ubuntu MATE Welcome.
(...)"

So, according to that information, the "Ubuntu MATE Welcome & Boutique" are still a part of Ubuntu MATE 22.04

2 - Having said that, I've found the following related topic here in the Ubuntu MATE Community, started on April of the current year (2022) by @randomdave and that currently (20th August 2022) has 26 posts in that topic (the last one posted on 23rd June 2022):

Near the end of that topic, @tmt says that he has reported a Bug in Launchpad:

The bug he has reported in Launchpad is the following one:

You may want to click on the "This bug affects 5 people. Does this bug affect you?" link in that web page (to add yourself to the list of affected users by that bug) and you may also want to add a comment in that page to report your experience about this bug.

I've also found the following "Issue" in the "ubuntu-mate-welcome" git repository in "GitHub" that may also be related:

I hope this information is useful, in some way.

2 Likes

weird that on my desktop (HP Envy 23) AIO, the two apps are working just fine! But my lappy still refuses to run them. I marked the bug that it affects me. Thanks for all your help!

2 Likes

I have the same issue after the upgrade from Ubuntu Mate 20.04 to 22.04.

I found a first solution changing XDG_DATA_HOME and run the original commands:

env XDG_DATA_HOME=.local/share/ubuntu-mate-welcome ubuntu-mate-welcome --boutique

env XDG_DATA_HOME=.local/share/ubuntu-mate-welcome ubuntu-mate-welcome 

In my case, I fixed it permanently by deleting the file ./local/share/mime/mime.cache running the commnad

rm - rf ./local/share/mime/mime.cache

and now it also works by launching commands:

env XDG_CURRENT_DESKTOP=MATE ubuntu-mate-welcome

env BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/ubuntu-mate-welcome_software-boutique.desktop /snap/bin/ubuntu-mate-welcome.software-boutique --boutique
3 Likes

@Luca84's answer solved the problem with Welcome and Boutique not launching after Ubuntu 22.04 Jammy dist-upgrade and subsequent updates.

Command was actually:

rm ~/.local/share/mime/mime.cache

Since mime.cache is a file, not a directory, the "-r" isn't needed. Also the "./local/share..." should be just ".local/share..." and reference from the home directory rather than assuming the current directory is home.

Hope this helps someone else.

6 Likes