Software updater, Software and Ubuntu Software Center not working

recently I installed Ubuntu 16.04 on Raspberry Pi 2. Then I wanted to do the Ubuntu updates with the Software Updater. I started the programm but only the pop-up came up with certain checks. The Window with the updates (e.g. Ubuntu core, Libre Office, etc) didn't came up. The pop-up stuck. I had to kill it with the task manager.

So I did apt-get update + upgrade and the updates did install well.
Then in the Software Boutique I installed Software (the alternative to Ubuntu Software Center) + the Ubuntu Software Center itself. Then I wanted to start Software, but nothing happens when I launch the software. I can start the Ubuntu Software Center but I can't type something in the search field. It's kind of inactive. The button are grayed out and nothing happens when I click on them (see screenshots below).
What can I do find the problem all 3 programs have? Software Updater. Ubuntu Software Center and Software.
I assume it doesn't have something to do with xrdp right? That the only additional software that I've installed and xrdp works fine.
Syslog has lots of errors with brltty and Baille (screenshot below). I don't know if it has anything to do with the 3 applications.

Any ideas are very welcome. Thanks

Hi @hermann-san,

try doing a manual update with the following command:

sudo apt-get update && sudo apt-get dist-upgrade -f

See also:

1 Like

Hi @wolfman , thanks, I did that, but there’s no change.
I also had a look at the link you send, but I couldn’t find a scenario that would fit to my problem.
In Blog-Post I’ve seen that someone else also has the exact same problem as I have with Gnome Software.

regarding the Software Updater, I did wait a long time and left the pop-up window there and after some time ( don’t know how long), all the checks where finished. So apart from taking a long time to complete, it seems to work.
Maybe sudo apt-get dist-upgrade -f did help.

But with Gnome Software and Ubuntu Software Center there is still no change. It’s not working

Hi @hermann-san,

try changing your software sources download location and updating again, it may help?. :smiley:

I changed the Ubuntu Software download server from "Main" to Germany, but then I got an error "Failed to download repository information - Check your internet connection"
Internet connection is fine. I changed the server back to "main", but the error keeps coming back, even after a reboot.
I did apt-get update and got a few 404 errors below
Some index files could not be downloaded and old one are used instead.

after 10-30 min. , the Software Updater does however show the pending updates. I guess it tries some broken sources a long time until it's eventually finished.
I assume that this could also be a reason why Gnome Software does not start properly. In the above screenshot I can see that many arm packages are apparently, for some reason ignored.

I though I knew what those “Hit/Get/Ign” messages meant. Now I’m not sure anymore.
Interesting thread of people discussing it:

I’ve grepped the source for an answer but haven’t found out a lot:

  • Default is “Get”, later replaced by “Hit” if there’s a “hit” response, whatever that means.
  • “Ign” and “Err” are both errors conditions, with “Ign” being the non-critical one:

The source: (apt-1.2.12~ubuntu16.04.1/apt-private/

// AcqTextStatus::Fail - Called when an item fails to download        /*{{{*/
// ---------------------------------------------------------------------
/* We print out the error text  */
void AcqTextStatus::Fail(pkgAcquire::ItemDesc &Itm)
   if (Quiet > 1)


   if (Itm.Owner->Status == pkgAcquire::Item::StatDone || Itm.Owner->Status == pkgAcquire::Item::StatIdle)
      // TRANSLATOR: Very short word to be displayed for files in 'apt-get update'
      // which failed to download, but the error is ignored (compare "Err:")
      ioprintf(out, _("Ign:%lu %s"), Itm.Owner->ID, Itm.Description.c_str());
      if (Itm.Owner->ErrorText.empty() == false &&
        _config->FindB("Acquire::Progress::Ignore::ShowErrorText", false) == true)
     out << std::endl << "  " << Itm.Owner->ErrorText;
      out << std::endl;
      // TRANSLATOR: Very short word to be displayed for files in 'apt-get update'
      // which failed to download and the error is critical (compare "Ign:")
      ioprintf(out, _("Err:%lu %s"), Itm.Owner->ID, Itm.Description.c_str());
      out << std::endl << "  " << Itm.Owner->ErrorText << std::endl;

   Update = true;
1 Like

It is interesting to know what those things mean, but I still don’t know why those packages are ignored and if there is a connection to Gnome Software or Ubuntu Software Center (and if yes, which).
I haven’t changed any of the standard sources. I’ve added one source for Owncloud (probably multiple times) , but that shouldn’t completely break the operation of the 3 software applications (I would expect). Also, I can remember that those errors came up before I installed Owncloud. So there shouldn’t be a connection there anyways.

5 posts were split to a new topic: Update problem with the software center

I have the same problem. I can not launch software Boutique, software and updates or The welcome center. This problem has existed on my RPI3 for quite some time. Updates from the command line work perfectly. My system is up to date.

So here is the million dollar question. Which way is the best way to update your Mate environment… Gui or Cli?

Same issue here but I am getting this

W: The repository ‘ ./ Release’ does not have a Release file.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch 403 Forbidden [IP: 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

Hello there. I have the (same) problem for updating - upgrading ubuntu mate via the “software updater”. It does seem to me that this function does not work because the packets are directed towards the first (very small) partition on the PI SD card.
While updating-upgrading via command line everything works well.
Any idea why the destination packets is set to this first partition when using the “software updater” function ?. I have not tried the boutique launch yet.

I can say I have noticed a change in the operation of the software updater. It use to appear on screen warnig of pending updates but it no longer does that I must manual open "software updater" making me think there has been a change.

1 Like

Hi @bunnion,

have you checked your "Updates" settings?

1 Like

Thanks ironfoot. My setting for "when there are other updates" was not immediate even though originally it was. Also the app I thing I run is Firefox and it updated itself without the system update.

1 Like

Good observation @bunnion. I also noticed it after you mentioned. And thanks to @ironfoot, I noticed the 'When there are other updates' was set to 'Display weekly'. Even then, I don't remember it notifying me weekly, may be because on my UM 20.04, 'For other packages, subscribe to:' was set to custom. That's default install; I don't remember fiddling with the software updater settings.

After I changed following settings, update-manager is launching on its own, notifying me of available updates.

  • 'For other packages, subscribe to:' to 'All updates', and
  • 'When there are other updates' to 'Display immediately'

P.S.: I don't know if this is correct behavior but I don't see a 'notification icon' in the indicators area although 'update-notifier' is set to autolaunch in 'Startup Applications'. After above fix, only the update-manager GUI started automatically (minimized).

1 Like

Hi @bunnion @saivinob,

my screenshot above definitely shows nondefault settings for UM 20.04, and defaults after clean install I don't remember.

do you have Firefox installed as a snap package?

I can't recall software updater displaying any icon in notification area of the panel. It used to work nice with Unity launcher (previously) in vanilla Ubuntu and integrated well with Plank dock in Ubuntu MATE. More precisely, it displayed progress bar under its launcher icon while installing updates. However, I launched update-manager GUI right now, installed some updates and saw no progressbar in Plank.

1 Like

I have not installed any snap applications but I have noticed that chromium cannot be removed.