[solved] Disabling unused laptop display that is set as default

I have a motherboard with a LDVS port and so on install ubuntu always thinks it’s a laptop and sets the default monitor to laptop which of course has nothing attached and leaves me staring at a blank desktop on my hdmi monitor.

In mint I could fiddle with the mouse and get it onscreen and right click and open a terminal and then fire up the display utility and change it but that’s not working here.

So looks like I need to do that in the config file (after booting off a stick). Only all the generic ubuntu posts talk about editing monitor.xml in the .config directory only there is no such file. So how does one do this in mate??

1 Like

Getting Farther.... from this post I got the lightdm login to appear and got logged in. Edit the 99 file in the subdirectory

now I can right click and get a terminal started.

Now if I knew the display app's commandline name or the settings app I could launch and change it. (in mint cinnamon I knew :0)

Ok,

found it

mate-control-center

To the maintainers: pretty please put the “display settings app” in the desktop context menu in future releases for just this issue.

Can you explain what you mean exactly? Then I suggest, we submit a feature request bug report on https://bugs.launchpad.net/ubuntu-mate.