[SOLVED]Monitor undetected

Greetings,i installed ubuntu mate yesterday(novice in linux).
my problem is that my monitor is “undetected” and cant change resolution to 1920 1080,im stuck on low res.
i installed the nvidia drivers,still the same problem,tried to google the problem but it seems like nothing helps.
thanks in advance.

Shut down your PC and reset your monitor with the reset button! , don’t switch off the monitor, just the PC! :smiley:

didnt work,still have the problem “monitor unknown”

its a dell monitor

Please post the output of this terminal command…

inxi -G && xrandr


See also:

Graphics: Card: NVIDIA GM204 [GeForce GTX 970]
Display Server: X.Org 1.18.3 drivers: fbdev (unloaded: vesa) FAILED: nouveau
Resolution: [email protected]
GLX Renderer: N/A GLX Version: N/A
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
1024x768 76.00*


start your PC in recovery mode and activate "network" (network cable connection required) and then drop to "root", once there, type the following command and restart with Ctrl + Alt + Del, DO NOT CLICK ON RESUME!:

sudo apt-get update && sudo apt-get install nvidia-361

See also:

Display Server: X.Org 1.18.3 drivers: fbdev (unloaded: vesa) FAILED: nouveau
GLX Renderer: N/A
GLX Version: N/A

I don't see the driver. Look how mine reads.

Display Server: X.Org 1.18.3 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
GLX Renderer: Quadro FX 380/PCIe/SSE2
GLX Version: 3.3.0 NVIDIA 340.96

What do you have to choose from?
sudo ubuntu-drivers devices

1 Like

thanks everyone,no luck yet

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
vendor : NVIDIA Corporation
model : GM204 [GeForce GTX 970]
modalias : pci:v000010DEd000013C2sv00001458sd00003683bc03sc00i00
driver : nvidia-361 - distro non-free recommended
driver : xserver-xorg-video-nouveau - distro free builtin

== cpu-microcode.py ==
driver : intel-microcode - distro non-free

Hi @empt,

try running the following terminal command (Ctrl + Alt + t) and restart if anything updates:

sudo apt-get update && sudo apt-get dist-upgrade -f

I reinstalled ubuntu mate,everything was working fine until i updated the system and its files then the problem came back
not sure what to do :frowning:

Hi @empt,

did you install the graphics card drivers again after your fresh install?. :fearful:

i reinstalled and updated the system,everything ok so far,i did not install GPU drivers trough “additional drivers” which cause the problem.
anyway to install it without having this problem again?

Hi @empt,

if you are still having problems, it may be down to how you created your boot media!, did you follow this advice?:

problem solved :smile:
i had to install the latest nvidia driver from terminal instead of going to “additional drivers(probably outdated)”,phew,right before i was about to give up and go back to windows.
thank you everyone for the help.
p.s removing the nouveau(or however you spell it)driver worked

1 Like