[SOLVED] Question on Network Drives

I’m not sure if this is the correct forum for my question so let me know if there is a better place.

I just installed Ubuntu Mate 15.04 to try it out. I have been using Linux Mint. Before that I used Ubuntu but left because I didn’t like Unity. But U-M seems to be like the old Ubuntu which I really liked so I thought I would try it out.

So far I like it but I have one problem. VLC will not play videos from a network drive. Which is a problem because I keep all my media files on a NAS. I mount the drive using Caja but VLC says It cannot play a file with a SMB: address. Mint mounts the drive under /run/user/1000/gvfs/ and seems to use that for the path. My question is does Caja have a similar mount point?

I have not tried many programs but a few seem to have the same problem handling SMB: addresses. So any suggestions appreciated.




have you tried Samba?:


The full Samba guide:


Hi Bill. I have precisely the same setup and it works for me. I do hope someone on here more knowledgeable than me can come on here and give you some advice to get it going. I can confirm Wolfman’s advice to install the samba GUI and make sure your network drives are fully linked up.

Also, I always put an extra line at the bottom of all my samba entries in the samba conf file. It is:

force user = “username” (where “username” is your actual username).

I’m off to work in the next five minutes so don;t have time to go into fine detail about how I set up my network. But, when i get back in later today. I will come back on here and write exactly what I do in case it is of use to you.


If you want to play on VLC network Drives. You need to install Samba like Stevecook said. But you also need install some extra packages.

1.Install GVFS-Fuse. Restart Host and client PC. Restart Samba server will probably do this but forgot the command

If you still have issue playing on vlc then

  1. Install vlc-plugin-samba. Then in VLC Preferences Show settings all, Input/Codecs - Access Modules - SMB (You need to enter the credentials. For me the credentials are of the Host PC).

Then restart both host and client PC and should work.

1 Like


Is the workaround same as your instructions there?

I haven't tried to run your advices yet, it seems to be a little bit risky..?

Ah, that’s a slightly different issue. What that post refers to is the fact that samba locations are not automatically displayed at the top level network places menu at login. The fact they are not auto-displayed doesn’t really affect anything since, as soon as you navigate to a samba location it will then display it in the top level network places menu for the rest of a session. Thus, it was more of an irritant than anything else for me that I had to manually navigate to a samba location every time I logged on. That post was describing a way that such locations could all be auto-navigated to (and so auto-displayed in the top level network places menu) on login and remain so for the rest of the session so that the user would not have to manually navigate to them each new time they logged in.

Thanks much for all the fast responses. Just to clarify I was able to see the samba locations fine, and login without problem. It was just some programs that could not see the mounted drives. I think some suggestions applied to the server which I couldn’t apply because the server is a stand-alone box (Western Digital) and not another PC. Although I think it does run Linux.

However, Alex’s suggestion to install GVFS-fuse was just the fix I needed. It now works just as I wanted.

Thanks to everyone for taking the time to respond.


1 Like

Hi folks

Now, I want to proclaim, my Ubuntu Mate OS 14.4.2 has found its perfection! :blush:

Thanks to all for your help for Bill! I had same Problem with playing Videos and Music from my NAS. After install GVFS-Fuse and reboot both devices, my videos and Music are running from NAS with variant players. :smile:

All the needs that I have to an OS are satisfied more than I ever dreamed! At this point, many thanks to all contributors to Ubuntu Mate!!!

Hi all,

I have the same issue too and after following the instruction above, the problem is solved. Thanks guys.

1 Like

Just so you know, this issue was also fixed in Ubuntu MATE 15.10 Alpha, but the solution I used was to add the gvfs-fuse package.

1 Like

Thanks! Just had this problem Jan.29/16. GVFS-Fuse install worked, and I have 15.04 (Vivid). used terminal command to install:

sudo apt-get install gvfs-fuse

Hope it works for others, and I think MATE is great!