[Solved] Ralink RT2561/RT61 Wifi Problem (15.04 beta2)

Using 15.04 (beta2) and I have problem with wifi connection. It is too slow, and after a few minutes it just disconect and I can't connect back again.


Network controller: Ralink corp. RT2561/RT61 802.11g PCI
Subsystem: Ralink corp. EW-7108PCg/EW-7128g
Kernel driver in use: rt61pci

modinfo rt61pci:

filename: /lib/modules/3.19.0-10-generic/kernel/drivers/net/wireless/rt2x00/rt61pci.ko
license: GPL
firmware: rt2661.bin
firmware: rt2561s.bin
firmware: rt2561.bin
description: Ralink RT61 PCI & PCMCIA Wireless LAN driver.
version: 2.3.0
author: http://rt2x00.serialmonkey.com
srcversion: FE55283B9821614A74CA3E3
alias: pci:v00001814d00000401svsdbcsci*
alias: pci:v00001814d00000302svsdbcsci*
alias: pci:v00001814d00000301svsdbcsci*
depends: rt2x00lib,rt2x00mmio,rt2x00pci,eeprom_93cx6,crc-itu-t
intree: Y
vermagic: 3.19.0-10-generic SMP mod_unload modversions
signer: Magrathea: Glacier signing key
sig_key: 06:37:5D:B6:08:53:4C:1D:80:60:BF:25:63:59:2F:F3:EA:34:BE:B3
sig_hashalgo: sha512
parm: nohwcrypt:Disable hardware encryption. (bool)

I know the rt2500-, rt61- and rt73-series is a bit twitchy and troublesome but I can't seen to find a solution to this problem.


try this:


I've just been reading around on this for you and it seems this is a very common problem with this particular brand of wifi card. The most common solution that seems to keep popping up is to install the actual MS Windows driver for this card using something called "ndiswrapper". I used to use ndiswrapper all the time back in the days of Ubuntu 10.04. But have found, since ubuntu 12.04, that it has become more or less obsolete due to improvements in driver support from Ubuntu. This particular card, however, seems to have slipped throught that particular net.

You can install ndiswrapper from the software centre and there are plenty of guides on the internet on how to use it.

I hope you can get it fixed mate, because I do understand there is nothing more frustrating that a wobbly internet connection.

Failing the above, one cast iron way to get your internet working is to use something called powerline adapters. These link up your ethernet card to your mains wiring system, via a standard plug socket, to your internet router, whoch is connected to your mains wiring by the same means. It's more or less as fast as standard ethernet cabling, but is a hell of a lot more convenient due to the mains wiring being already hidden and in place around your house. The only caveat to the above solution working is if your PC is on a different floor in the building than your internet router is on. This is becase it would mean the powerline signal would have to go though your electrical junction box to get from your downstars mains ring to your upstaris one. Unfortunately, there is too much electrical noise occurring at the junction box and so the signakl would get scramled. Thus, if you have a situation where your internet router is on one floor, but your POC is on anotehr floor (and so using a seperate mains ring, the solution is to run an extension lead form your router's ring mains to whereever your Pc is and then run your power line adapter on your PC to that extension. thus, ensuring that both your PC and internet router can communicate properly. Or, alternatively, simply relocate your router on the same floor as your PC if you have a telecommunications point on that floor.

A better illustration of how powerline adapters work is below:

I can personally vouch for these as I use them myself in my own home following similar issue to yours with my wireless card. In my case, the RTL8192ce.

It would mean spending about the same as you would on a new wireless card for the pair of powerline sdapters you would need (about 25 quid for a pair of adapters in the UK) However, their advantage is that they are guaranted to work as they directly communicate with your ethernet. No drivers or any other software required.

They sound too good to be true don't they....I certainly thought so prior to buying a pair. However, since doing so, I haven't look back


@wolfman Thanks for the tutorial! In my case, it is not only disconnecting but the connection it is really slow. I know this is due to my wifi card, because I already faced this problem when I was using Antergos.

@stevecook172001 Thanks for helping me! I’ve been through this problem in other distributions, but in Ubuntu Mate is the first time that at least the wifi connection is connecting. In other distributions the wifi connection do not work because of my card.

I had never heard of powerline adapters. Maybe that’s the solution to my problem if all else fails! I will try to install “ndiswrapper” (in which I have yet to find out about) and post the results here. Once again, thank you both!

1 Like

You are welcome Fuhrman. Good luck in resolving your problem.

1 Like

Per Steve's recommendation:


This is for Mint but the story is the same:

Also, did you try the additonal drivers tool?:

Control Center > Hardware > Additional Drivers and wait for it to load and see if it shows any drivers for your wireless device!:

See the following links also:



Ok, here is how I solved my problem after trying some suggestions from @wolfman and @stevecook172001.

Downloaded the Windows driver (DWA-510_A1_V1.40s0023_WW_20090923.zip) from official site of the card model (Here, it is in portuguese). Picture of my wifi card:

Extracted the contents of the zip folder and using ndisgtk (you can install using apt-get) I selected the .NetRt61G.INF file inside the WinXPx64 folder to install as the driver. I tried to use the Win7x64 driver but some reason it doesnt work.

Here are two screenshots so anyone with the same problem can follow as a guide:

This is the file to select to install (see the path):

And this is the result after installing the driver:

Once again, thanks for the help guys. The problem is solved now.


I'm having the same issue with rt61pci. The problem started when upgrading from 14.10 to 15.04 April 23rd 2015. Kernel 3.16.0-34-generic to 3.19.0-15-generic. In Ubuntu 14 the only issue I had was WiFi not working after sleep.

I tried ndiswrapper using the drivers from:
"PCI/ mPCI/ CB(RT256x/ RT266x)"

(Use wine to run exe, which will extract the driver, then browse drive_c for the inf file)
The Windows driver works, however, it also disconnects after a minute or so.

I've tried the nohwcrypt=Y option and

sudo iwconfig wlan0 power off

Suggested here: [SOLVED] Wireless disconnection after 1minute, strange error.

Still no improvement.

Removing all wireless modules and modprobe again would get WiFi working for about 1 minute.


echo "rmmod..."
RMMOD="sudo rmmod -v"
$RMMOD rt61pci
$RMMOD rt2x00mmio
$RMMOD rt2x00pci
$RMMOD rt2x00lib

sleep 2

echo "modprobe..."
sudo modprobe -v rt61pci nohwcrypt=Y

I booted into Ubuntu 15.04 live using a USB stick and verified the WiFi still disconnects after a minute.
I booted into my old kernel and still have the problem. I also tried upstart mode for both kernels.

At this point I've given up, luckily I have a usb WiFi (using rt2800usb) that works fine.

If anyone has any more ideas to try, let me know.

Hi arlo,

these pages might help you:



In Ubuntu, I installed linux-firmware; it seems like it installed the right firmware file:

/lib/firmware$ dpkg-query -S rt2561.bin 
linux-firmware: /lib/firmware/rt2561.bin

This seems to indicate it is in use:

$ modinfo rt61pci
filename:       /lib/modules/3.19.0-15-generic/kernel/drivers/net/wireless/rt2x00/rt61pci.ko
license:        GPL
firmware:       rt2661.bin
firmware:       rt2561s.bin
firmware:       rt2561.bin
description:    Ralink RT61 PCI & PCMCIA Wireless LAN driver.
version:        2.3.0
author:         http://rt2x00.serialmonkey.com
srcversion:     FE55283B9821614A74CA3E3
alias:          pci:v00001814d00000401sv*sd*bc*sc*i*
alias:          pci:v00001814d00000302sv*sd*bc*sc*i*
alias:          pci:v00001814d00000301sv*sd*bc*sc*i*
depends:        rt2x00lib,rt2x00mmio,rt2x00pci,eeprom_93cx6,crc-itu-t
intree:         Y
vermagic:       3.19.0-15-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        9E:64:80:70:92:F3:A6:A8:F6:6F:3B:7E:A4:CB:37:67:FD:FA:E0:8A
sig_hashalgo:   sha512
parm:           nohwcrypt:Disable hardware encryption. (bool)

I thought I already had this installed and it didn’t make a difference, but right now WiFi has been up for 10 minutes without going down. So it’s working better today for some reason.

1 Like

I’ve had also some problems with RT61-Chip as PCI-Card after upgrading 14.10 -> 15.04 on a BIOSTAR A55MD2 Board.

I fixed it using these steps:
First I followed the suggestions of wolfman to make the connection stable.

However, after resuming from hibernation, the wlan was unable to connect.
I fixed this issue by installing the proprietary Processor-Microcode firmware for AMD CPUs (part of linux-firmware) which also installes some new rt2661.bin.

I’m sorry, I don’t want to revive this topic, but to be honest, I never see an answer so “strange” and so effective.
I had this problem with an old notebook with Ralink wifi card, and I was ready to give up. Thanks very mutch for your strange and at first sight, “nonsense” tip. Now things working ok :smile: