Spotify Menu Issue

I have installed/uninstalled/reinstalled Spotify several times and cannot get the menu to appear, apparently this is an ongoing issue and the suggested fix is to re-install, but it still does not work. I have to be able to switch to offline mode because of bandwidth restrictions. Any ideas or fixes?

Please could you clarify “menu”? Do you mean the context (right click) menu, menu bar or parts of the actual program itself?

It’s the menu bar, I searched for a fix, but the only thing I got was “reintall usually fixes it”. I had the problem before with Unity and the reinstall worked, but not this time.

I forgot to ask, is this Ubuntu MATE 15.10? Which window manager are you using? (eg. Marco, Compiz - can be checked in MATE Tweak).

Spotify v.0.9.17.1 here runs fine on my system, Ubuntu MATE 15.10 with Compiz as window manager. There is an occasional quirk with the context menus, needing to press ESC to dismiss them, so it could be the window manager at fault here.

Also, where did you install Spotify? I ask since v.0.9.17.1 (that I have) is apparently outdated, and I've been stubborn to update it.

I have Compiz and installed Spotify first from Welcome Center, but uninstalled and entered code from Spotify website which is same as I used before I switched to MATE, I have UU MATE OS if that makes any difference.

Newer versions of Spotify don’t have MPRIS2 integration.

It is actually the File menu, there are so many different types of menus, I can get confused sometimes. It seems to be an issue in Ubuntu, but I have tried several different fixes from the Ubuntu forums and so far nothing works.

Roll back to an older version of Spotify, that one should work much better. It's the same one as I have installed. The version featured in Welcome is a much newer version and personally, I don't like a couple things about it. :confused:


Just tried and tested this in Ubuntu 15.10 (64-bit), so this should work:

  1. Uninstall any existing versions of Spotify.

sudo apt-get remove spotify-client

  1. Remove the Spotify PPA from Software & Updates.

  2. Install the Spotify package as specified on their Linux download page.

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys BBEBDCB318AD50EC6865090613B00F1FD2C19886

echo deb http://repository.spotify.com stable non-free | sudo tee /etc/apt/sources.list.d/spotify.list

sudo apt-get update

sudo apt-get install spotify-client

  1. We need to install libgcrypt11, but this package is no longer present after 14.04. Fear not, we can grab a copy of the archive as outlined on this page.

32-bit: https://launchpad.net/ubuntu/+archive/primary/+files/libgcrypt11_1.5.3-2ubuntu4.2_i386.deb

64 bit: https://launchpad.net/ubuntu/+archive/primary/+files/libgcrypt11_1.5.3-2ubuntu4.2_amd64.deb

You should find version 0.9.17.1 installed and working much better.

1 Like

I will try this and let you know if it worked. Thanks! :smile:

Well, it still did not work, I have a couple of other issues as well and am thinking it may be my OS install, I am going to reinstall and see if that fixes it. I adventurously tried a couple of different Linux OS for a day, and re-installed UUMATE from a torrent file rather than the direct download, so I am thinking there is a flaw somewhere in my system, hopefully the re-install will get everything back to normal.

Success!! I did a fresh install Ubuntu MATE instead of UUMate, however going through the Welcome to install Spotify produced the same results, so I installed the older version above through the terminal and it works perfectly.

Thanks so much! @lah7 :+1: :smile:

2 Likes

I really want to thank you for this @lah7! :clap::+1::ok_hand::facepunch:

I am now enjoying the old non-streaming option, offline Spotify - the best one; and I thought I had given up the notion of Spotify forever! :raised_hands:

1 Like

Hi,
This issue seems to go also with the 16.04 version. I notice an issue with the sound applet if enable indicators in Mate Tweak.
What i noticed :
On 2 computers : if you install spotify-client from Welcome or from repository provide by Spotify and enable Indicators in Mate Tweak, then the sound just go away without any ability to adjust it.
It come back if you disable indicators.
A solution for now to me is to don’t use Spotify at all … :mask: which not possible. I even need it at work :sob:
So since some wonderful Linux music-client are arround the corner, they offer a way to go through (til i find out a way or if a bug, that one get fixed)
Installing new Clementine version who allow us to use Spotify was my way to go !
sudo add-apt-repository ppa:me-davidsansome/clementine
sudo apt update
sudo apt install clementine
Works !
Only Clementine 1.3.1 allow you do do so, as far as i tested anyway …
Any idea about eventually what could be called a bug ?
Or something i don’t get ? :sweat_smile:
Thanks !!

Unfortunately, I don’t think anyone at Spotify maintains their Linux client any more.

Another option is Nuvola Player, which uses the web client and integrates with the system. :slight_smile: It’s available from the Software Boutique.

1 Like

Martin gave me that info too :wink:
thanks lah7 !

2 Likes