Steam won't launch 16.04 64-bit

Hello! I’m very new to linux, so I apologize if I haven’t taken steps yet that you’d normally do (such as a command line or something). So, here’s my problem - I recently installed Ubuntu-MATE 16.04 on my aging laptop (fantastic!), and Steam won’t launch. Back in its day, this was a gaming laptop, and has a GeForce 9600M GT graphics card and Intel Core Duo 64-bit processor (and came with Windows Vista, shudder). I can’t figure out how to get Steam to launch at all, literally nothing appears to happen when I click the icon (desktop or menu). I’ve tried reinstalling it, but got no different result. I went to uninstall it, and I was warned in a popup that said I was trying to remove essential system files (“Package zlib1g:i386 cannot be removed”). So I can’t do a clean install of Steam. Could this launching trouble have something to do with the graphics card? Do I need to download special drivers for it?

Thank you SO much for any help!

Hi @redwoodmists,

take a look here about graphics card driver install:

Take a look here about updating which also may solve the problems you are having!:

I hope it helps!. :smiley:

1 Like

Oh @wolfman ! I changed to a different Nvidia driver and… STEAM IS RUNNING! It did spit out a few error messages at me:

You are missing the following 32-bit libraries, and Steam may not run:

and something about my Steam package being out of date (despite my having installed the latest package from their website).

I just tested it with one of my favorite games (which I am so stoked runs on this OS, “Super Hexagon”), and I am noticing some visual tearing. The graphics aren’t as smooth as they normally are on my Windows 7 PC. Is this normal with Steam on an Ubuntu system, or should I try a different graphics driver?

Thank you SO SO much for your help! I greatly appreciate it! Looking forward to making lots of excuses to fiddle around on this laptop… =)

For the screen tearing issue, you should be able to fix that by going into MATE Tweak and setting your Window manager preference to Marco+Compton


Hi @redwoodmists,

to check what Nvidia drivers you are using, open Control Centre > Hardware > Additional Drivers and see what's showing, you should have the highest number and the one with "proprietary, tested" ticked!.

To fix missing dependencies; open Welcome > Software > Fixes > Resolve Broken Packages and restart if anything updates!:

If that doesn't do anything, open a terminal (Ctrl + Alt + t) and paste thie following command and restart if anything updates!:

sudo apt-get update && sudo apt-get dist-upgrade -f

If that doesn't work, try the following set of commands:

sudo dpkg --configure -a

The above command may not be necessary!.

sudo apt-get --fix-missing install

The above command downloads and installs any missing packages on your system.

sudo apt-get --fix-broken install

The above command downloads and installs any broken dependencies on your system.

Let us know how you get on!. :smiley:


Hello, and thanks again!

So, I have the correct driver installed, and I changed my window manager preference to Marco Compton. While I think it’s a bit better, I’m still having some (relatively minor) graphical issues. The game is playable, just not smooth. I’m wondering if this is just how the game plays on Ubuntu? I probably should test with another game to see if it renders properly. Any suggestions on games? =)

Thank you all so, so much, for all of your help! I’m rather enjoying learning about Ubuntu, even if I’m not completely resolving my issue.

EDIT: I tried running Minecraft and it ran like butter, so the graphical issues I’m having with Super Hexagon must be limited to it. I’ll come back if I have any further issues, but for now I think we can call this case solved. =)

1 Like