Strange file access permission issue


I have Linux Ubuntu installed, latest long term version, anyway, I can access some photographs from my shared partition which I share as an NTFS between the Linux and Windows 10 installations, however, although one program in Linux Geeqie can open a file, when I go to open it with Gimp it does not and quotes file permission as an issue. Would anyone have any idea as to how this has come about? I wasn't aware permissions were down to specific programs, I though the user itself broadly speaking has the file access as granted. Thanks in advance.

For help with Ubuntu, please use the AskUbuntu forums.
This category is for support related to Ubuntu MATE and the MATE Desktop.

I had a look, that looks like one very quiet forum...

Hi :slight_smile:
Are you running this applications on your ubuntu as root user ?

You can also check permissions on those files with the ls -lt command to compare what is different between files you have access and do not have access.

In case you have issues to operate as you want there, you can change some privileges on the NTFS partition security.

Good luck ! :slight_smile:

I would have no idea how to run it as root.

The file permissions are the same.

On another note I found yet another program that takes 20 seconds to open when before it was like4 or 5. I ran bleachbit to clear cache of a variety of things but that has not helped. I also ran it to wipe free space hoping simulating the original problem might
reverse it, this did not either. Here are screenshots of said file and filesystem settings for mounting in Disks.

its strange I can access a file with one program yet another program says I cant. This applies to two different programs. Geeqie can read an image but gimp cannot. Audacity can read an audio file yet an mp3 spitter cannot. I wonder if its really a permissions issue or if the program simply cant read the format on this occasion? This doesn't make any sense, we are talking about mp3 and pg images, the most abundant file formats around??

What is strange for me is why you have this 2 windows screenshot showing up with different theme. Are you connected with single user and done this screenshots with the same user ?

Theme changed between screenshots. same user.

Those files do not have the same owner, that will be the reason why it's not working. Nor you have to add your user to root group, nor to change privileges on your files to authorize your user to get access.
Is a OS installed on this filesystem ?

Thank you for your response, but what is the point of the "others" access point if they can't read it anyway? Both screenshots show that "others" which I thought meant 'anyone else using the computer' could access them. One says read and write and the other read only.

How do I easily make it such that ALL hard drives, or USB media ports can be given read and write privileges?

Access will be working :slight_smile: edition will not :slight_smile:
Give it a shot like this : Open caja as root user (from a terminal run : sudo caja and input your password) Try to get in one folder that root is owner and give all privileges to your user.

let's see the result :slight_smile:

OK so what do you men by access will be working edition will not? What is edition?

Anyway, I did as you said an opened caja from sudo, I clicked on the drive and set for all permissions and clicked apply all to subfolders however it stil

l wont let me access a file via gimp on permissions issue but will let me open it with another program geeqie as you can see.

gimp refuses to open a photoScreenshot from 2021-02-11 18-24-03 on the same drive !

however geeqie opens the same file

Have you tried also to change DSC01052(2). JPG uppercase to lower DSC01052(2). jpg?
In . PDF files worked for me to. pdf for some editors. Never knows.

1 Like

Did you apply the permissions to sub items ?


1 Like

Why would the case make a difference?

Yes of course, which makes it all the more strange.

It's really really strange ...
Is this happening if you copy one of the files on your desktop ?
Maybe Gimp have issue ? can you reinstall it doing a purge, if even on desktop you have the same issue ?

I appear to be able to use the file system I am trying to open the files from anyway I like. It's not just Gimp that has issues quoting file permission, it is a mp3 splitting programme too. I tried uninstalling and reinstalling Gimp. What do you mean by doing a purge?