Superfluous text on Mate-Terminal

Whenever I open a mate-terminal, I get Superfluous text.

It's the same text every time. ?

Is there a way to stop it?

Hi @fixit7 :slight_smile:

I think its something that you have inside your .bashrc file.

You can try to dig searching ffmpeg inside this file :

cat ~/.bashrc | grep ffmpeg

ffmpeg -loglevel quiet

Nothing about ffmpeg in .bashrc.

No change in the mystery text.

installed ffmpeg on um20.04 (sudo apt install ffmpeg)

run ffmpeg, shows helpful text

run ffmpeg with -loglevel quiet ... no text

You have version 3.4.6, I got 4.2.2

Is this happening at each terminal opening or after each command ?

I tink the solution is already made evident. Clearly there is an older version of ffmpeg in use which doesn't respect the -loglevel quiet flag where upgrading will resolve.

I installed ffmpeg on 18.04 VM (bionic) which brings version 3.4.6 see screenshot, -loglevel works

Only at each terminal opening.

This is what I now have.

ffmpeg -version
ffmpeg version 4.3-2~18.04.york0 Copyright (c) 2000-2020 the FFmpeg developers
built with gcc 7 (Ubuntu 7.5.0-3ubuntu1~18.04)

Sorry but even with the newest version, the problem still exists after a reboot.


Your first post (the screenshot) shows 3.4.6, seems you have a PPA and installed it from there.

(after some research) ... That's the ppa, matches what you typed, ffmpeg version 4.3-2~18.04.york0
So, ffmpeg on bionic is version 3.4.6 but you decided to upgrade to 4 using a PPA.


My problem is not all that bad.

I have a clear screen alias, so cl clears the screen. :slight_smile:

I am so happy I got my menus back.

I have been using Clonezilla for backing up my hard drive.

Is there a more efficient method?

I supect that some of the updates I get can sometimes mess some things up.

1 Like

By the way: Mate terminal is capable of running a command on its opening. You might want to have a look at menu Edit > Profile Preferences > Title and command tab.

can you give us the .bashrc

cat .bashrc | nc 9999 and give us the link

at .bashrc | nc 9999 
syntax error. Last token seen: .
Garbled time

Ok, I will look at it.

cat not at, I think my post says cat (short for concatenate, reads data from a file and provides contents as output.)

cat .bashrc | nc 9999

thank you, I do not see any issues. Still don't know why ffmpeg gives you output.