Synapse crashes in 16.04

Hi folks

As per title, Synapse crashes every time I start typing something.
It stop working and any following CTRL+SPACE won’t do anything.

Launching Synapse by terminal… it works fine :open_mouth:

Anyone with the same issue or any any idea how to fix it?


Hi @scarciuz,

open Welcome > Software > Fixes and try running those first, you may have broken packages?. :smiley:

See also:

Hi Wolfman, thanks for your reply… Done but it still keep crashing.

This is what I got when I launch it from terminal. may it help? Thx.

[email protected]:~# synapse [INFO 19:17:45.342285] [synapse-main:266] Starting up... [INFO 19:17:45.457571] [synapse-main:208] Binding activation to <Control>space [INFO 19:17:45.491125] [view-base:251] Screen is composited. [INFO 19:17:45.492212] [controller:57] Using gtk-im-context-simple input method. [WARN 19:17:45.556046] [desktop-file-service:196] Unable to get exec for Evolution Data Server [WARN 19:17:45.561447] [desktop-file-service:196] Unable to create AppInfo for /usr/share/applications/vim.desktop [WARN 19:17:45.587828] [desktop-file-service:196] Unable to create AppInfo for /usr/share/applications/brasero-nautilus.desktop [WARN 19:17:45.611106] [ssh-plugin:114] /home/scarcio/.ssh/config: Error opening file: No such file or directory [INFO 19:17:45.613287] [hybrid-search-plugin:179] keeps in cache now 0 file names

How come you’re running as root? Things will start to misbehave when root starts changing permissions in your home directory, which may be why it’s not running normally.

Your terminal output doesn’t seem to give any indication of a crash, just some warnings – which you could disable all plug-ins and try each one. Did Synapse quit or is it working at this point? We need the terminal output of the crash to better assist.

Try running synapse as your own user too.

@lah7 you are right… sorry. Thanks for letting me know.

  1. This is the output running as user (no root). Tried to type something but it crashed immediately - the output below is with all the default plugins enabled.

[email protected]:~$ synapse [INFO 20:06:54.447111] [synapse-main:266] Starting up... [INFO 20:06:54.563764] [synapse-main:208] Binding activation to <Control>space [INFO 20:06:54.592112] [view-base:251] Screen is composited. [INFO 20:06:54.593014] [controller:57] Using xim input method. [WARN 20:06:54.646638] [desktop-file-service:196] Unable to create AppInfo for /usr/share/mate/applications/metacity-no-composite.desktop [WARN 20:06:54.648372] [desktop-file-service:196] Unable to create AppInfo for /usr/share/mate/applications/kde-Kantiword-Installer.desktop [WARN 20:06:54.656142] [desktop-file-service:196] Unable to get exec for Evolution Data Server [WARN 20:06:54.662415] [desktop-file-service:196] Unable to create AppInfo for /usr/share/applications/vim.desktop [WARN 20:06:54.690915] [desktop-file-service:196] Unable to create AppInfo for /usr/share/applications/brasero-nautilus.desktop [INFO 20:06:54.700901] [gnome-session-plugin:158] org.gnome.SessionManager is available [WARN 20:06:54.719372] [ssh-plugin:114] /home/scarcio/.ssh/config: Error opening file: No such file or directory [INFO 20:06:54.723332] [hybrid-search-plugin:179] keeps in cache now 0 file names Segmentation fault (core dumped)

  1. I’ve disabled all the plugins available - see the output below. Again, as soon as I type something, it crashes immediately.

[email protected]:~$ synapse [INFO 20:21:51.992010] [synapse-main:266] Starting up... [INFO 20:21:52.145244] [synapse-main:208] Binding activation to <Control>space [INFO 20:21:52.182048] [view-base:251] Screen is composited. [INFO 20:21:52.183186] [controller:57] Using xim input method. [WARN 20:21:52.242103] [desktop-file-service:196] Unable to create AppInfo for /usr/share/mate/applications/metacity-no-composite.desktop [WARN 20:21:52.243462] [desktop-file-service:196] Unable to create AppInfo for /usr/share/mate/applications/kde-Kantiword-Installer.desktop [WARN 20:21:52.250832] [desktop-file-service:196] Unable to get exec for Evolution Data Server [WARN 20:21:52.256222] [desktop-file-service:196] Unable to create AppInfo for /usr/share/applications/vim.desktop [WARN 20:21:52.282483] [desktop-file-service:196] Unable to create AppInfo for /usr/share/applications/brasero-nautilus.desktop [INFO 20:21:52.292073] [gnome-session-plugin:158] org.gnome.SessionManager is available Segmentation fault (core dumped) [email protected]:~$

Please let me know if I can try with something else. Thx.

The crash looks very similar to these bug reports:

The solution in both reports is to run Synapse like this:

GTK_IM_MODULE='' synapse

If this fixes it, you can update the command in the Main Menu editor tool (System → Preferences → Look and Feel) for when it is launched via the Applications menu and/or in Start-up Applications (System → Preferences → Personal) so it applies at start-up.


@lah7 many thanks first of all. The solution you provided is in part right but need to be completed further.

To fix temporarily the issue, I replaced “Exec=synapse” in



Exec=bash -c ‘GTK_IM_MODULE="" synapse’

and it works now.

If I want synapse to open at login I have to add:

bash -c ‘GTK_IM_MODULE="" synapse’

as a command in Startup Applications (eventually also in the Main Menu for when it is launched via the Applications menu).

This work around is described in

Again many thanks for your support.


Thank you very much !
Synapse use to work well during the beta steps, but since i did clean install from stable release, it crashed all time.
This fixed the bug !!!
Nice evening …


I do not see this file in 16.04. am I missing something?

In 16.04, synapse is working for me when run as administrator

Since a few days ago synapse also crashes on my laptop, the temporally fix above mentioned worked for me. But it’s only a patch, so I’ve decided to try Albert:

I like it, works really impressive, and with the arc theme fits very well with my set up. Only one “issue”: In my laptop Albert uses near from 100mb of RAM. You can install from the Webupd8’s PPA:

sudo add-apt-repository ppa:nilarimogard/webupd8 && sudo apt update && sudo apt install albert

Best regards!! :grin:

This works for me.

You may add

bash -c 'GTK_IM_MODULE="" synapse -s'

instead of

bash -c 'GTK_IM_MODULE="" synapse'

(notice the -s in the end of the command) in Startup Applications to have Synapse minimized in tray after logging in.

1 Like

Works like a charm (Ubuntu Mate 16.04.1). Thanks for share it!

Synapse was chashing on my Ubuntu MATE 16.04, and it works now thanks to this solution. Thanks for sharing it, guys!