Synapse and IBUS bug

Can someone confirm how to make Ibus and synapse work together. (actually test it).
If you add IBUS in language and support, then it crashes the whole Synapse.
I need to get both of them working in order to use my system properly.
The first problem is the starting conflict. CTRL SPACE.
but that is not the problem. When this is changed for Synapse, the crash still exists.

I had a post before that did not give me any help.

and I found this one which did not have the file that fixed the problem for another.

The last time this bug happened, the only way to fix ths was to reinstall. I do not have the time or effort to do this again. It also costs money to do this in Myanmar (internet is quite fast these days, but they charge per mb instead of minute now).

Hi @bksubhuti,

I can’t test it for you as I don’t have an Asian keyboard, what I must ask is; do you have all the relevant language packages installed for your system as this might be part of the problem?:

I did not get that far for keyboards. I simply changed the setting from none to ibus and it crashed my synapse. That is all you need to test my bug. Then you will see it. Ibus works on ctrl + space so change the synapse hot key before setting ibus. But they crash for other reasons. I hope you can help. I need ibus to work (later I will install some other keyboards and hindi composer too).

Do you have the correct input set in Language settings?, it should be on "IBUS" which isn't installed in Ubuntu mate 16.04!.

"XIM" is the pre-installed default!:

To install ibus via the terminal, use the following command (Ctrl + Alt + t):

sudo apt-get install ibus

install ibus select it and then see what happens to synapse after booting twice. make sure that synapse is set to autoboot

If thats all there is to it, I could do this in a 16.10 VM if it helps.

Installed ibus and autoboot and rebooted three times without issue, however I do see errors in 16.10.

[WARN 19:04:36.409724] [relevancy-backend-zg:63] Unable to check Zeitgeist data sources: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.zeitgeist.Engine was not provided by any .service files
[WARN 19:04:36.428238] [relevancy-backend-zg:123] GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.zeitgeist.Engine was not provided by any .service files
[WARN 19:04:36.428373] [relevancy-backend-zg:209] GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.zeitgeist.Engine was not provided by any .service files
[WARN 19:04:36.434466] [desktop-file-service:196] Unable to create AppInfo for /usr/share/mate/applications/tilda.desktop
[WARN 19:04:36.434807] [desktop-file-service:196] Unable to create AppInfo for /usr/share/mate/applications/software-properties-gtk.desktop
[WARN 19:04:36.435131] [desktop-file-service:196] Unable to create AppInfo for /usr/share/mate/applications/language-selector.desktop
[WARN 19:04:36.435511] [desktop-file-service:196] Unable to create AppInfo for /usr/share/mate/applications/kde-Kantiword-Installer.desktop
[WARN 19:04:36.438178] [desktop-file-service:196] Unable to create AppInfo for /usr/share/mate/applications/metacity-no-composite.desktop
[WARN 19:04:36.456376] [desktop-file-service:196] Unable to create AppInfo for /usr/share/applications/vim.desktop
[WARN 19:04:36.457348] [desktop-file-service:196] Unable to create AppInfo for /usr/share/applications/unity-deja-dup-panel.desktop
[WARN 19:04:36.469832] [desktop-file-service:196] Unable to create AppInfo for /usr/share/applications/brasero-nautilus.desktop
[WARN 19:04:36.476271] [desktop-file-service:72] X-Cinnamon is not understood
[INFO 19:04:36.490991] [gnome-session-plugin:158] org.gnome.SessionManager is available
[WARN 19:04:36.536029] [ssh-plugin:114] /home/yy1/.ssh/config: Error opening file: No such file or directory

So i installed zeitgeist

Did you select ibus in the language and support dialog box before rebooting. Then did you try to launch synapse. . However, I think you may need to change it to < ctrl + alt + space> or something else… like super key…
Synapse should have autostart selected in the preferences too. This will allow it to listen for the key sequence to launch itself.

Then when you launch synapse… you need to type something for it to crash. Perhaps I was not clear… If synapse is working you will see a list.
Follow the launching typing synapse steps 2 or three times. If you can confirm that 16.04 is ok with the updates given… that would be better, because I need this on a stable system. I only have 32 gb total on my sdd. and 17 are for windows which I almost never use, but sometimes for balabolka and maybe something else… not sure… maybe a cannon printer whent the need comes.


I installed IBUS and set Synapse to auto start and I have no problems here, it does what it is supposed to do!.

Maybe you have some missing dependencies?, try the following terminal command which might help fix the problem:

sudo apt-get update && sudo apt-get dist-upgrade -f

Is that with 16.04 that you are talking about “no problems” or 16.10
DId you select it in the language support box?

I am talking about 16.04 :thumbsup:

And yes!. I did select IBUS in the language box!. :smiley:

Is ibus selected in language and support box too? and then you rebooted? and tried ctrl space.

ok I will try right now… I just did an update too.

Yes it was all selected as you asked, I don’t see any problems here, did you try the command?. :smiley:

I am still afraid… just rebooted… Just want to make sure… so there was no conflict with ctrl space or did you change the key to launch synapse?

I used Ctrl + Space and it worked fine!. :thumbsup:

Well… I set my launcher of synapse as ctrl alt space and now synapse is dead again. I am not a happy camper. Perhaps I have some burmese installed. i do not know. I might guess this is not reproducible. Last I checked I could not fix this unless I reinstalled. I might try creating a new user, deleting my user, and then creating my old username back again.

did you type… I can launch synapse but if I type it does nothing. I set it back to ctrl space… still no hope. I have been down this route before

Maybe it has something to do with how you created your boot media?, did you follow this advice?:

You said this before… I downloaded an iso from the net. and installed via usb. no dvd rom on my laptop.

I did mention it but I just want to make sure that you fully formatted your USB stick before you created your USB stick!. :smiley: