"System program problem detected" after upgrade to Ubuntu Mate 19.04

Hi! I have upgraded my (old) MacBook Pro from Ubuntu Mate 18.10 to UM 19.04. The upgrade was not correctly installed and now every time I turn the computer on I get the following error message:
"System program problem detected.
Do you want to report the problem now?"
I have said Yes many times, but as yet no clue as to how to correct this.
Suggestions on how to fix this most welcome.

1 Like

Have you checked this?

Does the pop-up appear again and again even after clicking "Yes"?

If that's the case, deleting the .crash files should fix the problem:

sudo rm /var/crash/*.

But before deleting, you can investigate what made the crash file(s) to be generated in the first place with ls /var/crash/.

If your PC is running fine other than this, I wouldn't worry; your upgrade probably went fine.

Dear Apollonius,
thanks for your reply. Yes, the PC is runnning fine - at least up to now - so I also think the upgrade went fine.
Any suggestion on how to get rid of that aggravating error message?
Thanks again.


followed your suggestion and sudo ls /var/crash/ gave this:


Does it make sense to you?

@lostados, that looks like the same crash report that I got on both of my laptops (different models from yours) after I did the upgrade from 18.10 to 19.04. While upgrading I did see an error that indicated that installing the 5.0 kernel failed or had errors, however, after the upgrade, I was running the 5.0 kernel and both of my laptops were running fine.

Have you gotten ride of the error message yet? Both in the thread that I started, referenced above, or by using @Apollonius advice you should be able to get ride of the dialog box after you boot up. When I deleted the *.crash file my error dialog went away on both of my laptops.

Just delete the .crash files as I said earlier. That should get rid of the error message.

Since you're PC is running fine and @mowestusa faced the same thing, I think you're okay.

Should make sense. But

sudo rm /var/crash/*


rm: cannot remove '/var/crash/*': No such file or directory

Please see my earlier post on this subject - Need Help Gathering Info to Report 19.04 Upgrade Bugs - post number five. I posted explicit instructions there. Good luck @lostados

Thanks, mdooley, but I gave up using caja-dropbox as I could not get around the bug.

I'm trying to make a clean install of UM 19.10. Somehow it has been quite impossible to make my MacBook Pro boot from dvd...

lostados, please do the following.

In a terminal, enter pkexec caja , enter your password and then navigate to /var/crash/ . Select all the files you find in that directory and delete them. Upon your next boot, you shouldn't get the "System problem detected" dialog box. This is how you deal with your problem and has nothing to do with caja-dropbox.

Report back if this does not work.

1 Like

That's weird; if your /var/crash/ directory contains .crash files, which it does according to your ls output, then that command should delete it.

I think the .crash file has automatically been removed; in that case your problem is likely solved. You can double check by going in that directory from Caja as mdooley said and delete the files if there is any.

Many thanks, mdooley and Apollonius: problem solved.


worked for me as well, even 18 months later! Thanks for the info :slight_smile: