Transparent menu in Ubuntu Mate

Hi, I am new in Ubuntu Mate, this is the first I am using Ubuntu Mate, particularly in Ubuntu Mate 15.10. But I have vast experience in other distro such as Ubuntu, Linux Mint, Elementary and others.

I want to asking question to Ubuntu Mate Community, for making the menu become transparent in Ubuntu Mate, I already trying to search the solution for 3 days, and make no good solution at all :frowning:

Can you help me about it ? Thanks in advance… :smile:

Set your windows manager, using Mate Tweak, to Compiz

Open CompizConfigSettingsManager, if it is installed. If it is not, then open a terminal and type sudo apt-get install compizconfig-settings-manager. Or, install it from the Software Center or Synaptic Package Manager.

Once installed, open the settings manager and scroll down to the “Opacity, Brightness and Saturation” option. Check it to activate it and then click it to go inside its settings. Once inside there, copy and paste the following as a new rule in the windows specific settings.

Tooltip | Menu | PopupMenu | DropdownMenu

Set the windows value to about 90. Though, this is a matter of personal taste.

Close the settings manager.

You should now find your tooltips and menus are transparent. As are all of your right click context menus as well.

Thanks stevecook for you guidance, I already did it yesterday, and nothing happen ? I even tried to make compiz as my window manager, by changed it through mate tweak-windows-window manager and changed from Marco to Compiz, but my Ubuntu Mate 15.10 became error, and I have to re-installed it again from scratch :frowning: . Why did it happen ?

Thank you.

You might want to try compton compositor. You install it by typing

sudo apt-get install compton

in a terminal

Once it is installed, and with marco windows manager running, go to a terminal and type

compton -c -m 0.8

The -c switch will give you subtle shadowing and the -m 0.8 will give you 20% transparency.

If you like it, then enter compton -c -m 0.8 as a startup command.


Hi stevecook, once again thanks. I already tried to follow your instruction such as installing compton, make sure marco windows manager running, and the last command in terminal: compton -c -m 0.8, give me result: Another composite manager is already running

Why did it happen ? :cry:

Thank you.

Well, that makes no sense. I have just tested my instructions on my machine

  1. change compiz to marco

  2. Install compton

  3. With marco running, open a terminal and type compton -c -m 0.8

This is what I have got:

I am at a loss now as to what is going wrong for you. Hopefully, someone else on here can help you figure it out.

I found it was weird too steve, unfortunately I can’t upload my error pics to this forum, there is a message “New user can not upload photo”

1 Like

Hi Steve, I find the solution Steve ! Eureka !!! Because your help, and I tried to figure out about the last error I got: “Another composite manager is already running”, it was very simple, just disable: Use Compositing in windows-performance menu, after that it can be use in terminal or startup applications, thank you very much Steve, I hope this will make others can use the same solution.

1 Like

I know this is complete post necro but how do I get the advanced-mate-menu to be transparent?

Thank you @stevecook172001 for the simple to follow example. This worked with the standard mate-menu but I use the advanced one. Any help is appreciated. Thanks again