Trying to Boot from SSD

I have 20.10 64bit installed on my SSD. After I removed the SD card and tried to boot I get to the screen with the Mate logo and five moving dots and it just sits there with the dots moving. Is this a power problem as my SSD doesn't have a power supply? If not what do I do next? Also with the SSD mounted on my 20.10 desktop it shows to devices, Filesystem root and firmware.

Please see these tutorials:

I have tried both, it says I have the latest eeprom. Is it possibly a power problem?

Anyone with any ideas?

Share with us your /etc/fstab :slight_smile:
It can be also that your rpi needs some configuration files from the SD card

Next post down. I think I got it.

There are a number of fstab files, but here is the first listed.

Try to reproduce it and during the Ubuntu mate dots animation hit escape key and get a look where it is stucking. It will show you a error message or a running job :slight_smile:

OK will do now. Thanks.

I thought it might be a power problem, as a few YouTube videos mentioned that.

Please check this link :

Guys there are trying to do same as you with a USB boot without SD card.

That is all above my skill level. So I guess I wait. I was reading that 20.10 is ready to boot from SSD.

Do it man :slight_smile: there are steps that is easy to understand, with ready to use command lines.
Just search inside the page for :

I had a similar problem after following the instructions

and copy paste commands he gave. Great opportunity to learn and get new skills :slight_smile:

Did that followed all commands and now my SD will not boot. I am starting again. I used my backup SD and I am back with all the fixes and mods. Just no SSD boot.

soma72 on Wimpy World gave me the answer. It had nothing to do with commands, It turns out that there is a bug in the OS that prevents booting from USB 3.0 without modification to the boot menu. I am able to boot without any modification using USB 2.0. I hope this is on the agenda to be patched.


I have the same problem. I use WD green 120 GBSSD for Ubuntu Mate 20.10 on Raspberry Pi 4 4GB and it doesnt boot wnen connected via USB 3. But is boots on USB 2.
However, I have seen Leepspvideo on you tube and he doesnt mention any issue while booting via SSD. Could it be something to do with SSD?
Raspberry Pi OS required that I set up VendorID and DeviceID quirk, for the HDD to be recognised as a boot device.

I had a problem booting with a USB / mSata adapter using a Jmicron controller. Now I only take AsMedia controllers

I have tried two different adapters and two different SSDs this is a bug that is fixable. You should report it as a bug as I have done. It won't be important if I am the only one reporting it.

1 Like

How do I find out how to get the vendor ID etc? And of course how to modify the OS for this? Thanks.

@Sparks I really don't know the code for Ubuntu :man_shrugging:. But assuming it is same as Raspberry Pi OS(both being Debian based) , check this out. However, if you are not sure of the code, I suggest that an expert from this community advises us.