TTF-MS Fonts issue

Fresh install to an external drive of Ubuntu MATE last night and it is excellent. But I have one issue. Microsoft fonts will not install. I tried installing them from the ‘extras’ package and that did not work, neither would directly installing them via the terminal work. Here is the pop up window:

Failure to download extra data files

The following packages requested additional data downloads after package installation, but the data could not be downloaded or could not be processed.


The download will be attempted again later, or you can try the download again now. Running this command requires an active Internet connection.

I need those fonts and appreciate any help.

1 Like

I had this the other day, the links are broken in the update source. I ended up downloading the deb package.


Thanks! That worked.
Since that is an older version, does the update break it?
Thanks again!

Should be 3.6?


I just noticed that it said a newer version was in the repo when I installed it. So I wondered if an update might break it again.

Thanks @antechdesigns, I just installed that and so far the fonts installer message hasn’t reared it’s ugly head!. :smiley:

FYI, the root cause of the problem is this one, fixed for 17.04, a backport is scheduled for 16.10 and 16.04 .


I simply ignore it. Honestly, if you really need MS fonts, get yourself a copy of a Windows 10 ISO file

WebUp8 has an excellent how-to

It talks about Windoze 8.1 but 10 works as well. I got all Windoze fonts this way. I’m not an avid fan of MS fonts but some programs I use, especially KeePass2, simply has empty squares in the window title. It’s not always the case. I didn’t have this issue with 14.04, but with 16.04 it reappeared.

I use the Java PPA from WebUp8 and maybe next time I don’t select the option to download MS fonts. I wonder if we still have the option.

Again, if you can live with the occasional pop-up window, leave it as is and let it be fixed with an update. I tend to break things when I try to fix them by myself :grin:

1 Like

Thanks for the info guys!

Some people write and edit in both Libre Office and MS Office. Having the same fonts is important.

1 Like

Hi @linuxfan,

I just noticed what you had written, I think you meant to say that

“an older version is available from the repository”!. :smiley:

Installing the version posted above will not break your system!. :smiley:

1 Like

Right. Thanks Wolfman!

1 Like

The fix has been released for 16.04 and 16.10 - ttf-mscorefonts-installer works again after the latest update for apt.


Thanks for the update!

I tried and I had encountered the same issues of data files not installing. The solution for me is still to grab the package from Debian’s repos.