Typos or questions about English strings in ubuntu-mate-welcome


#61

@ele. It still says "Close" on my German installation!:


#62

Sorry I didn’t explain it well, I was wondering about this one from above. I’m just trying to see if it affect other languages too or just mine?


#63

Hi @ele,

mine is in English too, I did ask a while back as to whether the apps lists/decriptions should be translated or not!. :smiley:


#64

Nope, sorry. It’s on the team to-do list. Did these strings ever get translated at one time, or have they never worked?


#65

From when I started translating and checking on they never worked for me.

I was thinking if that might be because it says ubuntu-mate-welcome.pot is in Python, while others are in HTML? Not sure if that make any difference or because po files for that are in main directory while others are in data/po? I don’t really know much about those stuff.


#66

They never worked Luke, I wrote about it somewhere! :smiley:


#67

It’s been a long while, but I have finally fixed those missing translations.

It was because the locales path was pointing in the wrong place all this time! :blush:

  • For 16.10, this is properly fixed for good.
  • For 16.04, just the system’s locale is used. Doesn’t support the --locale parameter.

If you want to quickly patch this yourself to check it out, run this:

 sudo sed -i -e 's/\".\/locale", fallback=True/\"\/usr\/share\/locale\/\"/g' /usr/bin/ubuntu-mate-welcome

#68

Works great from the quick look around all the places I remember to check. Thanks Luke for all your hard work. :thumbsup:

The only thing still not shown as translated for me is from the above link under Drivers in Getting started.


#69

It looks like ttranslations haven’t been synced to Transifex for adding these originally missing strings. :frowning: (A job for @Wimpy).


#70

Hello @lah7. Just found out that in Lithuanian language program name of Ubuntu MATE Welcome in the menu is wrong. In the menu it reads "Laukiama" while originally should be "Sveiki". The string "Laukiama" is missing in Transifex. I have no idea where did it come from and how to fix it.


#71

That’s part of the desktop launcher entry, which are not available on Transifex.

Thanks for pointing it out, I’ll update the string. :slight_smile: