Ubuntu Mate 16.04 LTS Power Mac G5 Booting loop

I’m a happy owner of Power Mac G5 dual 2,3Ghz (PowerMac 11,2) and I’m trying to install newest version of Ubuntu Mate. Installation goes well, whether I have a second partition with Mac OS or not, but after successful installation and rebooting, I’m stucked on booting menu. I can see the list of booting devices (type “l” for linux, “c” for CDROM"), but whatever I do, the distro doesn’t boot up, just keeps rebooting. I’ve already tried mounting sda3, checked the yaboot.conf as well. Everything just seems to be ok, so what’s the problem?

What should I do, or what do I do wrong?

Please, help.

Best regards.

PS. I’ve also tried with Lubuntu 16.04 and got exactly the same problem. Actually nothing newer than 12.04 LTS wants to boot up…

Boot the live CD (USB stick) and then open a terminal (Ctrl + Alt + t) and reset Grub with the following command then reboot (A working internet connection is required!):

sudo update-grub

Hi, thanks for the reply, but im not sure if i do have grub. Do I, on powerpc?


I did not know that as I don’t have one, please see the following links:




I hope it helps. :smiley:

Thank you so much for those links! Tho I’ve already tried everything from the second and third one, but the first one is kinda new to me!

I’m totally gonna try this out, as I’ve got no idea what else I could do…

Thank you again, have a great day!

1 Like

I would also recommend the IRC.



Thanks again for your help, but still, nothing’s changed and i’m gettin really confused…

Am I the only one that had this problem on powerpc? :confused:

After you type ‘l’ do you then get the real yaboot screen where you would normally press enter/return to use the default ‘Linux’ option? If you don’t get this second screen then that is a problem with your yaboot.conf and you should include it here with a list of your partions/drives. Booting into openfirmware will overcome this. If you’ve pressed return and the kernel loads, but then reboots then that could be some other problem and is harder to solve.

1 Like

G5 powermacs used to have problems with yaboot.conf, but I thought they should be okay now unless your boot partition is on a separate drive to your root partition.

I also wonder if there is some problem with Mate and yaboot - see Where is yaboot.conf?

Hi, thanks for the reply!
No, after i press “l” i don’t proceed to the second screen.
I’ll upload my yaboot.conf here as soon as I come home, thank you again!

Hi, somehow I’ve managed to pass through both of the booting screens,everything seems to be fine, but after the second one and about 15 minutes of black screen, BusyBox prompt shows up…
I’ve made some research and it seems like i need to point where the root is, is that correct? How to do it?

Thanks in advice, best regards

Okay guys, I’ve fixed it!
All I needed to do was, when the second bootload screen appears, simply type "Linux root=/dev/sda3

Thanks to all of you for your help!

Have a great Sunday!

1 Like

That’s great! You can add it to your yaboot.conf so you don’t have to keep typing it. It would be good to try and figure out why the installer failed for you.

It failed simply because i plugged in the HDD to the lower SATA cable, instead of the upper one. That’s kinda weird, but still - everything works perfectly now.

Thank you all for your help again!