Ubuntu Mate 16.04 - sleep screen has locked me out

Hi all,

I just installed Ubuntu Mate 16.04 today. I really like it. My problem is that it has gone into sleep mode with these circle graphics floating about the screen, and now when I try to enter my password so that I can log in, Ubuntu will not accept my password.

I am not sure, but I have had some issues today with my keyboard. For example, my tilde character showed up as some other weird character when I try to type it in the terminal. My password has character symbols in it, and I’m thinking this may be why my password is supposedly “incorrect” when it’s not.

I don’t know how to get back into Ubuntu now that I am locked out.

Edit: I just swapped keyboards in case there is an issue with my keyboard, but I am still locked out, so perhaps it isn’t a keyboard issue.

Hi @Caps,

scroll down a bit to the power manager window here:

1 Like

Same thing happened to me a while back but I haven’t been able to reproduce since.
My guess is this is a keyboard layout problem.
Can you confirm you’re not using a standard keyboard layout?
Mine was set to French / Legacy.
To be able to log in again, I had to click ‘switch user’ then use the lightdm login screen instead of the mate-screensaver login screen

1 Like

Thank you for your advice - I’ll definitely do that! Brilliant!

Ourmov, I don’t really know if it’s a “standard keyboard layout”. I am in the Netherlands, so I have a Dutch keyboard but it has an English character set and the only difference that I can see is that there is a Euro symbol on number 5. I set up my keyboard as “US”. So now I get some pretty weird things happening. For example in Dutch there is a character that is an e with an umlaut over it. To get this character, you have to press SHIFT + quotation mark + e. Now because I have set my keyboard to US, characters are rather unexpected. For example, SHIFT + quotation mark now gives me @. And SHIFT + tilde gives me ¬, SHIFT + hash = £ But the characters that I chose for my password are not any of these, so itś weird that the screen saver kept locking me out.

Edit: I just found where to check my keyboard layout, and I had it set to UK English. Now that I have it set to US English, my tilde and other chars show up as I would expect.

BTW, for anyone else that has my problem (getting locked out by the screen saver), all I did was reboot my computer and then I was actually able to log in with my password (the one which the screen-saver lock does not recognize). Very weird, but it worked!

1 Like

I forgot to mention, I would not use suspend if I were you as this has proven to be a pain!. :smiley:

Wolfman, you are talking to a total n00b. I don’t know what suspend is let alone how to use it! :stuck_out_tongue:

I had a lot of problems with my password stuff yesterday. The only place my password was accepted was at the ubuntu login window. Terminal did not recognize my password. The (horrendously annoying and now disabled) screen-saver locked me out because it refused to recognize my password. I had a hellish try at using grub and dropping into root to fix password issue but no luck there (n00bness). In the end I just re-installed because it was the easiest thing to do. Now my password is accepted in terminal and I can use sudo so I am happy. Also I have set my keyboard to US with euro symbol on 5 and that’s working properly now.

Hi @Caps,

is US English your standard keyboard language?, if it isn't; you may well have troubles further down the line, you can decide which should be your default keyboard here:


All about suspend here but like I said before, don't use it! (my opinion!):


This might be of interest to you … Laptop without visual caps or num lock indicator

Yes, I figured out that my keyboard is best described in Ubuntu as “US English with euro symbol on 5”. That’s the keyboard layout that I picked after I re-installed ubuntu and I no longer have issues with weird characters appearing when I type the tilde character for example. TBH I don’t believe that it was my keyboard that was the issue. It was very strange that although I could reboot ubuntu and log back in, terminal would not accept my password, and neither would the screen-saver. I’m sure it’s something that I did, but I have no idea what I did to cause that to happen. I ended up re-installing ubuntu and (touch wood) so far I haven’t had any more issues with my password not being accepted.

1 Like

So this happened to me again yesterday, while my laptop was waking up from suspend.
I’d like to submit a bug report but I’m not sure against what package.
Closest thing on launchpad is this:
Problem: I’m not sure mate-screensaver is a fork of gnome-screensaver or another program entirely.

@Wimpy, can you maybe help pinpoint the package?


[Edit] Found this: https://github.com/mate-desktop/mate-screensaver/issues/67
raveit65 has a few tips that I’ll try and use next time it happens.