Ubuntu MATE 16.04 sometimes needs long to shut down

I am using Ubuntu MATE since 15.04 and now i have installed 16.04 at 22.04.16. I noticed that this version sometimes needs very long to shut down. Sometimes it works fine: i am clicking "Shutdown" and then i see the "Mate-Animation" with the animated dots. Normally after the fourth dot the system stops. Now i have to wait sometimes 10 seconds or more.
Can somebody tell me the reason?

By the way: On system startup i see an grey screen for some seconds (15.04 and 16.04, too). This is normal?
My system: Intel i5 6500, 8 GB RAM, Ubuntu MATE 16.04 on SSD-Drive

Mate-Animation (picture not animated):

I'm affected by this as well: random "Windows-with-a-surprise-update"-like shutdown speeds.
Because the problem is somewhat random and happens on shutdown, I think it's gonna be quite hard to diagnose.

@Etamuk: can you please do the following:

  • Edit your file /etc/default/grub ( sudo nano /etc/default/grub ) and change the line:




  • Then run the command: sudo update-grub

Starting next reboot, this will give you more verbose informations about the steps your machine takes during Startup and Shutdown, instead of splashing the Ubuntu MATE logo.

I've noticed a few things that maybe you will be able to confirm:

  • The shut down process doesn't always hang on the same steps. I don't know what steps they are but they must immediately follow the following because I can often see those messages long enough to take notice:

[ OK ] Stopped Raised Network Interfaces.
[ OK ] Stopped D-Bus System Message Bus.
[ OK ] Stopped target User and Group Name Lookups.
[ OK ] Stopped crash report submission daemon.
[ OK ] Stopped CUPS Scheduler.

  • I think there's a way to make the problem happen more frequently but I can't be sure because well, random. Anyway the method I use is to ssh into the machine from another machine and to stay logged in while I start the shutdown. It appears to happen way more often when I do that.

Here are my system specs, note that I'm also using a SSD:

> System:    Host: Edge Kernel: 4.4.0-21-generic x86_64 (64 bit) Console: tty 0
>            Distro: Ubuntu 16.04 xenial
> Machine:   System: Notebook (portable) product: W510LU
>            Mobo: Notebook model: W510LU
>            Bios: American Megatrends v: 5.11 date: 10/21/2015
> CPU:       Quad core Intel Celeron N3150 (-MCP-) cache: 1024 KB 
>            clock speeds: max: 2080 MHz 1: 889 MHz 2: 1118 MHz 3: 1560 MHz
>            4: 1406 MHz
> Graphics:  Card: Intel Device 22b1
>            Display Server: X.org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
>            tty size: 80x24 Advanced Data: N/A out of X
> Audio:     Card Intel Device 2284 driver: snd_hda_intel
>            Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
> Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
>            driver: r8169
>            Card-2: Intel Wireless 7265 driver: iwlwifi
> Drives:    HDD Total Size: 128.0GB (25.7% used)
>            ID-1: /dev/sda model: LDLC size: 128.0GB

No need for all that, hitting the escape key will remove the animation and show you what’s going on during shutdown.

I’m affected by a randomly longer shutdown then 15.10 too.

The other way is to hold SHIFT when loading GRUB and edit the boot options (only applies as a one off) and take out quiet and splash. Either way, quiet should be removed as this is the most detailed, pressing ESC alone may not reveal enough.

In the past, I’ve identified a wait job holding up, and ModemManager hanging.

Still testing this to be sure…

Every time I’ve observed this issue is while performing a system shut-down/restart while an Internet connection is live. Disabling Networking first usually allows the system to always shut-down/restart rapidly.

Also noticed this in VirtualBox, but (as mentioned) need to perform more tests, will then consider generating a bug report.

I get something similar as well.
Mine just closes all programs (seemingly), panels disappear and just shows my wallpaper.
After about 10 seconds it eventually shut down.
For some reason it seems as though some program is not being quit or killed properly.
If I manually close all open programs (chrome, steam, etc) it shuts down quickly every time.

1 Like

I have also the same problem. But in my case it is not random it always takes >10 seconds if there is a network connection.
If I unplug the Ethernet the system shuts down in less than 2 seconds.

@DaveB, @thomasm : I can confirm shutdown takes around 3 seconds when I’ve first manually brought down the network.

Does someone know a way to log that shutdown sequence somewhere so we can better understand where the hang is happening?

The timeout waiting for tasks to quit and the disk to flush its cache is 90 seconds. You can see that if you disable the boot and shutdown splash.

1 Like

@Dave_Barnes, thanks to you I found this: https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1457400
I think it might be the closet thing on launchpad matching our current problem.

I've modified /etc/systemd/system.conf and set a 6s timeout value, though I'm not sure I did that correctly.


What I can say for now is that I don't appear to have bricked my system, and based on a few cycles of power-on / shutdowns, it seems like it does the trick. I'll continue testing and report here if I notice the problem again.

Of course, that's just a workaround that's not really fixing the underlying problem that one process killed during the shutdown must be ignoring the SIGTERM signal, or making wrong assumptions about what the standard user would want it to do when signaled.


Yesterday the problem was present again. I had enough time for searching my digi-cam to make a photo. The last step was „Stopped Raise network interfaces“. After some time the pc shuts down. I attached a photo.

By the way: After this my WLAN-Connection doesn't work from the next start. So i have to use the LAN-cable.

Well, the 6s timeout did the trick.
Had no problems whatsoever.

I briefly considered lowering it to 3s but well, I don’t think I’m gonna bother.

Edit: please keep in mind this is using a SSD. The time necessary to flush the I/O buffer to disk would be more consequent with a HDD, please be careful. (or issue the “sync” command in a terminal before initiating the shutdown)

Hello, I’m bumping this back up into play. I’m loving my Ubuntu MATE 18.04 even more this week after having distro hopped to both Ubuntu Budgie (interesting!) and Solus Gnome (ugh) briefly (both w/o a back up)

1> After clicking Shut Down, I looked behind the MATE animation, and my system hangs for a myterious 1 min 29s, then goes through the shut down process.

A> Why? (it is cool I can see it though, Apple and Microsoft’s processes both seem like closed systems)
B> Can I shorten that time, or would it best to leave it alone? How would I accomplish that? Is the previous post by ouroumov still relevant two years out?

2> I happen to have an idle SSD lying around. What software do you recommend I should back up with? I am used to my Apple time machine, something in that ballpark?

That is from up thread.
Have you tried it on 18.04? Can't hurt! :slight_smile:

I’ll try it on Monday AM - thanks

Depending the updates, often my computer takes 2 to 5 secondes to shut down, then the next update it can takes more than a minute for few days, then come back to 2-5 secondes to shut down.
When it takes long i escape [Esc] to see what’s the verbose is saying and often it’s something related to internet,
But in all case (even if something in the verbose has nothing to do with internet) when i disconnect from internet before to shut down the computer shuts down in just a second or 2.