Ubuntu Mate 16.04 System Keeps Locking Up / Frequent Crashes

Hi All,

Recently installed Ubuntu Mate 16.04 and love it! But randomly keeps freezing to the point where I have to hard reset. Seems almost always related to using mouse pointer. Example clicking on firefox launcher or any type of program.

Any help to point me in the wright direction would be much appreciated.


Here is my hardware specs:
System: Host: ubuntymatey Kernel: 4.4.0-22-generic x86_64 (64 bit)
Desktop: MATE 1.12.1 Distro: Ubuntu 16.04 xenial
Machine: Mobo: FOXCONN model: M61PMV v: FAB 1.0
Bios: Phoenix v: P05 date: 02/23/2009
CPU: Dual core AMD Athlon X2 240 (-MCP-) cache: 2048 KB
clock speeds: max: 2800 MHz 1: 2100 MHz 2: 1600 MHz
Graphics: Card: NVIDIA GT218 [GeForce 210]
Display Server: X.Org 1.18.3 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
Resolution: [email protected]
GLX Renderer: GeForce 210/PCIe/SSE2
GLX Version: 3.3.0 NVIDIA 340.96
Audio: Card-1 NVIDIA MCP61 High Definition Audio driver: snd_hda_intel
Card-2 NVIDIA High Definition Audio Controller
driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.4.0-22-generic
Network: Card: NVIDIA MCP61 Ethernet driver: forcedeth
Drives: HDD Total Size: 1120.2GB (1.7% used)
ID-1: /dev/sda model: SAMSUNG_HD103SI size: 1000.2GB
ID-2: /dev/sdb model: SPCC_Solid_State size: 120.0GB

Did you install the Nvidia driver? Maybe it is that. In the worst case you could try it also without. Then you have to see if you use compton, Compiz or just marco for compositing. Maybe disable compositing.

This are just some random ideas I got.

There would be also another thing, the Intel microcode. If you enabled to install proprietary drivers this could help with some problems with your CPU/GPU. You can see if proprietary drivers are enabled from the Control Center -> Additional drivers.

Are you fully updated?

Also try monitoring you ram usage. Something could be using it up. In terminal:

free -m

Have tried using the Nvidia 340.96 driver and the X.Org x server driver. Same issues. Little scratchy on compton, compiz etc as new to ubuntu desktop, though be using raspberry pi command line for ages. Will look into that.

Could remove card and use onboard graphics to see if that solves it.

RE: the micro code. That may be a issue as under Additional drivers, it says Unknown: Unknown, and mentions microcode. See attached screen shot.


Fully updated and check for missing dependencies. Ram seems ok.


I asked about this just to be sure your not going to swap. With your computer specs you should not, but needed verification :slight_smile:


Maybe try with the on board graphics, just in case. Then we can see what to do next.

The microcode is an option. Though you have AMD and I am not really sure in your case. On my machine I needed it for Kodi to work properly but only in Debian.

As for the compositors like Compton et al. Look into the Control Center -> Mate Tweak -> Windows. Check what is running. By default, I mean on a fresh install it should be Marco (Compositor). You can try to change to only Marco or the other options. Only Marco is without any composition.

I have an AMD driver and this is what i experienced…maybe it will help…

I was having problems with the system freezing/locking up. Mine was due to several factors unrelated to this post, but one issue that is related was the driver. I had to specifically use the following driver…

X.org X Server - AMD/ATI display driver wrapper from xserver-xorg-video-ati (open source, tested)

Using any of the other drivers caused intermitent freezing…including the fglrx proprietary and amd proprietary.

Ok thanks. Well worth knowing. I’ve got 2gb for swap. Is that enough?

I tried disabling composition and that seemed to make a big difference. But still locked up later on after using it for quite a bit, well this time not a complete freeze. Still had mouse and keyboard, but had to hard reset.

Will have a play later today after work. Thanks

Are you using a nvidia graphics card or a AMD/ATI card? I did try the free X.org for my nvidia geforce 210, but was still locking up.

I will remove the nvidia card and use the onboard to rule that out.


I’m using Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R4 Graphics]

Sorry slow getting back to this. Seems to be going ok now…

This is what I did:

  • Removed nvidia card and tried using internal graphics. This installed nvidia drivers for internal graphics.

  • Seemed to be much more stable as a result of this.

  • Possible nvidia card had come loose and wasn’t seated correctly - but only a maybe.

  • Re inserted nvidia graphics card. Seems to be pretty stable at this point.

  • Removed all nvidia drivers as per the first part of this guide.

Does seem pretty stable now. Has only crashed once. Time will tell. One thing I did notice but not a 100% on this, is now the driver says it is open source (nvidia 340.96) where as before I’m sure it said proprietary.

Thanks for all the help.