Ubuntu MATE 16.10 just won't install correctly

i don’t know whats the issue. i recently tried re-installing ubuntu MATE on a laptop of mine. to 64bit, and Ubuntu MATE 16.10 just Never installs the welcome screen and software boutique from the ISO. it did this with the 32bit to. so in order for me to install 16.10 i have to install 16.04.1 and then upgrade from there. i am Using Rufus to format the iso in to a USB. could that be the issue? Thanks.

I’ve never clean installed 16.10, but just to try and rule out some possibilities, try downloading a fresh ISO (don’t overwrite it on top of the old one for insurance) and flash it onto a USB using Etcher by resin.io.

Hope this helps!

it might work. But i have used Rufus for a few years now. on ubuntu mate,ubuntu,windows in genral it worked. never had an issue with the image i used it on ubuntu 16.04 and it never had an issue with it. it could be just ubuntu mate. i dont think it is rufus.the program i use to save on to a usb

Have you check the images sha etc.?

Etcher did funny things to my USB. I will report it when I got time.

I didn't know Rufus is available for Linux too. First time I heard of it.

i Used my main Windows PC To Copy the Image on to a USB Flash drive. but its probably possible using it on linux using wine. and yes i checked the images.

i Used my main Windows PC To Copy the Image on to a USB Flash drive. but its probably possible using it on linux using wine.

Hi @Shy_tzedaka,

did you try using the "Something Else" install method which keeps your files intact?:

Install Ubuntu-MATE using the "Something else" method - #4 by wolfman

Have you tried any repair options?, see the update guied for more info:

That’s only if i have a previous Ubuntu MATE installation. i am Talking about Clean install. When there is nothing on the hard drive. The only way to get 16.10 with out issues is by installing 16.04 and then upgrading from there using system updater. My problem is that when i boot in to the 16.10 Flash drive The welcome and software boutique works. but when i install it from the hard drive it does not work.I have also tried using a virtual machine different computers. I don’t see the Issue. but i think it Could be Just the ISO.

Could be?, try downloading a fresh copy from a different mirror!. :smiley:

Hello @Shy_tzedaka

As weird as that sounds, what happens if you try re-installing from the same USB device/copied ISO, will the result be the same?

If it’s the same, then for sure it’s either the ISO file that’s corrupted or your flash USB drive (or the USB port in which it’s plugged into).

If after reinstalling the result is NOT the same (Say Software Boutique pops up but you’re then missing something else) then for sure the problem might be with your RAM (There’s a memtest+ feature available upon boot, try running it).

Hope this helps,

1 Like

Yes, try first to check the RAM and your storage device for errors.

1 Like

On the Laptop im trying to Install i Checked the Memory using memtest86+ No errors. tried other usb flash drive. same issue. both of them are missing. then i tried installing it in virtualbox directly from the iso. Nope still same. applies to 64bit and 32bit. nothing worked. still missing software boutique and welcome is missing. it could be an issue with the iso. Are you saying no one did a clean install?

How very odd. try installing the essential Ubuntu MATE meta packages on the problematic install:

sudo apt install ubuntu-mate-desktop ubuntu-mate-core

This will “fill in the blanks” if anything is missing, or at least present an error.

If Welcome/Boutique are in the menu but simply do not launch, then this would be a different issue.

Okay Yes they are in the Menu but they dont Launch. including welcome not opening on startup.
So is it a problem with the ISO or?

In that case, it’s not a problem with the installation, but rather a fault with the Welcome / Boutique. Please try running Welcome from the terminal:


(At this time of writing, Boutique is the same application, but launches with -b as a parameter)

This will output something useful for me to identify/investigate, as it’s apparent the program just silently fails.

It could be possible it fails to initialise Apt, which causes the whole thing to crash. This has happened with another member when their Apt index was messed up.

You could try opting in to the Welcome Updates PPA too, which had newer versions then the Yakkety archive:

sudo add-apt-repository ppa:ubuntu-mate-dev/welcome
sudo apt update
sudo apt install ubuntu-mate-welcome

i might try that. But will it help to say that i tried Updating to the Latest Version of Software listing/welcome from the Software updater or what ever the name of the Program you use to get updates ? i thought it might solve it.
i will try The Terminal Command on a Virtual machine, since i have been Reinstalling Operating systems on my laptop way to much that i don’t want to Abuse the Read Cycles of the SSD.

I think i found my Issue. I set my Keyboard Layout to Hebrew But the system Language is english. as in i have Hebrew and Language in the Keyboard settings. Seems like a bug. did not happen in 16.04

so is there a way to fix it?

Hi @Shy_tzedaka,

have you installed the Hebrew language pack?:

Well thats if i want my system language to be Hebrew. i want it to be English. and have my keyboard settings english/hebrew. I was able to do this 16.04 but on 16.10 i cant do it in a clean install.