Ubuntu Mate 17.10 reboot problem

Hello all :slight_smile: I’m not an expert in Linux , so go easy on me… My computer can’t reboot with any kernel above 4.4.xxx. The system it seems it’s going to reboot but my monitor just stay’s on standby and no reboot. Today i tried the latest 4.16 kernel and i still have the same problem. BTW, same happens with other distros so i think somenthing changed after the kernel 4.5 that doesn’t play well with my hardware:

CPU AMD FX8320 (OC to 4.2)

2x Corsair Dominator 4GB DDR3 1600

Motherboard Asus M5A99X EVO

VGA AMD HD6950 2GB (using the latest Mesa 18 drivers from Padoka PPA)

Someone with the same problem? I changed a few settings on my bios motherboard and i tried some changes on the grub file (like GRUB_CMDLINE_LINUX=”reboot=efi”) but with no effect

Thank you in advance

Hi @fearfactory79,

I think it may be the Mesa PPA you added but cannot be certain, you can first try removing that?.

2nd, it may be missing the microcode package for AMD CPU’s?:

Use the following at your own risk!:

Start your PC in recovery mode and connect to the internet (cable connection required) and run the following command, restart your PC with Ctrl + Alt + Del, DO NOT CLICK ON RESUME!:

sudo apt install amd64-microcode

See the update guide if you don’t know how to get into recovery mode:

You can also try running “dpkg” per the guide!. :smiley:

Hello @wolfman , ok i will purge the Mesa PPA and give it a try. About the AMD64 microcode, i’m already using it but i can remove it to try your method :slight_smile:

Thank you

@wolfman I removed the Padoka PPA with the purge command to revert the driver i but i still have the same problem, black screen on reboot. This may be a problem with my motherboard, something changed after the 4.5 kernel.

Have you tried slowing the 8 Core FX_320 CPU back down to spec (3.5GHz)?

To speed up booting, the startup code (systemd?) has evolved to use multiples cores during boot.


Hi @fearfactory79,

further to @Dave_Barnes suggestion; have you tried a different flavour of Ubuntu as a live CD to see if that has any problems?.

Have you considered doing a fresh install to clear any bits left over that may be causing problems, you can keep your data intact if you have already set up a swap; root and home partition layout:


Hello @Dave_Barnes , i can try that, revert my cpu to stock speed but the problem it’s not in the booting, but rebooting. Everything seems ok, i hit ESC to see what Ubuntu is doing on the reboot process but in the end my monitor just stay’s on standy

Hello @wolfman , yes… i tried the “normal” Ubuntu 16.04, 17.10 , Mint 18.2, Mint 18.3 and even OpenSuse… always the same problem. This is the 3.º time i install the Mate 17.10 :smiley: . I will remove the cpu overclock to see what happens

Hello again, i tried with no CPU overclock but i have the same problem with the reboot. This must be a particular problem between the energy management of my Asus M5A99X EVO and the newer kernels.

So… will i be able to use the new Ubuntu 18.04 with a generic 4.4.xxx kernel?

4.4? Even Xenial is running 4.13 now, when’s the last time you were able to reboot successfully?
Can you say how you’re initiating the reboot? Can you say if you reach the “Reboot: power down” stage? (easiest way to say that is to remove the “quiet splash” in the grub default command and run update-grub, then power down, cold boot, then reboot.

@ouroumov I can reboot successfully only with the kernel 4.4.xxx, everything above that, i end up with my display in standby. I also have the new 4.16 kernel, everything runs work’s fine… games, programs, everyhing… and it shutdowns, the only problem it’s the reboot. I tried a few changes on the grub file but with no effect. You mean to see what’s happening during the reboot? I hit ESC during the reboot to see the CMD and it’s seems all ok but in the end my monitor stay’s on standby and my computer doesn’t reboot.

Well, I’m sorry to say I think your only recourse is to file a bug report against Linux.
(Command: ubuntu-bug linux when you’re booted in the most recent kernel)

I don’t see why not, however that’ll be a hack that will most likely mean you won’t be running a technically “supported” version of the OS. :/

@ouroumov i will try that but i think this is a lost cause :smiley: It’s something really particular with my hardware combo hehe

Yes, i will try the new 18.04 with the 4.4 kernel and see whats happens :slight_smile: Well, it’s a sign that i need to upgrade my hardware :smiley: Maybe a Ryzen 2xxx later this year.

Thank you all for your help

1 Like

Hi @fearfactory79,

have you reset your BIOS/UEFI to default optimal settings?. :smiley:

Hi @wolfman Yes i did :slight_smile: and i tried a few changes in the energy management of my motherboard, no effect… this is a lost cause :smiley: haha

HI @fearfactory79,

I have been using 18.04 for a while now, you can use it no problem even though it is still in Beta!. :smiley:

Artwork is by @antechdesigns :smiley: :smiley:

1 Like

Hello @wolfman :slight_smile: that looks good! I'm using the same weather widget, rain but not so cold here in Portugal :smiley: I'm going to remove both Virtual Box and VMware just to give it a last try...

1 Like

Hello again :slight_smile: I just want to update my situation. The problem seems solved with the latest 4.17 kernel. They made many changes for the AMD GPU’s in this new kernel and so far so good, 18.04 with kernel 4.17 + Padoka Mesa drivers running fine, no more reboot problems.