Ubuntu mate 18.04 lts Missing Software Boutique


#1

Upgraded to ubuntu mate 18.04 bionic and I’m now missing the software boutique.


#2

From the release announcement:

Get the Ubuntu MATE snaps

When the upgrade is complete and you’re logged in, open a terminal and execute:

snap install ubuntu-mate-welcome --classic
snap install software-boutique --classic
snap install pulsemixer

Run at least the top two lines to get the Boutique.


First software update after 18.04 32 bit install breaks Software Boutique
#3

I did all that but I’m not seeing it. Do I need to restart?


#4

Literally it show’s it in control center but won’t pin it to start up programs or launch it.


#5

I think I saw that someone else reported that issue… Can you open it thought the application menu or with the terminal (ubuntu-mate-welcome --boutique )?


#6

I get the same except mine starts to loads and just says stocking boutique for like 4 hours. System does not freeze during this time. can still work other stuff.


#7

Just upgraded from 17.10 myself and am also encountering this issue. Doing the snap commands. Will update when done.

UPDATE: The snap installs worked for me. Thanks @elcste :grin:


#8

I got this when running it through terminal. ** (ubuntu-mate-welcome:17419): WARNING **: 16:16:54.798: Failed to load shared library ‘libwebkit2gtk-4.0.so.37’ referenced by the typelib: libGL.so.1: cannot open shared object file: No such file or directory
/usr/lib/python3/dist-packages/gi/types.py:204: Warning: cannot derive ‘main+AppView’ from non-derivable parent type ‘void’
gi.type_register(cls, namespace.get(‘gtype_name’))
Traceback (most recent call last):
File “/snap/ubuntu-mate-welcome/169/usr/bin/ubuntu-mate-welcome”, line 855, in
class AppView(WebKit2.WebView):
File “/usr/lib/python3/dist-packages/gi/types.py”, line 213, in init
super(GObjectMeta, cls).init(name, bases, dict
)
File “/usr/lib/python3/dist-packages/gi/types.py”, line 192, in init
cls._type_register(cls.dict)
File “/usr/lib/python3/dist-packages/gi/types.py”, line 204, in _type_register
_gi.type_register(cls, namespace.get(‘gtype_name’))
RuntimeError: could not create new GType: main+AppView (subclass of void)

Edit: Also I’ve noticed I can’t install anything. MPV and VLC will end up showing an icon and nothing launches same with krita.

Edit2: Installing vlc with snap worked but it won’t install using normal methods.


#9

On 18.04.1 it fails for me as well. From the command-line with an error from libjavascriptgtk.

$ ubuntu-mate-welcome --boutique
[Welcome] Starting in Software Boutique mode. 
[Welcome] Snap detected. Using __VERSION__ 
[Welcome] Version: 17.10.26 
[Welcome] Application Ready. 
1   0xb3788464 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(WTFCrash+0x14) [0xb3788464]
2   0xb339acc9 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC24ScratchRegisterAllocator15allocateScratchINS_7GPRInfoEEENT_12RegisterTypeEv+0xf9) [0xb339acc9]
3   0xb3392318 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC24ScratchRegisterAllocator18allocateScratchGPREv+0x18) [0xb3392318]
4   0xb2f62284 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC22GetterSetterAccessCase16emitDOMJITGetterERNS_21AccessGenerationStateEPKNS_6DOMJIT12GetterSetterENS_12X86Registers10RegisterIDE+0x354) [0xb2f62284]
5   0xb2f1fd2e /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC10AccessCase12generateImplERNS_21AccessGenerationStateE+0x1dee) [0xb2f1fd2e]
6   0xb2f20eaa /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC10AccessCase8generateERNS_21AccessGenerationStateE+0x2a) [0xb2f20eaa]
7   0xb2f76e76 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC17PolymorphicAccess10regenerateERKNS_24GCSafeConcurrentJSLockerERNS_2VMEPNS_9CodeBlockERNS_17StructureStubInfoERKNS_10IdentifierE+0x9d6) [0xb2f76e76]
8   0xb2f88dff /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC17StructureStubInfo13addAccessCaseERKNS_24GCSafeConcurrentJSLockerEPNS_9CodeBlockERKNS_10IdentifierESt10unique_ptrINS_10AccessCaseESt14default_deleteISA_EE+0x5af) [0xb2f88dff]
9   0xb33912de /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(+0x7362de) [0xb33912de]
10  0xb33922a7 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC14repatchGetByIDEPNS_9ExecStateENS_7JSValueERKNS_10IdentifierERKNS_12PropertySlotERNS_17StructureStubInfoENS_11GetByIDKindE+0x37) [0xb33922a7]
11  0xb3362767 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(+0x707767) [0xb3362767]
12  0xaa6cc77b [0xaa6cc77b]
13  0xaa627df0 [0xaa627df0]
14  0xaa6046e7 [0xaa6046e7]
15  0xb33a0cc6 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(+0x745cc6) [0xb33a0cc6]
16  0xb339b788 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(+0x740788) [0xb339b788]
17  0xb331ba3e /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC11Interpreter14executeProgramERKNS_10SourceCodeEPNS_9ExecStateEPNS_8JSObjectE+0xbbe) [0xb331ba3e]

#10

First I used a persistent live USB of 18.04 and the software-boutique worked only for once.

Afterwards it opens but it does not load anything, just remains a blank window.

The software-boutique is part of the Welcome application. The Welcome application loads normally, but if you click to the software button to open the Boutique, you will receive a blank screen again.

Then I installed ubuntu-mate on an external drive and it happened the same. Software-boutique was loaded for a couple of times and I was capable to install some software. Then it was not functioning anymore.

Later I deleted and reinstalled ubuntu-mate on the external drive and again Software boutique worked only for once.
Then I removed and reinstalled the Welcome and Software Boutique packages, but without result.
I did the reinstallation at least 4 times successfully, but Software Boutique never worked.
Then why should I keep a program which does not work?

So I completely removed both packages, Welcome and Boutique.

We can always install a new program by downloading a deb package, or using the
apt-get install and snap install commands.

The only reason that I miss the Software Boutique is that it give us the opportunity to preview a new program and it presents us with a list of new applications that we are not always aware of.


#11

Please tell us the version of the os 32 or 64 bit? In the 32 bit os there is a problem with software boutique sadly.


#12

This is the filename of the version I downloaded and installed, ubuntu-mate-18.04.1-desktop-i386.iso
The 32 bit os if I am not mistaken.
I preferred that version because I thought it would be lighter for my 8 years old pc.
Do you suggest me to install the 64bit os or the 18.10 Ubuntu-mate version?


#13

Hello, Mykychak.

The error which kmashint reported some posts above and which you encountered as well, this issue is limited to the 32-bit edition of Ubuntu 18.04 Mate.
Actually, the same issue has been reported and discussed in this thread as well:
First software update after 18.04 32 bit install breaks Software Boutique
The issue is caused by a shared library, which Software Boutique makes use of.
At this point in time, it seems as if Ubuntu has not started deploying any bugfixed version of the affected shared library, yet.
But there is a workaround, which can be applied in order to make Software Boutique function properly again on Ubuntu 18.04 Mate 32-bit.
Please, cf. my post in the mentioned other thread

HTH,
Karl


#14

I had the same problem pfter upgrading, the snap commands sloved the problem :+1:


#15

Hello to everybody, I’m new to the community, I wish to report the same issue on my system.

I’ve recently updated my Ubuntu MATE 16 LTS to Ubuntu MATE 18.04 LTS and even if my platform is at 64 bit neither the welcome nor the boutique starts.

Tried to run from the console I receive this error:

ubuntu-mate-welcome
[Welcome] Snap detected. Using VERSION
[Welcome] Version: 17.10.26
[Welcome] Application Ready.

(WebKitWebProcess:17114): Gdk-ERROR **: 09:48:19.016: The program ‘WebKitWebProcess’ received an X Window System error.
This probably reflects a bug in the program.
The error was ‘GLXBadRenderRequest’.
(Details: serial 340 error_code 176 request_code 154 (GLX) minor_code 1)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the GDK_SYNCHRONIZE environment
variable to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

My system:

Linux d830 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Besides, I’m using “NVIDIA binary driver - version 340.107 from nvidia-340” as my X server.

EDIT: update, I’ve tested the software logging directly on the machine (I was using RDP to access it) and the program starts correctly, but freezes the mouse (the keyboard still worked) and I had to restart the X server to resume it. It seems something related to welcome e boutique using some particular function(s) of the XServer (luckily they seems really exotics, since overall the system works flawless).