First software update after 18.04 32 bit install breaks Software Boutique


#1

I have installed Ubuntu Mate 18.04 (several times actually - to prove a point) and find all functions are working really well on my ASUS dual-core 32 bit netbook. I know I am pushing my luck installing such a substantial OS on this hardware, but it runs incredibly well - and by the way - my congratulations on this perfect software release.

As confirmed during several installs, this OS works perfectly up to the point that I carry out the first software update - then I find that the Software Boutique (another great app) fails to work properly. You can click the icon (or use other means – via terminal, etc), and the first few screens come up but the app freezes when it tries to "stock the boutique". I have searched for this problem across the net but have found similar but not identical problems.

I cannot solve the problem by reinstalling the app - meanwhile the OS still works prefectly in every other way, as far as I can see.


#2

Please check these posts -

Good luck crjb.


#3

I appreciate your taking time to reply and providing the suggestions.

Unfortunately I have tried these solutions several times but the system responds that “snap “software-boutique” is already installed”, and the fact that the icon can be clicked and partially responds implies that the snap package is installed.

Perhaps if I removed the snap package and reinstalled it might help. Not sure how to do that though.


#4

Update -

I have figured out how to remove and reinstall the software boutique snap. After a reboot, the system is still not responding and freezes at “stock the boutique” as before.

I am happy that the rest of the OS seems to be working well but it is a shame that this useful app has failed. Any further suggestions would be much appreciated.


#5

I just looked at one of my 32 bit machines (a Dell D610) and it has a snap directory that lists under it a 168 directory, a common directory and a current directory. Does your snap directory look at all similar?

I updated my 32 bit ubuntu-mate, rebooted and used the Control Center to try to start the Software Boutique. It hung as you reported. The Boutique was functional back in September.

Apport developed an error report after waiting for a bit. I sent it off (apport asks permission to do this). The Software Boutique window remained white and not populated with possible programs to install.

I rebooted and tried launching the Boutique again. Same deal, no workee. Apport shows a failure in the ExecutablePath - /usr/lib/i386-linux-gnu/webkit2gtk-4.0/WebKitProcess Package libwebkit2gtk-4.0-37 2.22.2-0ubuntu0.18.04.2 and much more.

Please file a bug report on this.


Ubuntu MATE Software Boutique hangs
Software Boutique will not load from GUI or CLI - Ubuntu MATE 18.04.1
Software Boutique not loading
#7

My /snap/software-boutique directory has three subdirectories like yours - common, current and 30 - all empty.

Thanks all for raising the problem report.


#8

I have this exact same problem. Installed MATE 18.04 on an old Asus laptop. Installed a few apps from the Software Boutique with no issue. Then the first updates occurred and I can now no longer open the Software Boutique. It just hangs on the screen “Stocking the Boutique…”.


#9

Same problem for me with Ubuntu-Mate 18.04.1 32-bit. After a software update, the Software Boutique hangs. From the command-line, I get the error below when it hangs:

1   0xb370d464 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(WTFCrash+0x14) [0xb370d464]
2   0xb331fcc9 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC24ScratchRegisterAllocator15allocateScratchINS_7GPRInfoEEENT_12RegisterTypeEv+0xf9) [0xb331fcc9]
3   0xb3317318 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC24ScratchRegisterAllocator18allocateScratchGPREv+0x18) [0xb3317318]
4   0xb2ee7284 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC22GetterSetterAccessCase16emitDOMJITGetterERNS_21AccessGenerationStateEPKNS_6DOMJIT12GetterSetterENS_12X86Registers10RegisterIDE+0x354) [0xb2ee7284]
5   0xb2ea4d2e /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC10AccessCase12generateImplERNS_21AccessGenerationStateE+0x1dee) [0xb2ea4d2e]
6   0xb2ea50b6 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC10AccessCase17generateWithGuardERNS_21AccessGenerationStateERNS_22AbstractMacroAssemblerINS_12X86AssemblerEE8JumpListE+0x146) [0xb2ea50b6]
7   0xb2efc0a3 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC17PolymorphicAccess10regenerateERKNS_24GCSafeConcurrentJSLockerERNS_2VMEPNS_9CodeBlockERNS_17StructureStubInfoERKNS_10IdentifierE+0xc03) [0xb2efc0a3]
8   0xb2f0ddff /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC17StructureStubInfo13addAccessCaseERKNS_24GCSafeConcurrentJSLockerEPNS_9CodeBlockERKNS_10IdentifierESt10unique_ptrINS_10AccessCaseESt14default_deleteISA_EE+0x5af) [0xb2f0ddff]
9   0xb33162de /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(+0x7362de) [0xb33162de]
10  0xb33172a7 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC14repatchGetByIDEPNS_9ExecStateENS_7JSValueERKNS_10IdentifierERKNS_12PropertySlotERNS_17StructureStubInfoENS_11GetByIDKindE+0x37) [0xb33172a7]
11  0xb32e7767 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(+0x707767) [0xb32e7767]
12  0xaa7b942e [0xaa7b942e]
13  0xaa749e18 [0xaa749e18]
14  0xaa79bb98 [0xaa79bb98]
15  0xaa798cd8 [0xaa798cd8]
16  0xb3325cc6 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(+0x745cc6) [0xb3325cc6]
17  0xb3320788 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(+0x740788) [0xb3320788]
18  0xb32a0a3e /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC11Interpreter14executeProgramERKNS_10SourceCodeEPNS_9ExecStateEPNS_8JSObjectE+0xbbe) [0xb32a0a3e]

Software Boutique - blank screen
#10

I am experiencing the same issue.

[email protected]:~$ ubuntu-mate-welcome.software-boutique 
Traceback (most recent call last):
  File "/snap/ubuntu-mate-welcome/220/usr/bin/ubuntu-mate-welcome", line 32, in <module>
    import apt
ModuleNotFoundError: No module named 'apt'

Made sure that apt was installed:

[email protected]:~$ sudo apt-get install apt
Reading package lists... Done
Building dependency tree       
Reading state information... Done
apt is already the newest version (1.6.6).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Also tried installing python-apt package:

sudo apt-get install python-apt


#11

I have a question if you install software boutique without the —classic tag at the end what happens? Sudo snap install software-boutique


#12

Created a launchpad bug: https://bugs.launchpad.net/ubuntu-mate/+bug/1806459


#13

I too have the exact issue with my Dell D620 32 bit. New install of 18.04 Mate. Software Boutique works before the first update. Have have tried the suggestions listed, still have the problem.


#14

Hi, folks.
Stumbled across the reported issue on my Ubuntu Mate 18.04.1 32-bit only today.
Let me cut it short:
I cannot offer a real solution, but a simple workaround, which I have come across. This simple workaround renders Software-Boutique functional again.
Please, find the details in the Launchpad bug report, comment #3: Workaround makes Software-Boutique work again
Hope it will help you as well.
Cheers,
Karl


#15

Thanks for posting the comment here karichen. I booted my old Dell D610 32 bit machine, updated the system, rebooted, and checked the Software Boutique once again - it was non-functional. I entered the suggested line in a terminal and then started the Boutique in terminal - completely functional as far as I could tell.

I then amended software-boutique.desktop file in .local/share/applications/, rebooted and the Software Boutique worked as expected. Thanks again @karlchen


#16

Hi Karl
Many, many thanks for posting this workaround.

I’m glad to report that I’m back to full functionality after following your advice.


#17

Perhaps I spoke too soon.

I can follow the advice - execute two commands in terminal and have the software boutique fire up and populate.

Is there a way to get the workaround commands attached to the regular application startup (I normally use the icon on the control center, or the main menu)?


#18

Well I thought about that as I was amending the .desktop file. Instead of the welcome desktop file, I amended the software-boutique.desktop file and it works as expected from both Control Center and Main Menu.

Perhaps rebooting would help.


#19

Thank you for the response, i have tried the work around in the terminal and it works.
As far as changing a desktop file i have no idea how to do that. I would guess a real fix is in the works.
Thanks


#20

“we’ll either need to wait for the WebKit package(s) to update… or force an older version in the snap in the dependencies :confused:
This is the response from the main dev of wlecome and software boutique.