Welcome Screen and Software Boutique screens are blank



Chromium shows:
GL_VERSION OpenGL ES 3.1 v1.r17p0-01rel0.a881d28363cdb20f0017ed13c980967e


About the hardware acceleration:
With Mate 1710Beta2 I’m on VirtualBox.
After reading this I checked my VM settings and saw that 3D acceleration was checked!
So just for nuts I UNchecked it. And hey presto.
Welcome screen.


I also noticed that the Welcome screen is blank (white) with Ubuntu MATE (any recent version, including 17.10 Beta 1) running inside a VirtualBox VM if the “Enable 3D Acceleration” checkbox option in the VirtualBox “Display” section is ticked. So you have to de-select 3D Acceleration to get the Welcome screen working, which is a shame - not sure why.
Kind regards,


Did you get your issue resolved?


Toshiba Satellite 1135 Laptop…older machine:
Intel 2.0GHz Mobile Celeron CPU
Intel 82852/855GM Graphics. Kernel module is i915,intelfb.
32bit Ubuntu-Mate.

Older machine, so that is the primary reason Ubuntu-Mate 32bit was selected…to create a working, viable box using older/obsolete laptop.

After Ubuntu-mate clean install CD 16.04, Welcome and Software Boutique work as expected.

After Upgrade 16.04 to latest auto-updates, Welcome & Software Boutique give blank screens.

After Ubuntu-mate clean install CD 18.04, Welcome and Software Boutique give blank screens.

I’m on 18.04 at this point, so not going to downgrade back to 16.04.

So far, this issue appears to be isolated to Welcome and Software Boutique.

Uninstalled: snap remove ubuntu-mate-welcome
Reinstalled: snap install ubuntu-mate-welcome --classic

No joy.

Don’t really care so much about Welcome, but would appreciate being able to use Software Boutique.

Other than this issue, Ubuntu-mate works very well on Toshiba Satellite 1135, and has fully extended it’s useful life for my purposes.

While I’ve found some posts on the forums with folks reporting this issue, I have not seen any solutions posted that work (or sometimes even apply) to this situation. Since it appears this is not really an isolated instance, can anyone point me to a link to a FAQ or something about this issue?

As a workaround, Is there an older version (as in the version in 16.04 Install CD) that can be installed to replace the latest version?

Is there a fix (or one in the works) for the latest version?


My guess is your graphics hardware doesn’t support OpenGL which is used in WebKit2.

Can you check the output of

glxinfo | grep -i "opengl"

and next one

LIBGL_ALWAYS_SOFTWARE=1 glxinfo | grep -i "opengl"



here is the output:

glxinfo | grep -i “opengl”

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel® 852GM/855GM x86/MMX/SSE2
OpenGL version string: 1.3 Mesa 18.0.5
OpenGL extensions:’

LIBGL_ALWAYS_SOFTWARE=1 glxinfo | grep -i “opengl”

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 128 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:


OpenGL 1.3 is very old.
Setting the variable LIBGL_ALWAYS_SOFTWARE to 1 enables software rendering.
Next command will start ubuntu mate welcome with software rendering OpenGL 3.0

LIBGL_ALWAYS_SOFTWARE=1 ubuntu-mate-welcome

I hope that will work


Yep, that worked! THANK YOU.


That’s great. The same should work for Software Boutique.

Now the only thing left is to ask @lah7 to enable software based rendering when OpenGL hardware is below minimum requirements (or just add an option to run the program with Software Based OpenGL --soft-gl). Probably some animation was added at some point in development that requires a newer OpenGL.


Some good analysis, it would actually help other projects too, as I know a few other WebKit2-based applications where the same issue has cropped up with no firm solution.

In my quick test, it didn’t seem to make a difference in a known problematic environment (VirtualBox with 3D acceleration enabled) so I’m not sure if it’s the ultimate solution. As bizarre as it sounds, others had success just by updating their systems (or it occurred after an update).

It’s certainly a parameter (probably --software-fallback) we can add in a few update – Welcome’s codebase and development has gone a bit stale at the moment so not anytime soon. :confused:


For VirtualBox for start enabling debbuging could help

LIBGL_DEBUG=verbose ubuntu-mate-welcome

There are also Webkit variables https://trac.webkit.org/wiki/EnvironmentVariables

And from there, disabling things or changing options via variables until the main culprit appears.
mesa and libgl environment variables are here https://www.mesa3d.org/envvars.html

VirtualBox uses LLVMpipe driver.
One has to check LLVMpipe driver environment variables too.

One thing is sure, it isn’t going to be easy, but this is a start. :grinning:

I wish there is a universal way to bypass webkitgtk2 bugs.


You, sir, are a genius! I went ahead and added that environment variable to the Exec line in the desktop files in /var/lib/snapd/desktop/applications/

Exec=env LIBGL_ALWAYS_SOFTWARE=1 BAMF_DESKTO …(the rest of the line - point is I inserted it immediately after env)

Now I can finally see both the welcome screen AND software boutique on my old inspiron 600M. THANKS!

Of note to anyone else with the white welcome/software windows, this fix IS persistent through a reboot, so it’s finally G2G. Still can’t get the autorun one to show up at login, but progress nonetheless.


I had this issue on fresh install before installed proprietary driver for nvidia. Just install it and everything should work.



I just installed and am experiencing the same issues described in this thread, with the Software Boutique screen empty after showing coat hangers for a couple minutes. I have tried some of the suggestions here but am not having much luck. I am new to Linux so it is likely I am not doing something correctly. Everything else seems to be working well

  • I switched the software source location to main (was Canada), still went blank
  • i checked the Canonical Partners in Other Software , still went blank
  • I ran from the terminal - still went blank but terminal displayed the following in the terminal window (WTFCrash sounds like what I have been mumbling :slight_smile:

I am running on an HP Pavillion laptop. Does anyone have any ideas what I need to do to get this working? this thread is 6 months old so not sure if anyone still connects to it.

1 0xb3716514 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(WTFCrash+0x14) [0xb3716514]
2 0xb3325579 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC24ScratchRegisterAllocator15allocateScratchINS_7GPRInfoEEENT_12RegisterTypeEv+0xf9) [0xb3325579]
3 0xb331cbc8 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC24ScratchRegisterAllocator18allocateScratchGPREv+0x18) [0xb331cbc8]
4 0xb2eeca74 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC22GetterSetterAccessCase16emitDOMJITGetterERNS_21AccessGenerationStateEPKNS_6DOMJIT12GetterSetterENS_12X86Registers10RegisterIDE+0x354) [0xb2eeca74]
5 0xb2eaa4be /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC10AccessCase12generateImplERNS_21AccessGenerationStateE+0x1dee) [0xb2eaa4be]
6 0xb2eab63a /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC10AccessCase8generateERNS_21AccessGenerationStateE+0x2a) [0xb2eab63a]
7 0xb2f01626 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC17PolymorphicAccess10regenerateERKNS_24GCSafeConcurrentJSLockerERNS_2VMEPNS_9CodeBlockERNS_17StructureStubInfoERKNS_10IdentifierE+0x9d6) [0xb2f01626]
8 0xb2f135af /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC17StructureStubInfo13addAccessCaseERKNS_24GCSafeConcurrentJSLockerEPNS_9CodeBlockERKNS_10IdentifierESt10unique_ptrINS_10AccessCaseESt14default_deleteISA_EE+0x5af) [0xb2f135af]
9 0xb331bb9e /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(+0x736b9e) [0xb331bb9e]
10 0xb331cb57 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC14repatchGetByIDEPNS_9ExecStateENS_7JSValueERKNS_10IdentifierERKNS_12PropertySlotERNS_17StructureStubInfoENS_11GetByIDKindE+0x37) [0xb331cb57]
11 0xb32ed157 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(+0x708157) [0xb32ed157]
12 0xaa5cc41b [0xaa5cc41b]
13 0xaa57448f [0xaa57448f]
14 0xaa5169a7 [0xaa5169a7]
15 0xb332b596 /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(+0x746596) [0xb332b596]
16 0xb332603f /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(+0x74103f) [0xb332603f]
17 0xb32a643e /usr/lib/i386-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3JSC11Interpreter14executeProgramERKNS_10SourceCodeEPNS_9ExecStateEPNS_8JSObjectE+0xbbe) [0xb32a643e]
[Welcome] Application Closed


please disregard... after digging some more I found reference from December this year to this error being caused by an issue with 32bit version


This is a issue because of a web component that the 32 bit version uses. Until the bug is fixed upstream sadly the 32 bit version will not work. The other way is to rewrite the app from 0.


There is a workaround posted in this forum. See - First software update after 18.04 32 bit install breaks Software Boutique

where karlchen advises those afflicted by this bug to go to -

https://bugs.launchpad.net/ubuntu-mate/+bug/1806459/comments/3 and follow his directions.

They worked for me. Good luck all.


Still useful for MATE Welcome in Ubuntu MATE 19.04. Disabled 3D acceleration

and get MATE Welcome working again :slight_smile:


Been working on this over the weekend. I "think" I've fixed it.

Ubuntu MATE 19.04 Beta is out!