Welcome Screen and Software Boutique screens are blank

Upgraded the old dual Asus a7m266d to 16.10 yesterday.
Athlon 2800+ x2
3.25gb ram
nvidia 6200 gpu

Most things seem to run ok, but the welcome window is empty, and same with the software boutique. Just white empty windows no matter how long I wait. I found bug reports for mac machines, but those don’t seem to apply to me. I also found reference to GTK+ v3. Is this another instance of not having SSE2 in my antique CPU limiting the future usefulness of this old hardware as I found out concerning Skype?

1 Like

Hi @jmarkus,

try using a different desktop theme as it (that) can cause blank windows.

Control Center > Personal > Appearance

1 Like

No joy on the different themes. Tried using the nvidia and X org drivers which didn’t help either. I did notice a faint gray word “skip” in the lower right hand corner - which I assume is the lettering for the button. However, it never updates to “Close” - like the welcome app has crashed. I tried removing Welcome, and re-installing it. I really want to get to the software boutique, because of google chrome (native html v5 support versus pipelight\silverlight netflix support). Is there another way I can get to this special 16.10 version of chrome? (like a few terminal commands)

1 Like

try changing your software sources download location and running updates again!:

1 Like

If you think it’s crashed, try running Boutique from the terminal. This will output any error details.

ubuntu-mate-welcome --software-only 

This command will go straight to the Boutique section. Please also show us a screenshot if it still black.

However, if Software Boutique still isn’t working, Chrome (for Ubuntu) can be downloaded from Google’s website.

1 Like

Thanks Luke. I took a screen shot of the terminal results + the error it generated, and the blank software boutique window. This time the hangers, and some of the graphics loaded, but it stopped responding almost immediately, and went blank again. Graphic below

Changing software sources did not change anything.

1 Like

Unfortunately, I do not have a solution to this problem. :thinking: Either way, it’s definitely a bug with WebKit2GTK, which is the library that renders the page. That crashes and nothing can be seen. It’s not a bug specific to Welcome/Boutique.

A similar “blank screen” bug happens on the Raspberry Pi and PowerPC architecture. I would guess the lack of hardware acceleration is the reason why.

Your Nvidia 6200 GPU is quite an old card, but you’ve already tried using the NVIDIA (legacy?) driver and Xorg (open source) drivers… :confused:

1 Like

Hi @jmarkus,

what Nvidia driver do you have installed and have you tried the 304 package which is better for older cards but first please tell us exactly what Nvidia Card you have.

See also:

1 Like

I have this issue also. I wasn’t worried about the ubuntu welcome screen as much as installation screens for pycharm. I updated java and was able to get the installation screens to show up.

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get isntall oracle-java8-installer

Did anyone find a fix for the welcome screen and software boutique??

1 Like

I couldn’t figure it out for a week. I followed the guide that you linked and realized that Canonical Partners was unchecked. Welcome Screen and Software Boutique work again. Thanks!

1 Like

I also have this error (blank welcome and blank software boutique) on a box running 32 bit arm multicore. I ran the terminal command above and got this output:

ubuntu-mate-welcome --software-only
[Welcome] Starting in Software Boutique mode.
pcilib: Cannot open /proc/bus/pci
lspci: Cannot find any working access method.
Exception in thread Thread-2:
Traceback (most recent call last):
File “/usr/lib/python3.5/threading.py”, line 914, in _bootstrap_inner
File “/usr/lib/python3.5/threading.py”, line 862, in run
self._target(*self._args, **self._kwargs)
File “/usr/bin/ubuntu-mate-welcome”, line 1749, in detect_graphics
self.graphics_grep = self.graphics_grep.split("controller: ",1)[1]
IndexError: list index out of range

There is no PCI bus on my machine. A possible suggestion is that some code is trying to figure out what my graphics card is and is (perhaps) querying PCI bus to find out. I am a bit new to this and so it may be a red herring. Anyway, I got the above errors when attempting to run from terminal command mode. Any help would be greatly appreciated.

Additional information that may be helpful:

$uname -m
$ lspci | grep “vid”
pcilib: Cannot open /proc/bus/pci
lspci: Cannot find any working access method.
$ lsmod | grep “vid”

Chromium shows:
GL_VERSION OpenGL ES 3.1 v1.r17p0-01rel0.a881d28363cdb20f0017ed13c980967e

About the hardware acceleration:
With Mate 1710Beta2 I’m on VirtualBox.
After reading this I checked my VM settings and saw that 3D acceleration was checked!
So just for nuts I UNchecked it. And hey presto.
Welcome screen.

1 Like

I also noticed that the Welcome screen is blank (white) with Ubuntu MATE (any recent version, including 17.10 Beta 1) running inside a VirtualBox VM if the “Enable 3D Acceleration” checkbox option in the VirtualBox “Display” section is ticked. So you have to de-select 3D Acceleration to get the Welcome screen working, which is a shame - not sure why.
Kind regards,

1 Like

Did you get your issue resolved?

Toshiba Satellite 1135 Laptop…older machine:
Intel 2.0GHz Mobile Celeron CPU
Intel 82852/855GM Graphics. Kernel module is i915,intelfb.
32bit Ubuntu-Mate.

Older machine, so that is the primary reason Ubuntu-Mate 32bit was selected…to create a working, viable box using older/obsolete laptop.

After Ubuntu-mate clean install CD 16.04, Welcome and Software Boutique work as expected.

After Upgrade 16.04 to latest auto-updates, Welcome & Software Boutique give blank screens.

After Ubuntu-mate clean install CD 18.04, Welcome and Software Boutique give blank screens.

I’m on 18.04 at this point, so not going to downgrade back to 16.04.

So far, this issue appears to be isolated to Welcome and Software Boutique.

Uninstalled: snap remove ubuntu-mate-welcome
Reinstalled: snap install ubuntu-mate-welcome --classic

No joy.

Don’t really care so much about Welcome, but would appreciate being able to use Software Boutique.

Other than this issue, Ubuntu-mate works very well on Toshiba Satellite 1135, and has fully extended it’s useful life for my purposes.

While I’ve found some posts on the forums with folks reporting this issue, I have not seen any solutions posted that work (or sometimes even apply) to this situation. Since it appears this is not really an isolated instance, can anyone point me to a link to a FAQ or something about this issue?

As a workaround, Is there an older version (as in the version in 16.04 Install CD) that can be installed to replace the latest version?

Is there a fix (or one in the works) for the latest version?

My guess is your graphics hardware doesn’t support OpenGL which is used in WebKit2.

Can you check the output of

glxinfo | grep -i "opengl"

and next one

LIBGL_ALWAYS_SOFTWARE=1 glxinfo | grep -i "opengl"


here is the output:

glxinfo | grep -i “opengl”

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel® 852GM/855GM x86/MMX/SSE2
OpenGL version string: 1.3 Mesa 18.0.5
OpenGL extensions:’

LIBGL_ALWAYS_SOFTWARE=1 glxinfo | grep -i “opengl”

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 128 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

OpenGL 1.3 is very old.
Setting the variable LIBGL_ALWAYS_SOFTWARE to 1 enables software rendering.
Next command will start ubuntu mate welcome with software rendering OpenGL 3.0

LIBGL_ALWAYS_SOFTWARE=1 ubuntu-mate-welcome

I hope that will work