18.04 Blank welcome and software boutique

On a lenovo flex 2, which has been fully updated. There is an nvidia driver installed and the display manager has been changed to software. I seem to remember their being different options which used GPU based rendering when I first installed the beta. I also have the jre and josm installed, otherwise nothing much has changed.

I have looked at this thread and I tried the suggestions but didn’t help and the terminal error messages are different than that poster.

This is the output for both, ubuntu-mate-welcome --software-only and ubuntu-mate-welcome --boutique

Xlib:  extension "GLX" missing on display ":0".
[Welcome] Starting in Software Boutique mode. 
[Welcome] Snap detected. Using __VERSION__ 
[Welcome] Version: 17.10.16 
[Welcome] Application Ready. 
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".'

Also installed and ran gnome-software and tried to launch Hatari from the terminal with this with this out-put

Xlib:  extension "GLX" missing on display ":0".
15:34:53:0245 Gs  enabled plugins: os-release, desktop-categories, packagekit, packagekit-refine-repos, systemd-updates, fwupd, packagekit-upgrade, ubuntuone, packagekit-proxy, packagekit-local, packagekit-refresh, packagekit-offline, packagekit-url-to-app, appstream, hardcoded-blacklist, hardcoded-featured, hardcoded-popular, rewrite-resource, modalias, steam, desktop-menu-path, generic-updates, packagekit-refine, ubuntu-reviews, packagekit-history, snap, provenance, icons, provenance-license, key-colors, key-colors-metadata
15:34:53:0245 Gs  disabled plugins: dpkg, repos, dummy, shell-extensions, epiphany, odrs
15:34:58:0457 Gs  Only 0 apps for recent list, hiding
/usr/bin/env: 'python': No such file or directory

Hi @tadcan,

how did you install your Nvidia drivers?. Please see the following which may help?:

How to install graphics card drivers in Ubuntu :smiley:

@wolfman I used additional drivers from the Software Updater. It selected the 340.106 binary driver. Reading through the link now.


04:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (rev a1)

Edit. Went back to nouveau driver, which fixed the problem.

1 Like

Hi tadcan,

excellent, I have marked it as solved!. :smiley:

1 Like

@wolfman. Should I report that as a bug?

Hi tadcan,

I don’t think it is necessary, Nvidia drivers can be a bit funny in Linux anyway and they cannot do anything about them because they are closed source!.

When one looks at the available drivers, you should always choose the recommended package, if non are recommended, then choose the higher numbered package!. :smiley:


I see this same problem running Mate 18.04 in a Mac using Parallels Desktop. (virtual machine). The graphics driver is “Intel Iris Plus Graphics 640” and the resolution is set to be same as default mac retina resolution. No additional drivers are shown in the Software Update tab.