Ubuntu Mate 22.04 auto ending Sessions when I do something specific

Maybe some information here:


1 Like

I found this too

Window manager warning: Window 0x1800007 (Eclipse ) sets an MWM hint indicating it isn't resizable, but sets min size 452 x 302 and max size 2147483647 x 2147483647; this doesn't make much sense

Hi, @Ygor6889.

Does the "/var/crash " directory in your computer running "Ubuntu MATE 22.04" ("Jammy Jellyfish") have any "*.crash" files in that folder with information regarding those crashes? If there are such files, I suggest that you start by looking into those.

Yes it does have one file "_usr_lib_xorg_Xorg.0.crash"

Thanks for the feedback, @Ygor6889 :slight_smile:

The presence of that specific "_usr_lib_xorg_Xorg.0.crash" file seems to confirm @mickee 's guess of an "X Server" crash. Those "*.crash" files, in the "/var/crash" directory, usually have a line that begins with "Title:" that typically are good to search the web for the error that caused the crash. What does the "Title:" line say in the case of your ".crash" file?

If you're really interested, you may also want to take a look at the "StacktraceTop:", "Stacktrace:", "ThreadStacktrace:", "XsessionErrors:" (which I see, in another post of yours in this same topic, that you have already checked) and "JournalErrors:" sections also in that ".crash" file, but please be aware that some of those sections may contain a LOT of information and that some of that information, in some cases, you may NOT want to disclose in a public forum.

Also please note that I'm just another Forum user here (I'm NOT a Ubuntu or Ubuntu MATE developer).

Same problem here, on a Latitude E6410. In this example, when I go to "properties" of the Processor Frequency Grade Monitor, the mate session is terminated. This happens sporadically with other applications as well (eg when trying to open an instagram link in Firefox and Google Chrome):

1 Like

I didn't find any lines about the stuff you mentioned, weirdly, the end of the file is just "gibberish"

@Ygor6889 : those very long "gibberish" lines are probably part of the "CoreDump:" section of your ".crash" file. Try to find "CoreDump:" in that "_usr_lib_xorg_Xorg.0.crash" file to confirm if that's the case.

By the way: I see that you are opening that ".crash" file in the "Notepad++" text editor in Microsoft Windows (maybe in Windows 10?). Is that "Ubuntu MATE 22.04" installation running inside a VM (Virtual Machine)? If that's the case, what is the virtualization software that you're using to run the "Ubuntu MATE" VM? VirtualBox? VMware Workstation Player? Some other?

It's actually a dual boot, I'm opening this on Windows because I can't even open the file on Ubuntu Mate due to the "auto ending session" issue

1 Like

Here is the video showcasing the issue

1 Like

It's the exact same problem I'm having (I did post a video too)

Hi again, @Ygor6889.

OK. I suggest that we try now something different: let's try to use the "apport-cli" command / tool to extract the several parts of the ".crash" file into several files.

If you can open a "MATE Terminal" window (without the "auto ending session" issue also happening by doing that), I suggest that you try the following commands (I'm assuming here that your "Home" directory is "/home/ygor"). Also, in case you don't already know, the '$' ("dollar sign") in the following commands is just representing the shell prompt (don't type that dollar sign in your commands):

$ mkdir /home/ygor/mycrash
$ cp -piv /var/crash/_usr_lib_xorg_Xorg.0.crash /home/ygor/mycrash
$ cd /home/ygor/mycrash
$ apport-cli _usr_lib_xorg_Xorg.0.crash mycrash-files/

It's possible, when you do that last "apport-cli" command, that you get an error like the following one (but don't worry about that);

  File "/usr/bin/apport-unpack", line 77, in <module>
    pr.extract_keys(f, bin_keys, dir)
  File "/usr/lib/python3/dist-packages/problem_report.py", line 269, in extract_keys
    raise ValueError('%s has no binary content' %
ValueError: ['separator'] has no binary content

(It's also possible that you get an "apport-unpack" crash during this process, but also don't worry about that).

Now you should have a "mycrash-files" folder with lots of files. You can see the list of those files by entering a command like the following:

$ ls -l /home/ygor/mycrash/mycrash-files/*

Now, I would like to ask you to publish a new message here in this same topic with the content of the "Title" file by entering the output of the following command:

$ cat /home/ygor/mycrash/mycrash-files/Title

References for this answer of mine:

... particularly the following great answer written by @Norbert_X in that same Question in the "Ask Ubuntu" web site:

I can't run "cd /home/ygor6889/mycrash" because of the auto ending session :confused:

@Ygor6889, Igor, is your video card also from intel? I just solved the problem on the Latitude E6410. I created the /etc/X11/xorg.conf.d/20-intel.conf file with the following content:

$ cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "TearFree" "true"

Then I restarted the system and Ubuntu Mate stopped crashing!

I saw someone on this post reporting a similar problem:

And then I followed what was in the 6.1 section of the ArchLinux Wiki:


Yes my video card is a Intel HD Graphics

I'm gonna try that, if it works im gonna be super happy

OMG IT DID WORK, Obrigado!

1 Like

I wasted a whole week trying to fix this, you saved me

Thank you to everyone who tried to help me, @esan_br gave the solution, not only it did work but it completed fixed the issue

Problem SOLVED!



This works for me too, thanks Elias!. Intel G41 driver on old desktop pc, works ok with 20.04 but 22.04 continuously crashes (even with a fresh install) and your post resolves the problem.