Ubuntu MATE doesn't turn off the monitor


i have a small issue with ubuntu mate.

i user version 17.04 with Nvidia driver 375(installed from “additional drivers”)
Kernel: 4.10.0-20-generic

my hardware :
Asus laptop FX502VML (also known as GL502VM)
Intel Core I5 6300HQ
Nvidia GTX1060 3GB
Samsung NVME 960 Evo
(no Intel IGPU so no optimus tech)

Monitor: Samsung C27F591FD
connected with mini DP

now to my issue:
i have set my screen to turn off after an hour, it dosent work.
i tried to set screen saver it wont start. (i can start it manually and it working fine but wont start automatically)
after laptop wake up from sleep i get artifacts on screen and need to shutdown the laptop to resolve it.
when i try to restart it the GUI was it goes to sleep but working fine from terminal.

please help, i love this version it stable and smooth but this issue drive me crazy.
i tried to search google but most results want to stop the monitor from turning off so i cant use that.

P.S. i use mostly the laptop with lid closed however the laptop screen wont turn off when i close the lid, i had to manually turn it off from settings.


Control Center > Startup Applications

Make sure that both the Power Manager and Screensaver are present and enabled there. And reboot or log off and on.

i can see only Power Manager.
and its active

about the screen saver i dont really want it, i only tried it when i saw that screen dosent turn off.

The point is that without having that startup, any and all screensaver settings will simply be ignored. You NEED it there to be able to configure the screensaver to your liking.

When laptop lid is closed: Blank screen <--- does this work on your system?


as i said i need to go to settings and manually turn off the laptop monitor.

if you mean if the laptop screen go dark then yes it dose but the system still it as active monitor and if it were the primary screen then all menus are still there even when the lid closed.

thank you but i really dont like screen savers i prefer screen to go to sleep mode.
i now know why it didnt worked.

And can you tell us why?

i replied to “1Q7FE6zp”
saying that now i know why the screen saver wasn’t working (i didn’t had the screen saver in the startup applications"

[quote=“shadowk, post:9, topic:13095”]i didn’t had the screen saver in the startup applications[/quote]You’re more than welcome.

anyone can help with the power issues ?

Think I understand what you are wanting to do.

As we discuses earlier, if you select When laptop lid is closed: Blank screen in power management preferences your laptop screen will blank when you close the lid. This is the first part.

Next with your laptop lid opened, open Monitor Preferences by going to System > Control Center > Displays

Next plug in your external monitor. After you do that Monitor Preferences should show both monitors, your laptop monitor, and the external monitor.

Look at the screenshot below, and select Same image in all monitors in Monitor Preferences and click Apply

If everything worked correctly, you should now see the exact same thing on both monitors. Now you can close your laptop lid, it will blank, and you can use your external monitor as the desktop, including all panels that you would normally see on the laptop monitor.

The only other thing you may have to do is adjust the resolution of the external monitor if it is vastly different than your laptop monitor.

ok another part solved, thanks.

now just left:

i have set my screen to turn off after an hour, it dosent work. (UPDATE: it dose work only if after restart i dont login and just leave the laptop on the login screen)
after laptop wake up from sleep i get artifacts on screen and need to shutdown the laptop to resolve it.
when i try to restart it the GUI way from the menu it goes to sleep instead, but reboot working fine from terminal. (UPDATE: now its just log out to main screen, and when i try to restart it says that “restart in progress and i cant run it again” however nothing happans.)

I just set my monitor to sleep after 1 minute in Ubuntu Mate 17.04, also with kernel 4.10.0-20-generic, and it worked. This may be a incompatibility issue between UM 17.04 and your hardware. Zesty Zapus is the newest version of Ubuntu and bug fixes are on going. There’s a good chance this will be resolved for you in a future update.

but it dose work from the login screen after reboot.

something is wrong here.
for some reason i guess system never see my laptop as idle after login.

Or something running in the background is keeping it awake.

What happens if you run sleep 10s ; xset dpms force suspend in a terminal?

That should suspend your display after 10 seconds.

i see black screen however screen dosent go to sleep mode (as i can see full back light on)

It will not help your situation but you can also run (sleep 10s ; xset dpms force suspend) & xdg-screensaver lock which will suspend the display and lock the screen.

Question, are you trying to suspend the laptop display, or the external monitor display?

i try to put to sleep the external display

The following link sounds very much like what you are experiencing.