Ubuntu Mate LTSP - Control clients with epoptes

Hello Community,

I’ve build up a LTSP network with Ubuntu Mate at my school. First i want to thank you for all it’s great features!

I’ve made a couple of videos just with music showing some main features i’ve implemented to the network.

This video is about the teacher-features; how he can control the stundent’s clients over epoptes. The left hand screen repesents the student and the right one the teacher. My next demo videos will be definitly in english :smile:

Maybe i will make a general review of the system setup later.



Thanks for sharing this. Ubuntu MATE will feature deeper remote terminal service integration in the future. It great to see real world examples of this kind of deployment and being in the education sphere is icing on the cake :sunglasses:

1 Like

Outstanding work Matthias!

You are just the person I was hoping may come on to this forum. My name is Steve Cook and, until recently, I was running LTSP on Ubuntu 12.04 LTs with Gnome-Fallback as a personal research project as I am a teacher and was exploring the viability of persuading the schools I work in to implement some kind of LTSP setup. However, since using Ubuntu 14, with any desktop environment, I have been unable to get Ubuntu LTSP server to work. Consequently, I would be very grateful to know precisely how you set up your server and clients on ubuntu mate.

Same with me. I had gnome-fallback installed with the 12.04 LTS version of ubuntu, but this was no replacements for the gnome2/Mate Desktop.

While installing i made a documentation for my computer-sience teacher :wink:
I’m still a student, so forgive me my mistakes.

@moderator: You can move this manual to the wiki or another topic, if it does not fit here.

Here it is (fresh-translated from german):

Download and install the normal Ubuntu 14.04 LTS Server Edition.
The newest server edition creates a seperate home and root partition. Make sure that the root-Partition is large enough, about 20 GB is fine.

Do a full system update and restart.

You can take a look at some usefull tools:

sudo apt-get install htop iotop nethogs iperf

With them you can later check the connection speed between the clients and the server.

Now comes the fun part :smiley:

Install the ltsp-server package:

sudo apt-get install ltsp-server-standalone

You have to edit:


like this: (make sure that the line FAT_CLIENTS_DESKTOP is commented out, we will later install our own desktop. We don’t want to use Unity, which would be installed.)

# The chroot architecture.
#Later ubuntu mate will be installed.
# Space separated list of programs to install.
# The java plugin installation contained in ubuntu-restricted-extras
# needs some special care, so let's use it as an example.
# This is needed to answer "yes" to the Java EULA.
# We'll create that file in the next step.
# This uses the server apt cache to speed up downloading.
# This locks the servers dpkg, so you can't use apt on
# the server while building the chroot.



Change i386 to amd64 (depending on your architecture)

#cut begin
if substring( option vendor-class-identifier, 0, 9 ) = "PXEClient" {
    filename "/ltsp/amd64/pxelinux.0";
} else {
    filename "/ltsp/amd64/nbi.img";
#cut end



Put here the name of your interface where the client’s switch is connected to.


Now build the Image:

sudo ltsp-build-client



If you have 32-Bit clients replace amd64 with i386.


Now we are ready with the server and have to install some software in the image.

sudo ltsp-chroot -c -p

Like the Mate-Desktop :smile:

apt-get install software-properties-common python-software-properties
apt-add-repository ppa:ubuntu-mate-dev/ppa
apt-add-repository ppa:ubuntu-mate-dev/trusty-mate
apt-get update
apt-get upgrade
apt-get install --no-install-recommends ubuntu-mate-core ubuntu-mate-desktop 


For the last step update the image:

sudo ltsp-update-sshkeys
sudo ltsp-update-kernels
sudo ltsp-update-image

You can PM if you find any mistakes in my manual. (I will correct them)



That sounds like your server isn’t actually Ubuntu Mate. But is, in fact, Ubuntu Unity and that all youve done is implement Ubuntu Mate in the clients. Which, I guess, is fine if it works since it should also be implementable as a fully Ubuntu Mate 14 server. Or, at least, I hope it would, Though, I would have preferred to have seen it implemented that way from the off in your example.

The setup described is the same approach I use to install Ubuntu MATE X2Go servers. The technique of installing Ubuntu server (no desktop, not a hint of Unity), then enabling my PPAs and installing the ubuntu-mate meta packages does essentially create and Ubuntu MATE server that is practically indistinguishable from regular Ubuntu MATE. This is the correct technique :smiley:

Yes, but it’s not clear whether this was a server with or without Unity on board. Not that that matters if it works, of course, and the user is happy for Unity to be the desktop top of choice of the sever. For myself, I don’t want Unity to be anywhere on the system.

As for installing the server without any desktop environment in the fiest instance, I’ve already tried that with Ubuntu 14 and it didn’t work in exactly the same way it didn’t work with Ubuntu Mate on board. I have also tried it with the latest Mint Cinnamon and Mint Mate. Same story. In other words, in my experience, irrespective of the desktop being used, or no desktop at all, I have been unable to get the any up to date debian based distro to run with LTSP. Having said that, who knows, it may work with the Edubuntu Unity based server since this has LTSP written into the installation. but, as I have said, I don;t want Unity and the problem for me, at present, is that the OP is not clear about what they meant by “server”. They may have, for all I know, meant the Edubuntu server.

If they have, however, done it with a desktopless server, and then installed the Mate desktop after the fact on the server, then that great, I just need these things clarifying before setting off on another attempt to do what I have been hitherto uttery unable to do.

If, on the other hand, I have misunderstood the breakdown of the user’s installation, I am going to take another look and also take a look at the ubuntu Sever edtion for LTS 14

First problem. Can’t install server due to it not able to see wireless card due to, presumably, absent wireless driver.

Any ideas how to get round this anyone? Would minimal install CD still suffice? If so, then what is the several hundred megs that is absent from the minimal cd as opposed to the full one actually for?


Just realized…I need to take it downstairs and plug directly into my router…

Second problem. And it’s a total ********** of a problem!

After installing ubuntu server onto dev/sda (a 1TB sata drive), my system will not now boot. Not even to bios! So, i cant even load a live cd/usb to see if I can fix it. Only if I unplug the 1tb sata drive, can i get to bios to load a live usb. Having logged in on the live usb (which is where i am right now) I have tried retrospectively plugging in the opffending sata drive in order to erase it’s contents. But the live usb environment is not retrospectively picking it up.

so, i am now going to have to repartition my second sata (data storage) drive to create a partition sufficient to install a fresh ubuntu mate install and then hope to god I can re-plug my now duff 1tb sata drive in on the basis it wont lock my system up at bootup, I will then, theoretically, be able to access it from my new installation on the other drive in order to erase whatever crap was put on there by ubuntu server installation.

At which point, I can ***** start again!

And before anyone starts wibbling on about a duff sata drive, might i point out that:

A) this is a brand new drive (as is the rest of the machine)
B) it was working absolutely perfectly right up until the precise point i installed ubuntu server on it.

The fact is, despite all of the usual flakey bollocks that comes with an open source OS built piecemeal by generous volunteers, I will never go back to MS. But, jesus, this bollocks is just sooooooooooo linux.


Yep, it was the crappy ubuntu server that messed it up.

Installing ubuntu mate on the second sata did not get rid of the problem of the bios not loading with the 1TB drive plugged in, though I certainly do not blame ubuntu mate for this,

So, I had to temporarily unplug the 1TB drive, fire the machine up, enter bios and enable “hotplugging” of the drives. I then allowed it to boot to the temorary ubuntu mate installation on the second drive and plug in the 1TB drive while logged in. At which point it became visible. Went into gparted and erased all content (the ubuntu server installation), reformatted and rebooted. entered bios and disabled hotplugging/reset to default and left bios.

Lo and behold, all fired up into second temporary os (on my second sata) with 1 tb now visible on first sata.

So, it was ubuntu server that did this, no doubt whatsoever. Anyone with less persistence/knowledge might have quite easily mistaken this for a duff drive. It really is not good enough.

What the hell are ubuntu playing at with a bug like this in their server installation?


Installed again from freshly written usb iso just to see if it was a one off. It wasn’t. Did exactly the same thing. Killed the 1tb sata and wouldn’t even let me enter bios. Have since hotplugged and erased contents of drive. All working again.

Absolutely ridiculous.

Am going to write iso to cd and install again to see if it is related to installing from usb.


Wrote THE ISO to CD. Installed without a hitch and did not subsequently bugger my SATA drive up.

so, for anyone to whom it may concern:


Yet another update:

Ethernet no longer managed so going to have to set that up again before implementing LTSP (which was the whole pioint of going through all of this pain in the first place).

Graphics driver running weird. That is to say, when I log in, the screen jumps off to the left hand side by about 50%. Then jumps back, but overdoes it so that half of the panel icons are offscreen and if I load a document or webpage, about an inch of it is missing from the right hand side. Not to mention the fact that all of the panel system tray icons randomly appear in different places every time Ilog on.

Will continue to try and stabalise. But life is short and I’ve already wasted 36 hours of mine on this.

It’s rarely ever a case of “just install…” with Linux,

Final update:

Got the ethernet recognised by copying the instructions to get it going for the Precise-Mate install. Display still playing silly buggers. More importantly, despite following instructions on LTSP installation given by the author of the OP, it did not work in exactly the same way that it did not work on all previous attempts by me. So, the author of OP must be doing something in addition to what they have described that I am unaware of.

Anyway, I’ve re-ghosted my normal 64 bit Ubuntu-Mate back onto my machine.

Another 48 hours of my life wasted trying to get LTSP working on any and all current variants of Debian.

Yet another update:

Tried doing this with Edubuntu. Used my wirelesss card for the install and designated my eth card as the LTSP connection.

Following Installation, LTSP worked instantly. Came with Unity, of course, which stinks, But, will talk about how that was trivially solved in a minute.

First problem; wirelass, following installation, card not working (despite working during install). That is to say, wirless network working, but no internet connection. Knowing this wireless card can be a bit iffy, I always update the driver after a new installation. That is to say, although a bit iffy, it more or less works sufficiently to do the initial wifi upgrade, At which point i have a stable wireless connection and can build the system as I like it from that point.

However, on this occassion, no internet connection whatsoever. Cannot connect to internet using the eth card as this has been co-opted by LTSP and I do not want to start fiddling around with its settings since this was the whole source of the problem of not getting LTSP working in the first place!

So, went to PC World on the way home from work and got hold of a bog standard pci express eth card. so, now have two eth cards.

Reinstalled Edubuntu; one of the eth cards being used for the install and the other being designated as the LTSP connection. All installed fine and LTSP working. However, now the new eth card is not working despite working during the install! Just like the wireless card!

Searched internet for solutions; found loads of threads started by people with the same problem, Usually one of two post threads with someone coming on and wibbling on vaguely with no solution offered. At which point the thread usually dies.

I have managed to get a temoprary interent connection working via the following:

I fired up my laptop and edited its eth connection to a shared connection. I then connected my (non ltsp) eth card on my main machine to my laptop eth card. I immediately got an internet connection on my main (Edubuntu) machine. All of which tells me that my new eth card is being properly driven by Edubuntu, I then proceeded to update the driver for my wireless card. However, even after doing that, it is still not connecting to the internet! This, again, implies to me that it is being properly driven by Edubuntu. But, there is some kind of internet connection problem with both it and the eth card and that the only reason i am getting an interent connection with the shared connection to my laptop is becuase the initial connection to the internet is being handled by my laptop.

I should say, replacing Unity in Edubuntu with Mate, was trivial and i will talk about that some moreonce I have solved this damned problem with the interenet connection.

Has anybody on here got any ideas why no direct internet connection (either wirelsss or wired) seems to be working when ltsp is installed at initial installation?


Will, in due course, write up a comprehensive tutorial from start to finish on how to install LTSP in Ubuntu Mate for complete numb-nuts like me.

1 Like

Spoke too soon. Or, at least, it’s sort of fixed, but needs fixing some more…

Basically, I have identified the problem and can work around it in a messy kind of way.

It relates to two things:

(1) the dhcpd server

The dhcpd server must be already running to be able to hand out addresses to an LTSP client. However, since ubuntu 13 onwards, it seems that the dhcpd server can only start once an active connection is already physically established. That is to say, it needs to be already started when an ltsp client is booted up. However, if the ltsp client is the only other computer connected to the ltsp host, then the dhcp server wont be started and ready for it.

If I do a dhcp server restart command (sudo /etc/init.d/isc-dhcp-server restart) on the ltsp host before any physical connection are already established, then it fails. If I try and restart the dhcp server while the ltsp client is booting, then sometimes the restart fails and sometimes it does not. The ONLY WAY I have found to get the dhcp server started and ready for the LTSP client is to have previously connected a PC with the eth card with a full linux installation to the host machine. At which point, if I then do the dhcp server restart command, it will start. At which point, I can then shut down the other PC and boot back on the network. At which point, it will get the necessary addresses from the dhcpd server on the host. Which is where the next problem arises:

  1. the tftpd server

I don’t know what the server does exactly, but I do know it needs to be ruunning otherwise the clioent will report a tftp timeout error when booting. The tftp server should be already up and running on the host machine as a consequence of starting at boot time. but it isn’t. I have resolved this by simply running the server restart command and it loads without error. The command is “sudo service tftpd-hpa restart”. I will be sticking this command in a startup script and so this last problem should be trivially resolved.

So, in summary, to get my LTSP system running and cvlinets logging in unproblematically, I need to do the following:

  1. fire up the host

  2. restart the tftp server on the host

  3. fire up a normal (non LTS) full-fat ubuntu client machine and have it connected to eth0 on the host

  4. restart the dhcpd server on the host

  5. reboot the client to the network

6), At which point the client will recieve addresses from the dhcpd server on the host and it will also not report a tftp timeout error. In other words, it will boot to LTSP.

Presumably, once there is at least on ltsp client up and running, then all other clients should boot up without any hitches.

The only real problem i now have remaining is with getting the dhcpd server up and running and ready for the ltsp clinet in advance.

Anybody any suggestions?

Nobody on here witth server experience?

Well, I've been on just about every forum, irc and other source of information about LTS/ubuntu and not single one of them has been able to provide any kind of answer as to why this problem is happening. Indeed, i would be very interested for the OP of this thread to come on here and explian how tyhey seem to have implemented LTSP inb ububntu 14 without having experienced any of the server issues both I and a large number of other people have.

Everythng I have read seems to indicate that ubuntu (especially the latest version) does not do servers well. Whicgh is fine, of course, if all you are after is a stable desktop/laptop distro. Not so fine if you are wishing to seriously implement a server based system like I wish to.

In the absence of any further progress on this issue, I am going to have to look around for some other linux distro wherre this issue does not happen. Hopefully one where the mate desktop can also be installed. In the meantime, I will live with the approaching-end-of-life Ubuntu 12.04 LTS with Mate over the top (since this is the last Ubuntu distro that LTSP uncomplicatedly works on). That way, I can run LTSP till I find a suitable alternative to Ubuntu.

For a screenshot of an Ubuntu Mate 12.04 LTSP server and a fat client, both running in VMs in Virtual Box, see bleow:

I haven't bothered installing the Mate Desktop in the client image yet as that would be a trivial matter and this is just a proof of concept before I do a full rewrite on my main system.