Ubuntu-MATE on Raspberry Pi 5

Has anyone managed to get Ubuntu-MATE up on a Raspberry Pi 5? I tried with the 22.04 image and received an error message that this image was not supported on the Pi 5 and to try setting "sense_os=0" (or whatever the exact flag was). I added that and the system still wouldn't boot. Any more leads?

2 Likes

According to Ubuntu, 23.10 will support raspberry pi 5 as 22.04 LTS will not. Not sure if that would mean that MATE will support pi 5 on their 23.10.

https://ubuntu.com/download/raspberry-pi

1 Like

Welcome @mnawij13 to the community!

After installing the Raspberry Pi Imager 23.10 server image (SD or USB SATA drive), booting, & install ubuntu-mate-desktop. Everything works as it should.

3 Likes

Is that with Audio, & if so how ??

Jeff, that does it! Thanks for the response. This should allow continued familiar use until a 2024.04 LTS release comes out. This is so much better than the breakage with the 'new' Pi system.

2 Likes

Yeah! Well No! Everything installs nicely but, screen resolution is locked on 640480 and it is not possible to change! and who likes 640480 today? setup: lenovo screen that runs perfect on pi 4 with ubuntu mate and pi5 with raspberry os so actually it is only raspberry and ubuntu standard (Gnome) that "works out of the box" not booting is :Manjaro, althhough ive heard about somebody booting the KDE version , fedora also not booting Kali is also limited/locked to 640*480 Armbian with cinnamon desktop is booting but unstable(as armbian informs because it is only a beta release) so raspberry os is the only one that runs flawlessly

1 Like

I had no screen resolution problems.

I switched my SSD over to Proxmox & that is working grate other than I have not found a way to reliable convert an existing/downloaded img file that will boot yet.

1 Like

Welcome @Birger_Abrahamsen to the community!

Change of screen resolution is still impossible for me i have tried with another monitor/screen. this one also is locked to one resolution however that one is locked on 19201080 resolution (which is good but this monitor is used for my Pc) instead of 640480. to me it seems that a library/file is missing to recognize what screen is connected.
In monitor preferences it says : Unknown Default screen and resoution 640*480, refresh rate 0hz and rotation is also locked. Does anyone know if such a file is available anywhere? And how to apply it?

You might try to force a resolution if EDID autodetection fails:

1 Like

I have the same issue with a second Pi5 which is connected to an LCD with a resolution of 1280x800. Ubuntu is locked into a 1920x1080 resolution and I have so far been unable to change it. Some of the things I tried include: disabling the cloud-init and trying various things, forcing the actual resolution in /boot/firmware/config.txt, trying xrandr which would not do anything. Other than this resolution issue, the second system works Ok but everything is VERY small.

The first system that I installed this on has a 1920x1080 LCD with HDMI audio which does not work. I have tried to configure this in /boot/firmware/config.txt but it didn't work. The audio setting in Control Panel does not find any audio device so the system is silent. Has anyone experienced this?

This is what I've found, but I found a workaround, which fixes most of the issues, but is admittedly a very heavy cludge, and that is to first Install an Armbian version (Armbian_23.11.3_Rpi5b_jammy_current_6.1.68_gnome_desktop.img.xz) then modify/update as needed, which at least gets to a workable solution, until a better version comes along...