UEFI Troubles, internal drive won't boot

My laptop HDD took a dump on me while i was attempting to copy it to a new drive due to issues that had been occurring. Halfway through the copy the source drive completely failed. Decided on MATE for the OS except I knew nothing about this UEFI at all and freaking erased it during the install. now i can only boot live because the laptop wont boot the internal drive at all. Any help with either getting the UEFI back or a way to boot up internal drive without it, thanks in advance!

Please clarify something for us - what do you want to do exactly?

  • Recover your data
  • Install Ubuntu MATE

Sorry for mot being more clear. I have installed MATE but before doing so I formated the whole drive as one partition giving up on my old files. I am having trouble booting the drive having removed the partitions that I now assume had the UEFI installed on it. Not looking for recovery of failed drive right now. new drive installed and i want laptop to be dedicated MATE machine now.

Seems like the system is expecting to load the UEFI but not finding the files. tried installing with different settings, even made a partition dedicated for the bootloader but nothing works. Keeps telling me there’s nothing to load.

During the partitioning step of the installer, when it proposes to “erase disk and install Ubuntu MATE”, you should pick that if you don’t need to have a specific partition layout.

If you want a specific layout you should first try and disable UEFI in your BIOS, see if you have a “legacy” mode and disable “secure boot”.

If you wanna stick with UEFI use something like the following partition layout (assuming 4Gigs of RAM):

/         ext4 40GB
          swap 4GB
/boot/efi ESP  250MB (EFI System Partition)
/home     ext4 <all remaining space>

See the UEFI section in the partition guide too!:

Erase disk and install worked like a charm, thank you so much. I was attempting a specific partition set up for recovering the old windows drive so i overlooked that option and after these issues with UEFI I was worried having erased the partitions with that stuff I would have to get them back.

Thank you both for your help in this matter!


Excellent news @Bain , I have marked @ouroumov’s answer as best answer solving your problem!. :smiley: